none
OOB Workflows [ Approval, Collect Feedback ] Missing on Workflow template form

    Question

  • Hi:

     

    One of my SharePoint site collection is missing the out of the box workflows [ Approval, Collect Feedback etc ].

     

    Solutions I have already tried

     

    1. Activated Workflows feature from Site Collection Features.

     

    2. Activated SharePoint 2007 Workflows Feature

     

     

    Thanks For your help

     

    Monday, June 27, 2011 10:00 PM

All replies

  • Hi,

    Please go to top site > site settings > site collection administration > workflows to check if all the workflow' status are active.

    If no, i think there are some issues about your sharepoint workflows feature. please create a new one to check the results.

    Regards,

    Seven


    Thursday, June 30, 2011 8:59 AM
  • Hi:

    Thanks for the response.

    Yes, All of my workflows are active.

    Note: This was a migration from SharePoint 2007

    Any help getting this resolved will be greatly appreciated.

     

    Thanks for your help.

    Thursday, June 30, 2011 4:13 PM
  • I have a SharePoint Server 2010 install that was migrated from 2007. It has the following site collection features pertaining to workflows:

    • Disposition Approval Workflow
    • Publishing Approval Workflow
    • SharePoint 2007 Workflows
    • Workflows

    I thought I was having the same issue as Tisson, but once I enabled them all the following workflows were available in to document libraries:

    • Disposition Approval
    • Three-state
    • Collect Signatures - SharePoint 2010
    • Approval - SharePoint 2010
    • Collect Feedback - SharePoint 2010
    • Publishing Approval
    Monday, July 18, 2011 9:41 PM
  • Did you have to restart the server or IIS to get them to appear or did it simple require activating the Workflows?
    Wednesday, July 20, 2011 2:06 PM
  • In my case, activating the workflow-related features was sufficient to get the workflows to appear. No iisreset was necessary. 
    Wednesday, July 20, 2011 2:09 PM
  • I also have a sharepoint 2010 farm and migrated many of my 2007 site collections across using the database attach method. I have gone into the Site Collection settings and activated all workflow items including the MOSS 2007 workflow items.

    My problem is that when I generate a new workflow from the existing OOB MOSS 2007 Approval workflow that was migrated across, I DO receive an email showing that the workflow was created but the approver DOES NOT receive an email notifiying them of the workflow task. I can create a workflow in the same library using the OOB Sharepoint 2010 workflow and everything works fine.

    Does anyone know what causes this and even more important, how can I fix it? We use the workflow history as an audit method and would hate to have to remove the MOSS 2007 Approval workflows as well as any comments in the history list.

     

    Tuesday, August 02, 2011 3:44 PM
  • Guys, please check this article - http://blogs.technet.com/b/vinitt/archive/2011/02/23/moss-2007-workflows-no-longer-available-visible-when-we-upgrade-from-2007-to-2010-database-attach-method.aspx if that helps:

    =============

     

    Syptom

    After upgrading the SharePoint 2007 Database via database attach method to SharePoint 2010 we might observe 

    · The 2007 Approval workflows were no longer available/Visible for users to create new workflows

    Cause

    · In SharePoint 2010 the 2007 workflows are there to allow any running workflows to complete, but by default creating new instances of the workflows is disabled as the expectations are that you will want to move forward to the SharePoint 2010 workflows.

     

    Resolution

    1- The following steps must be taken to enable 2007 workflows after upgrading to SharePoint 2010:

    · Go to Site Actions ->Site Settings->Site Collection Administration->Site collection features

    · Activate ‘SharePoint 2007 Workflows’

    · Remove ‘none’ from <AssociationCategories>none</AssociationCategories>

    · 14\template\features\ReviewWorkflows\Reviewapproval.xml

    · 14\template\features\ReviewWorkflows\ReviewFeedback.xml

    · 14\template\features\SignatureWorkflow\Signatures.xml

    · Associate Workflow

    · Go to Shared Documents, Library Settings, Add a Workflow

    · Select legacy Workflow.

     Note : Please take a back up of Reviewapproval.xml,ReviewFeedback.xml,Signatures.xml before doing the modification, the above solution is not verfied after we install any new update.. chances are there that these files might get replaced in future update.. please have a backup of working files as well.


    Amrita Talreja
    Tuesday, August 02, 2011 3:58 PM
  • Amrita,

    The article was interesting and I have read it before BUT It is not a resolution to my problem.

    As it stands right now, I can create a new workflow task from the migrated OOB MOSS 2007 Aproval Workflow. The approver, once they are aware of the newly created task, is able to approve the document and complete the task and all comments including those before the migration, are accessible.

    My problem is that when someone creates the new workflow task, the person assigned the task, does not receive a task notification email.

    The person creating the task gets a task creation email.

    The person assigned the task, the approver,  will get an email once they have completed the task idicating that it is complete.

    There must be a reason for not receiving the initial workflow task. Has anyone else had this problem? Has anyone figured out how to resolve this problem?

    Wednesday, August 03, 2011 4:09 PM
  • Hi Amrita Talreja,


    I've done all above steps as you sugessted still i can't able to see the default OOB workflows Approval ,Collect Feedback ,Collect Signatures in 2010 document libraries . understand with couple of ohter blogs before migration all workflows  has set to pause or completed ? please clarify me if yes i've already done migration from sharepoint 2007 to 2010  what would be the best Resolution ..

    Wednesday, October 12, 2011 8:59 AM
  • Same issue here, sharepoint 2007 db attach and upgrade to 2010.  I am opening a support case with MS now and will let you know if they come to a resolution.  All site collection features are enabled.

     

    Regards,

    Brian

    Thursday, October 20, 2011 5:16 PM
  • same issue guys.  any luck?
    Thursday, December 08, 2011 10:14 PM
  • Hi:

    One of my SharePoint site collection is missing the out of the box workflows [ Approval, Collect Feedback etc ].

    Solutions I have already tried

    1. Activated Workflows feature from Site Collection Features.

    2. Activated SharePoint 2007 Workflows Feature

    Thanks For your help

    Hi

    Is there any way to take the backup and restore for OOB workflows in the sharepoint document library or list? IF yes, how we can

    Suppose if a document Library attached with workflow(OOB) and it is saved a templete , will workflow able after restoring the library?

    Please suggest

    Thanks in advance


    Regards

    Tuesday, February 21, 2012 9:50 AM
  • Probably Late on this one but MS resolved my issue, the steps are below.  Pretty comical if you ask me...  Anyway, it worked for my environment.

    CASE RESOLUTION AGREEMENT:

    -----------------------------------------------------

    Once the out of box workflows appear on the SharePoint designer for the site https://sharepoint.com, we will consider this issue resolved and case to be closed. 

    Assessment:

    -----------------------------------

                    · Browsed to the site actions-> site settings-> site collection features

                    · Deactivated Workflows feature

                    · Re-Activated Workflows feature

                    · Went back to SharePoint Designer and selected Workflows in the left pane list, all the out of box workflows appeared .

    • Proposed as answer by BrianWDavis Thursday, June 28, 2012 11:46 PM
    Thursday, June 28, 2012 11:46 PM
  • I know this is a pretty old thread but I have just recently been having the same issue.

    We had upgraded from SP 2007 to SP 2010 also.

    I tried deactivating and activating the SharePoint 2007 Workflows and the OOB Workflows to no avail.

    I finally decided to use the SharePoint 2010 Management Shell. 

    I decativated the workflow settings using Site Settings/Site Collection Features and then, using SharePoint 2010 Management Shell, I ran the cmdlet Enable-SPFeature -Identity Workflows -URL http://siteURL and the SharePoint 2010 workflows Approval - SharePoint 2010, Collect Feedback - SharePoint 2010, Collect Signatures - SharePoint 2010 finally added to the site collection.

    Friday, September 21, 2012 5:50 PM