locked
Somase com intervalos de datas

    Pergunta


  • Problema.
    Baseado em uma coluna que contém datas, preciso somar os valores da coluna ao lado.
    Exemplo:

    Início Dias
    21/12/2005 10
    2/1/2006 3
    17/2/2006 4
    25/2/2006 4
    1/3/2006 2

    O que eu desejo: Somar os valores da coluna "Dias" se na coluna "Início" houver uma data igual ou inferior à outra que está em outra célula.

    Será que tem jeito isso?

    Obs: Todas as datas são variáveis.
    segunda-feira, 29 de outubro de 2007 18:42

Todas as Respostas

  • Frank use a somarproduto, conforme o exemplo abaixo:

     

    =SOMARPRODUTO(N(A2:A6<=D1);(B2:B6))

     

    A2:A6    SÃO AS DATAS

    D1         É ONDE VOCÊ COLOCA O CRITÉRIO DE SOMA

    B2:B6    SÃO OS VALORES QUE SERÃO SOMADOS

     

    Qualquer dúvida a mais é só perguntar; abraços

    LBARBOSA@SANEPAR.COM.BR

     

    segunda-feira, 29 de outubro de 2007 19:30
  • Ou assim:

    {=SOMA(SE((A2:A6<=D1);B2:B6;0))}

     

    Na maneira matricial.

     

    segunda-feira, 29 de outubro de 2007 19:35
  • Ah!

    Se a resposta atender sua necessidade, por favor marque como Respondida.

     

    Abraço

    terça-feira, 30 de outubro de 2007 09:08
  • Caro Leandro Barbosa ...

     

    Fantástico. Resolveu a minha vida (tanto uma como a outra).

    Aproveitando, te pergunto se você saberia onde encontrar material, de preferência free, para estudos iniciais sobre Fórmulas Matriciais (se não me engano, seu segundo exemplo).

     

    Abraços e obrigado novamente.

    terça-feira, 6 de novembro de 2007 15:56
  • Bom dia Frank,

    Olha só, seu desejo é o mesmo que o meu! rsrs

    Também procuro um material desses, o único confiável que achei é do Linha de Código, do guru Robert Marin

    esse você pode ter certeza que é bom, só que são oito módulos, e cada um custa R$ 10,00.

    Estou esperando uma folga no orçamento para comprar.

    O que eu tenho agora é uma planilha com algns exemplos der matriciais, baixei da web, se você quiser me manda um e-mail que ai te respondo com a planilha, é muito boa também.

    Ó: LRARBOSA@SANEPAR.COM.BR

    ABRAÇO

    quarta-feira, 7 de novembro de 2007 09:43