locked
somase com critério de data

    Pergunta

  • Ola, bom dia

    Minha questão é a seguinte, preciso fazer uma soma em que o critério para que ela se concretize é que as datas do intervalo sejam menores que a data de hoje, exemplo:


    A B C D E
    1 1/9/2007 1/10/2007 1/11/2007 1/12/2007 1/1/2008
    2 2 2 2 2 2

    =SOMASE(A1:E1;<HOJE();A2:E2)


    É isso que eu preciso, mas dessa forma a equação não funciona. O que eu fazendo errado??
    sexta-feira, 30 de novembro de 2007 13:13

Respostas

  • Use esta matricial:

    {=SOMA(SE((A1:E1<HOJE());A2:E2))}

     

    Escreva a fórmula e para fecha-la aperte ao mesmo tempo: CTRL+ SHIFT+ENTER

     

    Lembre-se que por ela ter a função hoje(), automticamente amanhã o valor da soma vai mudar.

     

    Marque como respondida por favor.

     

    abraços

    Leandro

    sexta-feira, 30 de novembro de 2007 14:39

Todas as Respostas

  • Use esta matricial:

    {=SOMA(SE((A1:E1<HOJE());A2:E2))}

     

    Escreva a fórmula e para fecha-la aperte ao mesmo tempo: CTRL+ SHIFT+ENTER

     

    Lembre-se que por ela ter a função hoje(), automticamente amanhã o valor da soma vai mudar.

     

    Marque como respondida por favor.

     

    abraços

    Leandro

    sexta-feira, 30 de novembro de 2007 14:39

  • Valeu Leandro, realmente funcionou.

    Que ninja esse negocio de CTRL+ SHIFT+ENTER... mas deu certo. Na verdade eu fiquei aqui fazendo uns teste e tb consegui tambem o mesmo resultado com a seguinte função:

    =SOMARPRODUTO(N(H38Surprise38<HOJE());(H73Surprise73))

    so para constar....

    Obrigado tenha um bom dia
    segunda-feira, 3 de dezembro de 2007 17:18