locked
Windows Live Sign In

    Question

  • Hi,

    I am currently setting up the Windows Live Messenger Web Toolkit into a website. I have the Messenger bar set up at the bottom of my page. When I attempt to sign in however I get a notification saying this...

    "Error message<input class="RichTooltip_Header_CloseIcon " src="http://img2.wlxrs.com/_D/F$Live.SiteContent.Messenger/3.70.54183/resources/images/transparent.gif" type="image" />
    There's a problem with this site and Messenger isn't working correctly. Please try again later."

    The Sign In process worked yesterday.

    Is this an error with my site or with the service itself? Sorry if this question has been asked/answered before. I'm a n00b and have only been trying this out for a few hours.

    Thanks!
    Jon

     

    Wednesday, July 21, 2010 9:01 AM

All replies

  • If you are using Messenger Web Toolkit, you should post in Windows Live Messenger Web APIs: Development forum.

     

    Assuming you are using <wl:bar> control of Messenger Connect, then one possible cause is callbackurl parameter being incorrect.

    The callbackurl parameter in <wl:app> tag should be something like:
    callbackurl="<%= ConfigurationManager.AppSettings["wl_wrap_client_callback"] + "?wl_session_id=" + Session.SessionID %>"

    Wednesday, July 21, 2010 9:46 AM
  • Apologies if this is in the wrong section.

    I am using the <msgr:bar> to display the bar at the bottom of the page.

    I am using the following to initialize the app :-

    <msgr:app 

            id="appTag" 

            application-verifier-token="<?php echo $wll->getAppVerifier(); ?>" 

            token-url="refreshmessengertoken.php"

            privacy-url="Privacy.html"

            channel-url="Channel.html">

    </msgr:app>

    There are two scripts in the <head> of the page : -

    <script type="text/javascript" src="http://www.wlmessenger.net/api/3.7/loader.js"></script>

     

    <script type="text/javascript">

    Microsoft.Live.Core.Loader.load(['messenger.ui.styles.core', 'messenger.ui']);    

     </script>

    Then some PHP above the DOCTYPE :-

    <?php

     

    //     Copyright (c) Microsoft Corporation.  All rights reserved.

     

    /** 

     * This is the main page for the

     * Windows Live Messenger Web Toolkit

     * Getting Started Sample.

     * 

     * EXTENSION LIBRARIES ARE REQUIRED, PLEASE CONFIGURE IN PHP.INI

     * - mhash module

     * - mcrypt module

     */

     

    // Load common settings. For more information, see Settings.php.

    include 'lib/settings.php';

    include 'lib/windowslivelogin.php';

     

    // Initialize the WindowsLiveLogin module.

    $wll = WindowsLiveLogin::initFromXml($KEYFILE);

    ?>

    I basically took the code from the samples .zip file I downloaded and put the code into my page where needed.

    Thanks for the help,

    Jon

    Wednesday, July 21, 2010 10:00 AM
  • Is this still reoccurring for you?

    Keiji

     

    Wednesday, July 21, 2010 6:24 PM
  • Yes it is still reoccurring. Not sure if I am doing something wrong?

     

    Thanks for the reply,

    Jon 

    Thursday, July 22, 2010 8:31 AM
  • Hi...

    I have a question for you JonPenny..

    Did you read and follow line by line the documentation for using the Messenger  API?

    I mean, Did you already get  the meesengerSecret, and then configurated the settings.php file with it?

    I ask you that bacaus e i'm also a newbie and all the problems I had to make the bar work were about messengerSecret and publishing the application in Azzure Services (If you don't know what i'm talking about you REALLY must read again the documentation about the API)

    Monday, August 09, 2010 2:16 AM