none
Pass-through query in access 2010

    Question

  • A pass-through delete query that i was using in windows xp pro, office access 2003 is not working in windows 7, 2010.  In windows 7, office 2010 I created the same DSN ODBC Connections that I had in 2003.  I re-linked the tables and they all work fine.  However, When i open the pass-through query in design mode and click "run" in 2010 the "Select Data Source" window opens.  I select the DSN, enter the SQL Server Login password and get the message "Pass-through query with ReturnsRecords property set to True did not return any records."  Can someone assist me with getting this working in windows 7, office access 2010.  Thank you.

    ilfo

     

    Thursday, March 10, 2011 12:40 AM

Answers

  • kmahone,

    The answer to your issue is directly in the message. Open your pass-thru query in design view and then select "Property Sheet". You will see a property named "Returns Records" this property defaults to YES - chenge it to NO and your error should disappear.

     


    Mark Burns, MCAD, MCP
    Sr. Microsoft Access Analyst/Developer
    Manager LinkedIn.Com community: Professional Microsoft Access Developers Network (PMADN)
    • Marked as answer by Bruce Song Monday, March 21, 2011 6:21 AM
    Thursday, March 10, 2011 1:33 AM

All replies

  • kmahone,

    The answer to your issue is directly in the message. Open your pass-thru query in design view and then select "Property Sheet". You will see a property named "Returns Records" this property defaults to YES - chenge it to NO and your error should disappear.

     


    Mark Burns, MCAD, MCP
    Sr. Microsoft Access Analyst/Developer
    Manager LinkedIn.Com community: Professional Microsoft Access Developers Network (PMADN)
    • Marked as answer by Bruce Song Monday, March 21, 2011 6:21 AM
    Thursday, March 10, 2011 1:33 AM
  • Is there a way to do this in code?

    the icon changes to a globe with a exclamation point when setting it manually.

    When setting it with cmd.properties it is wanting an index.  What is the correct syntax for using the index to set returns records = no


    Janine

    Wednesday, July 02, 2014 10:12 PM