none
SharePoint 2013 Office Web Apps Problem - Unable to Open/View/Edit

    Question

  • I am currently in the process of deploying our company SharePoint 2013 solution. I am having problems with regards to Office Web Apps, specifically I cannot get it to work. 

    Our infrastructure team set up the OWA Server and i have followed the instructions given here: http://technet.microsoft.com/en-us/library/ff431687.aspx

    However when I have completed the set up and try to create a document anywhere whithin SharePoint I get the following error messages:

    Word Document : "Sorry, there was a problem and we can't open this document. If this happens again, try opening the document in Microsoft Word."

    Excel Document: "We couldn't find the file you wanted. It's possible the file was renamed, moved or deleted"

    PowerPoint: "Sorry, we ran into a problem. Please try again"

    One Note:"Sorry, you don't have permission to edit this notebook."

    However after each of the above actions a document of the relevant type is created in the SharePoint library but I can then open the documents using the relevant client application.

    I have been trying to resolve this for several hours now with no success, does anyone have any ideas.

    Thanks in advance

    Monday, December 03, 2012 11:58 AM

Answers

  • @Fat Dragon,

    I solved my problem 1/2 hour ago (finally), after 5 cups of coffee, numerous cans of RedBull, and bag of Tylenol.  Hope this help your trouble shooting.

    Turned out on my Office Web App server, even thou everthing is mapped to HTTPS, external, etc.  I found an entry in the ULS said WOPI Check:

    Unexpected  WOPI Check, non-200 return [code:Forbidden, url:http://xyz.abc.com/_vti_bin/wopi.ashx/files/1f9e6f2832194eb5ab228baa04d7cca1] 780d8be3-6d3b-45ae-a4ad-b5356ceff424

    when I was trying to preview a PPTX file.  Doesn't make sense again, because all the blindings are set to use HTTPS.  I went in the SP2013 CA, dug up the Web Application's AAM.  I have the Default zone as HTTP, then an Extranet zone as HTTPS.  I flipped the Default zone to use HTTPS, and removed the Extranet zone (We all use HTTPS both in or out of the office anyway), and the Preview, Editing, everything started working magically.  So now I have all HTTPS settings, blindings, AllowOAuthOverHttp=false, everthing seems working.

    Not sure if my issue was related to the fact that I overwrote my New-OfficeWebAppsFarm with HTTPS over my prior HTTP, because if you did so the cmdlet have an warning message saying:

    "The cmdlet will overwrite the settings of the existing Office Web Apps Server farm and may result in unintende side-effects. Continue with this operation ?"

    Anyway, I can still see some BroadcastServicesWatchdog_Wfe checking my X.X.X.X:80 even after all SP2013 preview, editing are working.  I'm planning to put it aside first, and trouble shoot this again.  We seem to be on the forefront, there isn't much information anywhere on the web unforunately.

    Thursday, December 20, 2012 6:41 PM

All replies

  • Are you using http:// or https:// to access the Office Web Apps server?  I saw this kind of error regularly druing the beta if I forgot to set the SPWopiZone when using http.  See step #4 for configuring a test environment in the article.

    If you are using https:// I would check to make sure your SSL cert is working correctly.


    Paul Stork SharePoint Server
    MVP Principal Solutions Architect: BlueChip Consulting Group
    Blog: http://dontpapanic.com/blog
    Twitter: Follow @pstork
    Please remember to mark your question as "answered" if this solves your problem.

    Monday, December 03, 2012 12:56 PM
  • Paul thanks for your response, we are using https:// to access the server and my SPWopiZone is set to "external-https" which matches the settings I get when I run the Get-SPWopiBinding command on the Sharepoint server.

    I have tried various combinations of the setting but no differences are obsevered ??

    • Proposed as answer by AndreXR Monday, April 28, 2014 11:30 PM
    Monday, December 03, 2012 1:09 PM
  • This is what I can see in the ULS log on the OWA server that looks like it relates to the issues:

    12/03/2012 15:21:13.64 w3wp.exe (0x0D0C) 0x21D4 Office Web Apps WAC Hosting Interaction adhrj Monitorable HttpRequestAsync (WOPICheckFile,WACSERVER), request failure [HttpResponseCode:Unauthorized, HttpResponseCodeDescription:Unauthorized, url:http://xxxxSP2013Server/Test/_vti_bin/wopi.ashx/files/253dfae36c56469aa07473f04b6159b4?access_token=REDACTED_1074&access_token_ttl=1354584069207] b79825d0-fc27-409d-9413-5d9b335a0468
    12/03/2012 15:21:13.66 w3wp.exe (0x0D0C) 0x21D4 Office Web Apps WAC Hosting Interaction adhrr Medium HttpRequestAsync (WOPICheckFile,WACSERVER) Setting Completion [Time in ms: 1905, Bytes Read: 0] b79825d0-fc27-409d-9413-5d9b335a0468
    12/03/2012 15:21:13.66 w3wp.exe (0x0D0C) 0x21D4 Office Web Apps WAC Hosting Interaction ajdv9 Medium HttpRequestAsync (WOPICheckFile,WACSERVER) SetCompletion Track start | setting trackers | WebRequest.Create() | Create() returned | _req.ContentLength 0 | setting request headers | setting user agent | setting keep alive | setting timeout callback | Start calling StartResponseProcessing | StartResponseProcessing._req.BeginGetResponse() | BeginGetResponse() returned | StartResponseProcessing RETURNS | Start RETURNS | End.AsyncWaitHandle.WaitOne() | GetResponseCallback isSync:False | _req.EndGetResponse() | GetResponseCallback WebException | RecordWebException | RecordResponse Unauthorized | SetCompletion False | b79825d0-fc27-409d-9413-5d9b335a0468
    12/03/2012 15:21:13.67 w3wp.exe (0x0D0C) 0x1D54 Office Web Apps WAC Hosting Interaction ag7m6 Medium WOPI Http Request Completed [host machine name:, version:, host correlation:] b79825d0-fc27-409d-9413-5d9b335a0468
    12/03/2012 15:21:13.67 w3wp.exe (0x0D0C) 0x1D54 Office Web Apps WAC Hosting Interaction adhr1 Medium WOPICheckFile,WACSERVER Unauthorized [url:http://xxxxSP2013Server/Test/_vti_bin/wopi.ashx/files/253dfae36c56469aa07473f04b6159b4?access_token=REDACTED_1074&access_token_ttl=1354584069207, host correlation:] b79825d0-fc27-409d-9413-5d9b335a0468
    12/03/2012 15:21:13.72 w3wp.exe (0x0D0C) 0x1D54 Services Infrastructure Services Infrastructure Logging m9y9 Medium Updating the event log properties triggered a SecurityException. b79825d0-fc27-409d-9413-5d9b335a0468
    12/03/2012 15:21:13.72 w3wp.exe (0x0D0C) 0x1D54 Office Web Apps WAC Hosting Interaction 00000 Medium Request http://xxxxSP2013Server/Test/_vti_bin/wopi.ashx/files/253dfae36c56469aa07473f04b6159b4 failed with 401 error but we will not retry. [file source: WACSERVER] b79825d0-fc27-409d-9413-5d9b335a0468
    12/03/2012 15:21:13.72 w3wp.exe (0x0D0C) 0x1D54 Office Web Apps WAC Hosting Interaction adhsk Unexpected WOPI CheckFile: Catch-All Failure [exception:Microsoft.Office.Web.Common.EnvironmentAdapters.FileUnknownException: WOPI 401     at Microsoft.Office.Web.Apps.Common.WopiDocument.LogAndThrowWireException(HttpRequestAsyncResult result, HttpRequestAsyncException delayedException)     at Microsoft.Office.Web.Apps.Common.HttpRequestAsync.End()     at Microsoft.Office.Web.Apps.Common.WopiDocument.GetWopiRequestResultWithRetry(Int32 maxSize, MemoryStream ms, WopiRequest wopiRequest)     at Microsoft.Office.Web.Apps.Common.WopiDocument.CheckWopiFile()] b79825d0-fc27-409d-9413-5d9b335a0468
    12/03/2012 15:21:13.72 w3wp.exe (0x0D0C) 0x1D54 Office Web Apps WAC Hosting Interaction ajjve Medium WOPI CheckFile: Catch-All Failure [url:http://xxxxSP2013Server/Test/_vti_bin/wopi.ashx/files/253dfae36c56469aa07473f04b6159b4] b79825d0-fc27-409d-9413-5d9b335a0468
    12/03/2012 15:21:13.74 w3wp.exe (0x0D0C) 0x1D54 Excel Web App Excel Calculation Services ad9nt Medium ServiceHost.GetDocumentHostInfo: Caught an exception while retrieving base doc, e: Microsoft.Office.Excel.Server.Host.HostFileException ---> Microsoft.Office.Web.Common.EnvironmentAdapters.FileUnknownException: WOPI Check File     at Microsoft.Office.Web.Apps.Common.WopiDocument.CheckWopiFile()     at Microsoft.Office.Excel.Server.ServiceHost.ServiceHostLoader.GetCheckedBaseDocument(String querySignature, BaseUser baseUser, String canary, Boolean shouldCheckCanary, ScenarioRestrictions restriction)     --- End of inner exception stack trace ---     at Microsoft.Office.Excel.Server.ServiceHost.ServiceHostLoader.GetCheckedBaseDocument(String querySignature, BaseUser baseUser, String canary, Boolean shouldCheckCanary, ScenarioRestrictions restriction)     at Microsoft.Office.Excel.Server.ServiceHost.ServiceHost.GetCheckedBaseDocument(String uri, String canary, Boolean shouldValidateCanary, Byte[] documentProperties, ScenarioRestrictions restriction), type FileOpenNotFound b79825d0-fc27-409d-9413-5d9b335a0468
    12/03/2012 15:21:13.74 w3wp.exe (0x0D0C) 0x1D54 Excel Web App Browser bdke Medium Utils.ExecuteWebEventHandler: An exception occured Microsoft.Office.Excel.WebUI.ExcelWebRendererException: We couldn't find the file you wanted. ---> Microsoft.Office.Excel.Server.CalculationServer.Proxy.ServerSessionException: We couldn't find the file you wanted. ---> Microsoft.Office.Excel.Server.Host.HostFileException ---> Microsoft.Office.Web.Common.EnvironmentAdapters.FileUnknownException: WOPI Check File     at Microsoft.Office.Web.Apps.Common.WopiDocument.CheckWopiFile()     at Microsoft.Office.Excel.Server.ServiceHost.ServiceHostLoader.GetCheckedBaseDocument(String querySignature, BaseUser baseUser, String canary, Boolean shouldCheckCanary, ScenarioRestrictions restriction)     --- End of inner exception stack trace ---     at Microsoft.Office.Excel.Server.ServiceHost.ServiceHostLoader.GetCheckedBaseDocument(String querySignature, BaseUser baseUser, String canary, Boolean shouldCheckCanary, ScenarioRestrictions restriction)     at Microsoft.Office.Excel.Server.ServiceHost.ServiceHost.GetCheckedBaseDocument(String uri, String canary, Boolean shouldValidateCanary, Byte[] documentProperties, ScenarioRestrictions restriction)     at Microsoft.Office.Excel.Server.ServiceHost.ServiceHost.Microsoft.Office.Excel.Server.Host.IEwaHost.GetDocumentHostInfo(String uri, String canary, Boolean shouldValidateCanary, Byte[] documentProperties, Boolean isGenerated, ScenarioRestrictions restriction)     at Microsoft.Office.Excel.WebUI.EwaState.EnsureDocumentHostInfo()     --- End of inner exception stack trace ---     at Microsoft.Office.Excel.WebUI.EwaState.EnsureDocumentHostInfo()     at Microsoft.Office.Excel.WebUI.EwaState.OpenWorkbook()     --- End of inner exception stack trace ---     at Microsoft.Office.Excel.WebUI.EwaState.OpenWorkbook()     at Microsoft.Office.Excel.WebUI.Utils.ExecuteWebEventHandler(CoreWebEventHandler coreWebEventHandler, CoreWebEventHandler baseClassHandler, Object param, IMainControl mainControl) b79825d0-fc27-409d-9413-5d9b335a0468
    12/03/2012 15:21:14.14 w3wp.exe (0x0D0C) 0x1D54 Excel Web App Browser 3k9g Medium InternalEwr.RenderWebPart: Finished rendering internal EWR b79825d0-fc27-409d-9413-5d9b335a0468
    12/03/2012 15:21:14.16 w3wp.exe (0x0D0C) 0x1D54 Office Web Apps Office Web Apps common af46w Medium WACServer HttpModule: Completed request with status code [200] b79825d0-fc27-409d-9413-5d9b335a0468

    Monday, December 03, 2012 3:44 PM
  • Hi guys,
    I'm getting the exact same problem with Office 365.

    Word Document : "Sorry, there was a problem and we can't open this document. If this happens again, try opening the document in Microsoft Word."

    Excel Document: "We couldn't find the file you wanted. It's possible the file was renamed, moved or deleted"

    PowerPoint: "Sorry, we ran into a problem. Please try again"

    I didn't try One Note, but the smart money is on the same error message.

    Happens on Chrome, Firefox and IE 9.
    The documents links use http and the site we're using is http://mobusol.sharepoint.com/
    Thanks to anybody who can help.

    Wednesday, December 05, 2012 4:16 AM
  • Not sure if this will help, but I recently encountered a very similar issue. The following fixed it for me.

    Found the info here (http://www.ntsystems.it/post/Office-2013-Web-Apps.aspx):

    if you are using https on your SharePoint web applications you should be ready to go. If you are using http for SharePoint you need to set AllowOAuthOverHttp to true. This needs to be done in the SharePoint Management Shell using the following commands:

    $config = (Get-SPSecurityTokenServiceConfig)

    $config.AllowOAuthOverHttp = $true

    $config.Update()

    Now I'm stuck on having the web apps server render office doc previews in Exchange 2013 OWA... so convoluted!

    Paul

    • Proposed as answer by RoyJoyson Friday, February 22, 2013 5:15 PM
    Wednesday, December 05, 2012 1:44 PM
  • Hi,

    I have the same problem, i can create a new document on my sharepoint library, Word Web App create the new document, I can work it, I saved him, but as soon as I ve re-open, it puts the message:

    Sorry Word Web App ran into a problem opening this document etc... I use HTTP, and i have allready setup the spsecuritytokenServiceConfig to HTTP, i have allready activated the license based on user, and configured the OpenFromUrlEnabled to true. But same result, the webapp is claim based and not https configured.

    Any idee ?


    Fred
    • Edited by ITCentre Wednesday, December 05, 2012 3:08 PM
    Wednesday, December 05, 2012 3:08 PM
  • Fred I currently have an outstanding call with Microsoft on this one, currently they think it may be a problem with the Cache configuration that web apps moves a document to before opening, ours is currently timing out.

    Microsoft are coming back to me today at 11:00am BST to test a fix, I will report back the results.

    Tuesday, December 11, 2012 10:23 AM
  • Geoff, any updates from your support call?
    Thursday, December 13, 2012 4:59 PM
  • No still trying to fix with Microsoft and not getting anywhere fast!!
    Thursday, December 13, 2012 6:36 PM
  • The very same issue in my case. I've tried three times with clean install of Office Web Apps Server 2013, and the result is the same. Twice I've tried with Office Web Apps Preview, and in the third attempt I've installed RTM from MSDN - and again the same result.

    The certificate is issued by my internal PKI (enterprise CA), contains SAN record with FQDN of Office Web Apps server, and https://owa.domain.com/hosting/discovery opens discovery XML without reporting any issues with the certificate.

    I do have preview with Exchange 2013, but I can't get it work with SharePoint 2013 (Preview).

    When I try to preview Word document I've upload manually I get "Sorry, there was a problem and we can't open this document. If this happens again, try opening the document in Microsoft Word"

    When I try to preview Excel document I've uploaded manually I get "Sorry, we're having problems showing this workbook. Details: Something is preventing us from opening the workbook. It might be blocked for security reasons."

    When I try to create the new Word document I'm getting "Sorry, there was a problem and we can't open this document. If this happens again, try opening the document in Microsoft Word." But the new documents remains on the list of documents, and can be downloaded, but when I try to open downloaded version in Word I'm getting "We're sorry. We can't open documentname.docx because we found a problem with its contents."

    When I try to create the new Excel document I'm getting "We couldn't find the file you wanted. It's possible the file was renamed, moved or deleted." Again, the new workbook remains in the document list, and can be downloaded. This time MS Excel can open downloaded document - which is of course blank workbook.

    Any help will be appreciated.

    Thanks


    Aleksandar

    Saturday, December 15, 2012 2:25 PM
  • "Microsoft Office Web Apps" event log logs following errors when I try to open Word document uploaded to SharePoint 2013 document collection, using Office Web Apps 2013:

    BroadcastServicesWatchdog_Wfe reported status for BroadcastServices_Host in category 'BroadcastWfeRedirect'. Reported status: Exception when checking /default.aspx: System.Net.WebException: Unable to connect to the remote server ---> System.Net.Sockets.SocketException: No connection could be made because the target machine actively refused it 10.0.10.15:80
       at System.Net.Sockets.Socket.DoConnect(EndPoint endPointSnapshot, SocketAddress socketAddress)
       at System.Net.ServicePoint.ConnectSocketInternal(Boolean connectFailure, Socket s4, Socket s6, Socket& socket, IPAddress& address, ConnectSocketState state, IAsyncResult asyncResult, Exception& exception)
       --- End of inner exception stack trace ---
       at System.Net.HttpWebRequest.GetResponse()
       at Microsoft.Office.Web.Common.WatchdogHelper.CheckWfeRedirect(ServiceInstance instance, Int16 category, String categoryName)

    ---------------------------------------------------------------------------------

    BroadcastServicesWatchdog_Wfe reported status for BroadcastServices_Host in category '2'. Reported status: Contacting the GetData.ashx web service failed with an exception: Unable to connect to the remote server

    ---------------------------------------------------------------------------------

    BroadcastServicesWatchdog_Wfe reported status for BroadcastServices_Host in category '1'. Reported status: Contacting the PutData.ashx web service failed with an exception: Unable to connect to the remote server

    ---------------------------------------------------------------------------------

    BroadcastServicesWatchdog_Wfe reported status for BroadcastServices_Host in category '3'. Reported status: Contacting Participant.svc failed with an exception: Unable to connect to the remote server

    ---------------------------------------------------------------------------------

    BroadcastServicesWatchdog_Wfe reported status for BroadcastServices_Host in category '4'. Reported status: Contacting Present_2_0.asmx failed with an exception: There was no endpoint listening at http://[owaservername]/m/Present_2_0.asmx that could accept the message. This is often caused by an incorrect address or SOAP action. See InnerException, if present, for more details.

    ---------------------------------------------------------------------------------

    Bing and Google have never heard about BroadcastServicesWatchdog_Wfe. Maybe I'm the only guy on the world who is experiencing this error? :)

    Please help!

    Thanks


    Aleksandar

    Saturday, December 15, 2012 2:45 PM
  • One thing I've noticed which may be the lead:

    As you can see in my comment above there some connection issues. 

    1. There is "...System.Net.Sockets.SocketException: No connection could be made because the target machine actively refused it 10.0.10.15:80". 10.0.10.15 is LAN address of my Office Web Apps Server. My question is why port 80? There's even no listener in IIS on port 80. (My Office Web Apps Farm is configured to use HTTPS.)
    2. Similar thing with third log from my comment above: "...There was no endpoint listening at http://[owaservername]/m/Present_2_0.asmx that could accept the message." As I've already said - there's really no listening endpoint on port 80. Question is why this "watchdog" tries to get such endpoint???

    I hope it'll be helpful for guys who knows how to handle it.

    Thanks!


    Aleksandar

    Saturday, December 15, 2012 3:21 PM
  • And more issues. When I try to open http://[owaservername]/m/Present_2_0.asmx I don't get anything because, as I've already said, there's no listening endpoint on port 80. But when I try to open the same URL with https prefix - I'm getting "Server Error in '/m' Application". Event log shows ASP.NET 4 warning about "A configuration error has occured", Exception message: "Could not load file or assembly 'Microsoft.Build.Utilities, Version=2.0.0.0, Culture..."

    I've checked web.config file from C:\Program Files\Microsoft Office Web Apps\BroadcastServices_Host, and there is:

    add assembly="Microsoft.Build.Utilities, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"

    Problem may be in version 2.0? I don't have .NET framework 2.0 installed because neither one is mentioned in software requirements at  http://technet.microsoft.com/en-us/library/jj219435.aspx.

    Is framework 2.0 or 3.5 is needed? Or I'm missing something...


    Aleksandar

    Saturday, December 15, 2012 4:22 PM
  • I have the same issue also.  Just got the WAC & SP2013 setup and seeing flood of watchdog errors in the Event Log checking my port X.X.X.X:80.  I have mine set on external-HTTPS.  The only setup I might have messed up was I had it on HTTP prior when I setup the WAC farm the first time because we were waiting for the cert to be purchased.  So I tested it with HTTP first, and now overwritting the WAC farm to use HTTPS instead.

    The only way now I can get it to work (even both SP2013 & WAC box are set to HTTPS) is by enabling that

    $config = (Get-SPSecurityTokenServiceConfig)

    $config.AllowOAuthOverHttp = $true

    $config.Update()

    Then everything will work, which doesn't make sense and I am still trying to trouble shoot this and hopefully I don't have to set AllowOAuthOverHttp, nor format the WAC box. ;(

    Thursday, December 20, 2012 5:01 PM
  • @Fat Dragon,

    I solved my problem 1/2 hour ago (finally), after 5 cups of coffee, numerous cans of RedBull, and bag of Tylenol.  Hope this help your trouble shooting.

    Turned out on my Office Web App server, even thou everthing is mapped to HTTPS, external, etc.  I found an entry in the ULS said WOPI Check:

    Unexpected  WOPI Check, non-200 return [code:Forbidden, url:http://xyz.abc.com/_vti_bin/wopi.ashx/files/1f9e6f2832194eb5ab228baa04d7cca1] 780d8be3-6d3b-45ae-a4ad-b5356ceff424

    when I was trying to preview a PPTX file.  Doesn't make sense again, because all the blindings are set to use HTTPS.  I went in the SP2013 CA, dug up the Web Application's AAM.  I have the Default zone as HTTP, then an Extranet zone as HTTPS.  I flipped the Default zone to use HTTPS, and removed the Extranet zone (We all use HTTPS both in or out of the office anyway), and the Preview, Editing, everything started working magically.  So now I have all HTTPS settings, blindings, AllowOAuthOverHttp=false, everthing seems working.

    Not sure if my issue was related to the fact that I overwrote my New-OfficeWebAppsFarm with HTTPS over my prior HTTP, because if you did so the cmdlet have an warning message saying:

    "The cmdlet will overwrite the settings of the existing Office Web Apps Server farm and may result in unintende side-effects. Continue with this operation ?"

    Anyway, I can still see some BroadcastServicesWatchdog_Wfe checking my X.X.X.X:80 even after all SP2013 preview, editing are working.  I'm planning to put it aside first, and trouble shoot this again.  We seem to be on the forefront, there isn't much information anywhere on the web unforunately.

    Thursday, December 20, 2012 6:41 PM
  • Yes, changing Default zone to https resolved the issue. Now I'm able to preview/edit office docs using Office Web Apps and SharePoint 2013.

    Thanks GorZilla!

    Office Web Apps development team should check what's going on with bunch of annoying watchdog errors in logs.

    And documentation should be improved a lot.


    Aleksandar

    • Proposed as answer by Puddy_Tat9999 Wednesday, June 12, 2013 9:24 AM
    Friday, December 21, 2012 2:17 AM
  • Thanks GORzilla I've been watching this post for a week with exactly the same problem and not a lot of time, I followed your tip and its working perfectly now. Excellent work

    Regards

    Ian


    iansn


    • Edited by iansn Friday, December 21, 2012 11:15 AM
    Friday, December 21, 2012 11:15 AM
  • Btw. be careful with coffee, RedBull, Tylenol and stuff like this. Liver can lead you to much worst problems than any MS Server, believe me...

    ;-)


    Aleksandar

    Friday, December 21, 2012 10:24 PM
  • "The candle that burns twice as bright, burns half as long." - Dr. Eldon Tyrell. 

    You just need to get your priority straight Fat Dragon. ;)  I was just joking about the amount of those intakes.

    Monday, December 24, 2012 4:14 PM
  • Thanks, GorZilla, this solved the problem for me too! :-)
    Monday, January 28, 2013 5:57 PM
  • If your SharePoint site is not registered in DNS, you will need a host file entry on the Office Web App Server. I noticed this the hard way. I like to build everything out before the DNS entries are added.
    • Proposed as answer by CheekPouch Wednesday, October 09, 2013 12:03 PM
    Monday, February 18, 2013 12:36 AM
  • I found that this works but then sharepoint then starts to use the internal url to the wopiframe and typically fails for external users. I found my issue was I created the bind between the sharepoint server and office web apps server using my external OWA server instead of the internal OWA server address. removing the bind and creating a new bind using the internal OWA resolved this issue and search started to use the external url to the wopiframe.  
    Monday, February 18, 2013 9:27 PM
  • I believe that the best way is to use split-DNS and to have the same dns names internally and externally. Doing so you'll always avoid such issues, and also make things easier for TMG (or other reverse proxy) because there'll be less work for URL rewriting.

    Fat Dragon

    Tuesday, February 19, 2013 12:29 AM
  • Hi Guys

    I have been having the excact same problem. I am using http on my internal sharepoint sites, but have set up https connection to the OWA server.

    When i try opening office documents i get the same errors, and if i create new , the error shows and a file is created.

    I guess flipping the AAM will not help for me as all my Sharepoint IIS bindings are http ?

    best regards

    Bjorn

    Wednesday, March 06, 2013 10:45 AM
  • I was stuck with the same issue.

    I installed twice the Office Webapps setup and perform again and again the same powershell commands.

    Without any success. Indeed.

    When I look at the ULS, I also had the same errors :

    WOPI CheckFile: Catch-All Failure [exception:Microsoft.Office.Web.Common.EnvironmentAdapters.FileUnknownException: WOPI 404    

    WOPI CheckFile: Catch-All Failure [url:http://mymachine/_vti_bin/wopi.ashx/files/36582336bf2c409c93a168addc84703d]

    After a pint of black coffee, I was pretty sure that the OWA server was unable to reach http://mymachine because of the domain was missing and the infrastructure is not ajusted to Microsoft Solution (go to hell reverse proxy) and no, ping the SP from OWA server and ping the OWA from SP is not enought (that was my first error).

    Anyway, I try to change the AAM for "default" zone, with  the name of the webapp with the domain name.


    I moved it from http://mySPmachine to http://mySPmachine.mydomain.com and few minutes later (and after an iisreset) it was working.

    Additional advice, don't try to open an existing Word document, there is something weird with it.

    I recreate Word, Excel, Powerpoint files and try to open and edit them in Office WebApps, and "Magie", it was finally working.


    By the way, don't forget to run the commandlet New-OfficeWebAppsHost –Domain “mydomain.com” on the OWA Server.

    So be sure that your OWA server is able to reach SP2013 Server, and no, ping is not enought (that what I thought first).

    So, please, don't waste time and check your AAM.

    Regards,

    Julie
    Lesson learned : It's always the AAM !

    Friday, April 26, 2013 9:05 AM
  • Fat Dragon,

    Thanks for the info, however it doesn't resolve my problem although I am getting the same errors you described. Here are the steps I followed:

    1. Open CA
    2. Go to App Management
    3. Select Configure Alt. Access Mapping

    Once there I have one entry; Http://sharepointsrv (example) Zone = Default. There are no other zones except the CA site and zone.

    When I change the application url from http to Https://sharepointsrv and save the change, none of my SharePoint test sites (2) work. If I flip it back to http:// they work fine.

    What am I missing here?

    jr

     

    Friday, May 24, 2013 11:48 PM
  • Hi,

    i have this problem too.

    My sharepoint webapp's default zone url is configured to https.

    In my domain i use split brain dns. Therefore i configured the same url for internal and external.

    The owa url is also configured to use ssl (we are using a public wildcard certificate)

    I added the sharepoint webapp hostheader domain to the allowed list of the office webapp server. I even installed the latest owa update.

    in the uls log of my owa server i'm getting a 401 unauthorized error (WOPI CheckFile: Catch-All Failure [exception:Microsoft.Office.Web.Common.EnvironmentAdapters.FileUnknownException: WOPI 401)

    I don't know why this does not work...

    Monday, May 27, 2013 11:35 AM
  • @Fat Dragon,

    I solved my problem 1/2 hour ago (finally), after 5 cups of coffee, numerous cans of RedBull, and bag of Tylenol.  Hope this help your trouble shooting.

    Turned out on my Office Web App server, even thou everthing is mapped to HTTPS, external, etc.  I found an entry in the ULS said WOPI Check:

    Unexpected  WOPI Check, non-200 return [code:Forbidden, url:http://xyz.abc.com/_vti_bin/wopi.ashx/files/1f9e6f2832194eb5ab228baa04d7cca1] 780d8be3-6d3b-45ae-a4ad-b5356ceff424

    when I was trying to preview a PPTX file.  Doesn't make sense again, because all the blindings are set to use HTTPS.  I went in the SP2013 CA, dug up the Web Application's AAM.  I have the Default zone as HTTP, then an Extranet zone as HTTPS.  I flipped the Default zone to use HTTPS, and removed the Extranet zone (We all use HTTPS both in or out of the office anyway), and the Preview, Editing, everything started working magically.  So now I have all HTTPS settings, blindings, AllowOAuthOverHttp=false, everthing seems working.

    Not sure if my issue was related to the fact that I overwrote my New-OfficeWebAppsFarm with HTTPS over my prior HTTP, because if you did so the cmdlet have an warning message saying:

    "The cmdlet will overwrite the settings of the existing Office Web Apps Server farm and may result in unintende side-effects. Continue with this operation ?"

    Anyway, I can still see some BroadcastServicesWatchdog_Wfe checking my X.X.X.X:80 even after all SP2013 preview, editing are working.  I'm planning to put it aside first, and trouble shoot this again.  We seem to be on the forefront, there isn't much information anywhere on the web unforunately.


    This worked for me :)
    Monday, June 03, 2013 11:58 AM
  • Spurr82, unfortunately this doesn't work for me. I have configured the default zone url with ssl, but I'm still getting the error.

    Monday, June 03, 2013 12:10 PM
  • No still trying to fix with Microsoft and not getting anywhere fast!!

    Did you get this resolved?

    I am in the same boat.

    On SP2013 Foundation, HTTP.

    I have ensured that AllowOAuthOverHttp is true on my SP SVR.

    Thursday, June 06, 2013 9:30 PM
  • I tried to reproduce the error in a test sharepoint 2013 farm and a separate WAC Server (both RTM).

    Both servers RTM - result: Office document preview inside the browser works

    Installed march 2013 public update on sps - result: 401 error on WAC server

    Installed april 2013 cu on sps - result: still 401 error on WAC server

    It seems that with the march 2013 pu something changed on the sharepoint side...

    On the sharepoint server following error gets logged

    Application error when access /_vti_bin/wopi.ashx, Error=Method not found: 'System.String Microsoft.SharePoint.Utilities.SPUtilityInternal.GetSharingUrl(Microsoft.SharePoint.SPWeb, System.Guid, Int32)'.

    • Edited by gojo119 Tuesday, June 11, 2013 11:55 AM additional information
    Tuesday, June 11, 2013 10:53 AM
  • So this worked for me thanks!
    Wednesday, June 12, 2013 9:24 AM
  • I have the same problem, and i read all above. finally i solve it. because we all forgot to change the AllowOAuthOverHttp setting in SharePoint 2013 to true. so only set the AAM to https can solve the problem.

    the follow are from the technet. i copy it.

    Step 5: Change the AllowOAuthOverHttp setting in SharePoint 2013 to True

    To use Office Web Apps withSharePoint 2013 over HTTP in a test environment, you must set AllowOAuthOverHttp to True . Otherwise Office Web Apps will not work. You can check the current status by running the following example:

    (Get-SPSecurityTokenServiceConfig).AllowOAuthOverHttp
    

    If this command returns False , run the following commands to set this to True .

    $config = (Get-SPSecurityTokenServiceConfig)
    
    $config.AllowOAuthOverHttp = $true
    
    $config.Update()
    

    Run the following command again to verify that the AllowOAuthOverHttp setting is now set to True .

    Monday, June 24, 2013 10:09 AM
  • Hi,

    i changed the AllowOAuthOverHttp setting to true without any success. The office web apps still didn't bring up any content.

    I started a microsoft support call. As soon as i get a solution i will post it here.

    Monday, June 24, 2013 1:24 PM
  • FYI, I also got this error.  Opened support case with Microsoft and it turns out the Office Web apps server name must be 15 characters or less (NetBIOS restriction).  After we renamed the server and issued New-OfficeWebAppsFarm command again and re-reran the steps to tell sharepoint 2013 to point to the new office web apps server name things worked correctly.

    Bottom line: Office web apps server name must be 15 characters or less. 

    We did not test registering the office web apps server with a FQDN however, that may have also solved it.  Not sure at this point.

    Monday, July 08, 2013 8:43 PM
  • I solved the same troubles by doing following (I have 1 internal zone with SSL, so don't need to set AllowOAuthOverHttp=true):

    1) Remove current binding on SP server:

    Remove-SPWOPIBinding –All:$true

    2) Then enroll new certificate for Office Web Apps server, using Computer cert template, double check that Subject field equal server FQDN. And Subject Alternative Name (DNS Name) equals FQDN too. I add even IP address to certificate.

    3) Then run again WA Farm creation with InternalURL equals ExternalURL (though i have 1 internal default zone with SSL):

    New-OfficeWebAppsFarm -InternalUrl "https://server.contoso.com" -ExternalUrl "https://server.contoso.com" -CertificateName "OfficeWebApps Certificate"

    4) And finally set zone on SP server and create default binding with server name like -ExternalUrl without https://:

    New-SPWOPIBinding -ServerName server.contoso.com
    Set-SPWOPIZone –zone "external-https"
    iisreset /noforce
    

    And got it works!

    So, double check your cert and try to use both zones Internal=External.

    • Proposed as answer by lehus pohus Thursday, September 26, 2013 4:33 AM
    • Unproposed as answer by lehus pohus Thursday, September 26, 2013 4:34 AM
    Wednesday, September 25, 2013 6:04 PM
  • Just to clarify.  Office Web Apps only uses one zone.  If you only have Internal users then you should use the internal zone.  If you have both internal and external users then you need to setup for the external zone, but all users will actually use the external zone to access the system, even if you setup the internal zone to be different.  You can't use both zones.

    Paul Stork SharePoint Server MVP
    Principal Architect: Blue Chip Consulting Group
    Blog: http://dontpapanic.com/blog
    Twitter: Follow @pstork
    Please remember to mark your question as "answered" if this solves your problem.

    Thursday, September 26, 2013 12:08 PM
  • I have the same problem that "SharePoint 2013 Office Web Apps Problem - Unable to Open/View/Edit". I'm using http for sharepoint and office web apps. However, the AllowOAuthOverHttp is still False after I using the commands as Administrator in the Sharepoint server.

    $config = (Get-SPSecurityTokenServiceConfig)

    $config.AllowOAuthOverHttp = $true

    $config.Update()

    Do you have any idear about it?

    Wednesday, October 09, 2013 4:18 AM
  • Hi,

    I am having similar problem, but my problem is i can't even get the http://mywebsite.com/hosting/discovery XML page, which should be created right after the OfficeWebAppsFarm creation command in the OWA server.

    All i get is error "404 Not Found"...Thus, i can't even proceed with binding as there is nothing to Bind to in the Sharepoint Server.

    I have read almost every blog in existance  about this and there was very little mentioned about "404 Not Found" other than both Sharepoint and OWA server must be in the DNS entry list. I have already confirmed both server are in our Active Directory DNS list.

    Right now, i am only trying using HTTP (was trying HTTPS previously, but same thing).

    Any help please? I am desperate....

    Thank you!

    Wednesday, April 02, 2014 8:19 AM
  • Sorry for asking you that GMD_1 but can you check if

    1. on the Office Webapps Server the IIS App Pool and the IIS Website are running correctly (site or pool are not in stopped state)
    2. In the bindings you have specified a ssl certificate (in case of https)
    3. you have configured any Proxy in the browser where you try to open http://mywebsite.com/hosting/discovery

    Otherwise i suggest to execute the new-officewebappsfarm again.

    Wednesday, April 02, 2014 9:02 AM
  • Hi gojo119,

    Thanks for your reply.

    1. All the services from app and site are started.

    2. There are no bindings of ssl certificate (i am only trying to create for HTTP).

    3. Not sure how to check this, but it's a new test installations. I haven't setup anything special. If i access from a client PC, i also get the same "404 Not found" message.


    I have tried re-install and run/remove new-officewebappsfarm for countless times...the same results.

    :(

    =========

    Update:

    I think i'd done something wrong. I was checking the hosting/discovery using the Sharepoint server address! 

    http://<mysharepointserver.com>/hosting/discovery

    instead of

    http://<myOWAserver>/hosting/discovery

    So, after i put in http://<myOWAServer>/hosting/discovery, i can see an XML page.

    I am suppose to test using the OWA server and not the Sharpoit server right?

    Now, i have done the WOPI binding on the Sharepoint, but i still can't get the preview. Instead i get Error 404 (Word file) and Error 500 (Excel file).

    I have followed the advice here as well to fix the 500 error, but no go.

    http://technet.microsoft.com/en-us/library/jj219455.aspx

    • Edited by GMD_1 Thursday, April 03, 2014 8:27 AM edit
    Thursday, April 03, 2014 2:47 AM
  • Thanks CheekPouch - I was looking in completely the wrong direction until I saw your post.

    Thursday, May 01, 2014 9:43 AM
  • AAM settings helped. We are using OWA via F5. Used to put the SharePoint 2013 web app URL in the Office Web App host file to make it to work. But now I can remove the host file entry and works via F5 VIP. Thanks
    Friday, June 20, 2014 10:34 AM