none
Designer Workflow Emails Not Populating

    Question

  • I have an interesting situation that I hope someone can help with.  I have a list, Service Requests, which are populated when created with info such as Location, Status, Contract...

    I have 2 email notifications: Item Created and Item Closed.

    All information is populated in the Closed email but only about 1/2 of the information is populated in the Created email.  I have verified that all information is in the item when created so there should be no gaps.

    I have tried pausing the Created email with no luck.  Does anyone have any suggestions?

    SharePoint 2013, Workflows 2010.

    Tuesday, September 02, 2014 3:07 PM

Answers

  • Hi,

    Based on your description, the email sent when item was created did not include the values from the columns.

    Per my knowledge, this issue may be due to the values of some columns are not be stored in the database completely before the email is sent.

    So I recommend to pause for a longer time in the workflow before sending the email to see if the issue still occurs.

    Or you can add conditions to check if the values exist in the columns before sending the email in the workflow as Cameron suggested.

    Best regards.

    Thanks


    Victoria Xia
    TechNet Community Support


    Wednesday, September 03, 2014 5:40 AM
    Moderator

All replies

  • Hi MD, you might want to try having the workflow check for a value in a column as a trigger for the workflow instead of using a pause.

    cameron rautmann

    Tuesday, September 02, 2014 5:55 PM
  • Hi,

    Based on your description, the email sent when item was created did not include the values from the columns.

    Per my knowledge, this issue may be due to the values of some columns are not be stored in the database completely before the email is sent.

    So I recommend to pause for a longer time in the workflow before sending the email to see if the issue still occurs.

    Or you can add conditions to check if the values exist in the columns before sending the email in the workflow as Cameron suggested.

    Best regards.

    Thanks


    Victoria Xia
    TechNet Community Support


    Wednesday, September 03, 2014 5:40 AM
    Moderator