none
Excel 2013 ActiveX controls

    General discussion

  • Hi,

    We want to switch to Excel2013. We are using several templates that are using AxciveX command buttons to start VBA scripts.

    However every ActiveX control shows a red cross and the text "This image cannot currently displayed" instead of the caption text as it does with Excel 2010.

    Any idea what is wrong?

    Regards,

    Rene

    Wednesday, December 05, 2012 4:58 PM

All replies

  • Could it be that you did not establish Trusted Locations for that release ?

    It would have been nice if during the installation it would pick-up those from the 2010 release.

    Curious: what is the big incentive to move to 2013 ?

    Wednesday, December 05, 2012 6:31 PM
  • Hi9 Syswizard,

    No this could not be the problem. To be more precise the button doesn't use a picture at all. Even if I draw a new button it gives this message. If I click the ob the button so that it gets the focus the caption text appears. However than it also runs the script directly.

    The reason to plan to go to 2013 is that at the noment were working on many different version starting with office XP untill Office2010. Next year we want uo upgrade all user to one version. Which wil than be most likely office 2013 or Office365.

    Thursday, December 06, 2012 9:32 AM
  • Hi Rene van Noorloos,

    Thank you for posting in the MSDN Forum.

    Could please send me a sample workbook? You can upload it to SkyDrive make it accessible and then share the link.

    I look forward to your reply.

    Best regards,


    Quist Zhang [MSFT]
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Thursday, December 06, 2012 12:47 PM
    Moderator
  • Sounds like the default for the button controls in 2013 is to have images.
    Can the default button properties be changed I wonder ?
    Thursday, December 06, 2012 2:26 PM
  • test
    Thursday, December 06, 2012 4:32 PM
  • Okay not sure what hapend but is seems I have 2 display names

    To Quist: the link is  //sdrv.ms/THnbNK. It's my fist attempt so  I hope it works.

    To Syswizard That should than be a image that is hardcode by MS. Which I cannot imagine. I added a image in the property box but than I ger the same error message

    Regards

    Rene

    Thursday, December 06, 2012 4:55 PM
  •  I added a image in the property box but than I ger the same error message


    Sounds like a bug to me. Not surprising given how quickly Excel 13 went live.
    Thursday, December 06, 2012 6:54 PM
  • Hi Rene van Noorloos2,

    Do you mean the caption of "vernieuw lijst" button? I can see it there.

    I'm going to change this thread to discussion. You can wait till the final release and report back if the issue still occurs.

    Thank you for your understanding.

    Best regards,


    Quist Zhang [MSFT]
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Friday, December 07, 2012 5:47 AM
    Moderator
  • Hi Quist and Syswizard,

    Thanks for the info. I thuoght this was already the Final release

    Let's wait and see if the bug will be solved.

    Kind regards

    René

    Friday, December 07, 2012 8:49 AM
  • Hi Rene van Noorloos2,

    Thank you for your last reply.

    So, which version you're using? Is it Customer Preview?

    Besides, you've inserted a screenshot of the button in Excel 2010, but there's no screenshot of Excel 2013. It will be nice if you could insert the screenshot into the workbook and upload it again.

    Thank you for your time and effort.

    Best regards,


    Quist Zhang [MSFT]
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Friday, December 07, 2012 9:28 AM
    Moderator
  • Hi Quist,

    It is the version that MS made available through our volume licence.

    Version Excel 2013 15.04420.1017

    Kind regards,

    Rene.

    Friday, December 07, 2012 10:05 AM
  • Hi Rene van Noorloos2,

    I have the same build number with yours, but the captions can be seen on my side.

    You can try to follow below steps to enable ActiveX controls

    • 1. On the Security Warning message bar, click Options.
    • 2. The Security Options dialog box appears.
    • 3. Select Enable this content.
    • 4. The content is enabled for this session.

    For more information in regards to ActiveX control settings in Office documents, you can take a look at Enable or disable ActiveX controls in Office documents.

    Hope it helps.

    Best regards,


    Quist Zhang [MSFT]
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Friday, December 14, 2012 8:39 AM
    Moderator
  • Hello Quist.

    I don't get a warning.

    Furthermore I disabled all security settings.

    But as long there is no focus on the control it doesn't show the control correctly.

    The only thing I can think of that it some how conflicts with the existing installation of office 2010.

    Best Regards,

    Rene

    Monday, December 17, 2012 8:45 AM
  • Hi Rene van Noorloos2,

    It will be nice if you can try it on a machine which has only Office 2013 installed. If the caption still cannot be seen, please feel free to let me know.

    Best regards,


    Quist Zhang [MSFT]
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Monday, December 17, 2012 1:09 PM
    Moderator
  • Hello Quist,

    I will try this next week and send my results.  

    Kind regards

    Rene van Noorlooos

    Wednesday, December 19, 2012 8:41 AM
  • Hi all, 

    this thread is almost 2 years old. Now I have the same error with the german version of excel 2ß13. 

    I also have a spreadsheet with ActiveX controls in it. It always worked fine. No problems. Suppdenly, when I open existing spreadsheads or new ones, I always get the frame with with the ActiveX control and a red cross and the text "This image cannot currently displayed".  I didn't changed anything in excel. I assume some windows or office update or another installation corrupted my excel installation. But I have no idea how to fix the error. 

    Can you help me? 

    I use Windows 8.1 and office 2013, version 15.0.4631.1004. 

    sonny


    Siegmund SonntaG

    Saturday, July 26, 2014 1:23 PM
  • The error is solved. This behaviour is related to the error in MS Outlook when the Links in E-Mails doesn't work. There is a fix for that error in outlook: MicrosoftFixit20056.mini.diagcab. Running this fix for outlook will repair, i.e. open the links in E-Mails AND also repair the ActiveX control in Excel, i.e  display the correct ActiveX control in Excel and no longer the red cross with the text: "This image cannot currently displayed".

    how funny. :)

    sonny


    Siegmund SonntaG

    Monday, July 28, 2014 6:48 PM