none
MS Access 2007, 01013 timeout error - Oracle 10g ODBC - When creating linked table

    Question

  • I have recently been updated from Oracle 8 ODBC driver to the Oracle 10g ODBC driver. I run multiple queries in MS Access 2007 and now am no longer able to connect. I receive the ORA-01013 error.

    So I tried creating a completely new db and receive the timeout error before being able to select a single table.

    Steps to receive error: External Data > More > ODBC Database > Link to the data source by creating a linked table > OK > Machine Data Source > 10g ODBC > Enter Password > OK (At this point it tries to connect, after ~3 minutes, I receive the timeout error).

    I've tried the same ODBC connection in SQL Developer and it works without a problem. I have also tried incorrectly entering the password, and I received an immediate incorrect UN/PW error message. I have tried in both System and User ODBC connections.

    I need help to get this connection working again, using the 10g driver.

    Thanks!

    Wednesday, December 12, 2012 6:44 PM

Answers

  • The ODBC connection worked perfectly, I was able to use the same exact connection in SQL Developer, never having a query timeout.

    I did actually some additional trials and tests - finally fixing the issue by completely disabling the timeout in the 10g ODBC connection (Enable Query Timeout).

    Thanks for your answer though, I appreciate the reply.

    Thursday, December 13, 2012 12:15 AM

All replies

  • Hello,

    First, make sure that your ODBC connection is working properly - run the test in the ODBC administration. If the connection test successful - you should be able to link to the database.

    If the timeout is the issue - try to increase it to 300 in query design properties (it is 60 by default). If you have a lot of queries - change the Query Timeout in the registry (ODBC key)

    Nadia

    Wednesday, December 12, 2012 11:44 PM
  • The ODBC connection worked perfectly, I was able to use the same exact connection in SQL Developer, never having a query timeout.

    I did actually some additional trials and tests - finally fixing the issue by completely disabling the timeout in the 10g ODBC connection (Enable Query Timeout).

    Thanks for your answer though, I appreciate the reply.

    Thursday, December 13, 2012 12:15 AM