none
VBA Access Arabic problem

    Question

  • This really simple, but I haven't found a solution to it so far, and it's screwing all my access programs. It started happening with Access 2007 an on.

    Here's the problem.

    1. Create a form.

    2. Create a label on a form.

    3. Edit the OnLoad event of the form.

    4. Change the caption of the label: Label0.Caption = "تجربة"

    The problem is that I get accented letters in caption when I change it to Arabic. Although I can write in Arabic in VBA, I can't seem to get it to display properly in the form. There seems to be a miscommunication between VBA and Access forms and reports.

    Does anyone know how to fix this problem, please?

    Sunday, June 23, 2013 9:15 AM

Answers

  • Hi mqasem,

    Welcome.

    After installing the language pack, you may follow these steps: From the Control Panel, go to Region and Language. Go to the Administrator tab, click "Change System locale" in the panel "Language for non-Unicode programs", and select Arabic. Refer to the following picture, please:

    Hope it helps.


    Yoyo Jiang[MSFT]
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Thursday, June 27, 2013 1:15 PM

All replies

  • Which font you have set for your Label0?

    Vladimir Cvajniga

    Sunday, June 23, 2013 11:41 AM
  • I tried different Arabic fonts, but the results are always the same, accented letters.

    Sunday, June 23, 2013 3:07 PM
  • This is what I get when I change the caption to a word in Arabic (of course, the letters change when I change the Arabic word).

    Sunday, June 23, 2013 3:15 PM
    1. Is your operating system locale Arabic?
    2. Is your MS Access Arabic, too?
    3. Which version of MS Access do you have?

    Vladimir Cvajniga

    Sunday, June 23, 2013 3:51 PM
  • I appreciate your quick response.

    1. I'm using the English locale.

    2. My Access is English, but I have installed the Arabic Language Pack.

    3. I have 2013, 2010 and 2007. All behave exactly the same way.

    I'm used to having the English locale and the English Access without these problems. This happened when I got Access 2007 and on.

    Thanks

    MQ


    • Edited by mqasem Sunday, June 23, 2013 4:04 PM Added more info
    Sunday, June 23, 2013 4:01 PM
  • I'm very sorry I can't help. Just for sure, could you check out/reinstall your system fonts from your Arabian Language Pack (if there are any...)?

    Vladimir Cvajniga

    Sunday, June 23, 2013 4:29 PM
  • I just tried reinstalling the Arabic Language Pack. It didn't work.

    Thanks for your help.

    Sunday, June 23, 2013 4:41 PM
  • Just an idea: can you contact your local Microsoft dealer and ask for help?

    I'm very sorry I couldn't help. :-(


    Vladimir Cvajniga

    Sunday, June 23, 2013 4:54 PM
  • I appreciate you trying.

    Thanks

    MQ

    Monday, June 24, 2013 11:14 AM
  • You mentioned having A2007, 2010 & 2013.

    Does this mean you have all three installed on one machine? If so, Microsoft recommends only having 1 version of software installed at a time as there are version conflicts. This may have something to do with the issue.

    Otherwise, can you recreate the issue in a new file rather than just creating a new Form in the same file?


    Chris Ward

    Monday, June 24, 2013 1:54 PM
  • Each is on a different machine.

    I have created a form in a new file. I get the same problem.

    Thanks.

    Monday, June 24, 2013 7:52 PM
  • Hi mqasem,

    Welcome.

    After installing the language pack, you may follow these steps: From the Control Panel, go to Region and Language. Go to the Administrator tab, click "Change System locale" in the panel "Language for non-Unicode programs", and select Arabic. Refer to the following picture, please:

    Hope it helps.


    Yoyo Jiang[MSFT]
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Thursday, June 27, 2013 1:15 PM

  • I thought that changing the locale would change all my settings into Arabic. This was the only thing I didn't try, because I didn't want to change my menus to the Arabic Language. I'm glad it didn't. Problem solved!

    Great job!!! Thank you so much. It worked.

    MQ

    Friday, June 28, 2013 9:48 AM
  • I'm glad it helps.

    Good day.


    Yoyo Jiang[MSFT]
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Wednesday, July 03, 2013 9:24 AM