none
Email Alert Not Working - Telnet not working

    Question

  • Hi,

    I have installed new Sharepoint Server. When i was checking the email alert, it is not working.

    I tried to send message from powershell, i get the following error

    I have disabled firewall and antivirus. Please let me know why i am not able to send mail

    Wednesday, July 02, 2014 2:06 PM

All replies

  • Did you check if the smtp server is online and listening on port 25?

    This post is my own opinion and does not necessarily reflect the opinion or view of Slalom.

    Thursday, July 03, 2014 7:18 AM
  • Could you pls tell me how to check if SMTP server online and talking to port 25? Thanks
    Thursday, July 03, 2014 7:35 AM
  • Hi

      Yes Guru is right for sending mails in SharePoint you need to configure SMTP service please go through below link for configuring SMTP Service:

    http://technet.microsoft.com/en-in/library/cc288949(v=office.14).aspx

    Regards,

    MS

    Thursday, July 03, 2014 7:38 AM
  • If the SMTP server that you're using "mail.adex.com.my", does not accept connections from unknown hosts, then you will need to add the IP address of your SharePoint server to the mail servers whitelist.

    The only way to test this from the SharePoint server is to enable the Telnet Client feature on the server, and then use:-

    TELNET mail.adex.com.my 25

    If you get a connection (A blank screen, with a flashing cursor), type HELO and see if you get a response back.

    Paul.


    Please ensure that you mark a question as Answered once you receive a satisfactory response. This helps people in future when searching and helps prevent the same questions being asked multiple times.

    Thursday, July 03, 2014 9:51 AM
  • Hi,

    According to your post, my understanding is that you couldn’t use the PowerShell to send email in SharePoint 2013.

    There can be multiple reasons for it.

    At first, you’d better check if you configure outgoing e-mail and incoming email for your SharePoint 2013 farm.

    There are two articles about how to configure outgoing e-mail and incoming email for your SharePoint 2013 farm.

    http://technet.microsoft.com/en-us/library/cc288949(v=office.14).aspx

    http://technet.microsoft.com/en-us/library/cc262947(v=office.15).aspx

    And then, you’d better check whether your anti-virus software blocking to connect SMTP server using PowerShell.

    I recommend you to check with the following steps:

    1.        Right click on McAfee icon
    2.        Click on Virus Scan Console
    3.        Double click on Access Protection on VirusScan Console
    4.        On Access Protection tab
    5.        Go to Anti-Virus Standard Protection
    6.        On right hand side, double click on Prevent mass mailing worms from sending mail
    7.        On process to exclude tab, add PowerShell.exe at the end
    8.        Click ok
    9.        Click apply on Access Protection
    10.    Click ok

    Then you can try again to use the PowerShell to send mail.

    For more information, you can refer to:

    http://dhimantr.blogspot.com/2013/06/send-mailmessage-unable-to-connect-to.html

    In addition, there is an article about how to check if SMTP Port 25 is blocked.

    http://kb.siteground.com/smtp_port_25_blocked/

    Thanks,

    Linda Li                

    Forum Support

    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Linda Li
    TechNet Community Support



    Thursday, July 03, 2014 10:01 AM
    Moderator
  • Dear All,

    I have tried the smtp configuration, unblock firewall and uninstalled antivirus. But still get the error remote host could not be found when i use the smtp-mailmessage command in the powershell

    Is there anything else that need to check?

    Wednesday, July 09, 2014 7:24 AM
  • Hi

    Please telnet smpt server with port 25 ... it should give you blank screen.

    Then you need to install IIS6 and do some configuration also you need to update few thing in Central admin .

    Please refer url:http://blogs.msdn.com/b/pareshg/archive/2010/04/23/how-to-configure-incoming-and-outgoing-emails-in-sharepoint-server-2010.aspx

    Also communicate with team who manages SMTP server for relay setting.

    --Prasad Tandel

    Wednesday, July 09, 2014 8:26 AM
  • I have installed IIS already and completed all te configuration suggested in the link. But still when I use send-mail message it give an error "unable to connect to remote server"
    Wednesday, July 09, 2014 9:31 AM
  • Hi,

    According to your post, my understanding is that you got the error “unable to connect to remote server” when you used send-mail message.

    I recommend that you can test your SMTP connection to the remote server at first.

    There is a great article describing the Telnet way of testing your SMTP connection:

    http://www.msdigest.net/2011/09/test-sending-mail-to-your-smtp-connector-using-powershell/

    Thanks,

    Linda Li                

    Forum Support

    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Linda Li
    TechNet Community Support


    Wednesday, July 09, 2014 12:46 PM
    Moderator
  • hi,

    already tried the telnet

    when i ping port 25 , i get this

    when i do telnet to port 587, it is working

    please let me know how to make email sending possible

    Wednesday, July 09, 2014 2:20 PM
  • SharePoint sends emails using SMTP on port 25. If your mail server does not respond on port 25 you will need to set up a relay server, such as the IIS SMTP service that listens on port 25 and relays to the actual server. You can install the SMTP service on one or more SharePoint servers in the farm, which you need to do anyway to support incoming email.

    Wednesday, July 09, 2014 2:41 PM
  • Please contact your Wintech / Server team to open port 25.
    Wednesday, July 09, 2014 4:12 PM