none
Missing Utility Actions in SPD 2013

    Question

  • Hi,

    I just installed SharepPoint Designer 2013 and found out some of the Utility actions (Find Substring in String, Replace Substring in String, Trim String) missing from the menu.  I got the installer and SP1 update on the download site.  Appreciate any help.  Thank you

    Rose

    • Edited by Rose_A Wednesday, September 03, 2014 5:54 PM
    Wednesday, September 03, 2014 5:53 PM

Answers

  • Hi Rose,

    I could not reproduce this issue, my SharePoint Designer 2013 is working well.

    When you create workflow in SharePoint Designer 2013, you can choose 2013 platform and 2010 platform. The  2013 platform include the Utility actions (Find Substring in String, Replace Substring in String, Trim String), but the 2010 platform doesn’t include these Utility actions (Find Substring in String, Replace Substring in String, Trim String).So check which platform you have used.

    And if you didn’t configure 2013 platform for SharePoint 2013 Designer, you need to configure 2013 platform for the SharePoint Designer 2013, then check if it works.

    Here is a link about how to configure workflow for SharePoint Server 2013, you can use as a reference:

    http://technet.microsoft.com/en-us/library/jj658588(v=office.15).aspx

    If the issue still exists, please feel free to reply me.

    Best Regards,

    Lisa Chen

    • Marked as answer by Rose_A Thursday, September 04, 2014 5:18 PM
    Thursday, September 04, 2014 10:24 AM

All replies

  • Hi Rose,

    I could not reproduce this issue, my SharePoint Designer 2013 is working well.

    When you create workflow in SharePoint Designer 2013, you can choose 2013 platform and 2010 platform. The  2013 platform include the Utility actions (Find Substring in String, Replace Substring in String, Trim String), but the 2010 platform doesn’t include these Utility actions (Find Substring in String, Replace Substring in String, Trim String).So check which platform you have used.

    And if you didn’t configure 2013 platform for SharePoint 2013 Designer, you need to configure 2013 platform for the SharePoint Designer 2013, then check if it works.

    Here is a link about how to configure workflow for SharePoint Server 2013, you can use as a reference:

    http://technet.microsoft.com/en-us/library/jj658588(v=office.15).aspx

    If the issue still exists, please feel free to reply me.

    Best Regards,

    Lisa Chen

    • Marked as answer by Rose_A Thursday, September 04, 2014 5:18 PM
    Thursday, September 04, 2014 10:24 AM
  • Dear Lisa,

    Thanks for the reply.  You're correct.   I checked and I was working on the 2010 platform. It seems 2013 platform is not working for the site.  I will ask our Admin to configure it.  Appreciate the prompt reply.

    Cheers,

    Rose

    Thursday, September 04, 2014 5:17 PM