none
cannot connect to Access 2003 database in Windows 7

    Question

  • I'm a college student taking database related programming courses.  The dual-boot computers at school boot Windows XP for these classes because the IT & CIS people there can't figure this problem out either.  Basically, I can't do any of my classwork on a Windows 7 computer even when running "XP mode".

    Under Windows XP, I'm able to compile and run Java programs using the following string to connect to a local Access 2003 or Access 2007 database (the example is for a 2003 file, "ACCESS_DB_FILE .mdb", on my desktop):

         "jdbc:odbc:Driver={Microsoft Access Driver (*.mdb, *.accdb)};DBQ=C:/DOCUME~1/tom/Desktop/ACCESS_DB_FILE.mdb"

    I needed a new computer but was unable to purchase one with Windows XP because Microsoft doesn't sell it anymore.  So I purchased one that runs Windows 7 Home Premium (64 bit).  The connection string above no longer works and I CANNOT find a substitute anywhere ... and I've spent many hours searching on the web.  I decided to upgrade to Windows 7 Ultimate so that I could run "XP mode", assuming that I could use the old string in that environment.  I spent many hours setting that up and reinstalling Access inside the VM, but I still get the same error when trying to connect to the database.  This is the error:

        [Microsoft][ODBC Driver Manager] Data source name not found and no default driver specified


        C:\Windows\SysWOW64\odbcad32.exe

    but there are no instructions on what to do once the program launches.  I clicked Help and a useless (from my stand point) pop-up came up and asked me to rate it.  POOR!  Doesn't help at all.  It also asked if I wanted to post a comment, so I said clicked "yes" and wrote most of this stuff you're reading now, but the email (to sqldocfb@microsoft.com) was rejected by the Microsoft servers. ("The error that the other server returned was: 550 550 5.4.1 sqldocfb@microsoft.com: Recipient address rejected: Access Denied (state 13)").

    Hence I'm posting on this forum.  I can't imagine I am the only student with an issue like this.  I'm completely unable to use my new computer for school -- an almost complete waste of $800.

    Thank you.

    Wednesday, May 09, 2012 11:56 PM

All replies

  • What kind of instructions are you looking for? Launching C:\Windows\SysWOW64\odbcad32.exe launches the 32-bit version of the ODBC Data Source Administrator. You use it in exactly the same way you use the 64-bit version.

    Doug Steele, Microsoft Access MVP
    http://www.AccessMVP.com/djsteele (no e-mails, please!)
    Co-author Access Solutions — Tips, Tricks, and Secrets from Microsoft Access MVPs (ISBN 978-0-470-59168-0)

    Thursday, May 10, 2012 1:10 AM
  • Hi Ozozo,

    As Doug mentioned, odbcad32.exe launches the 32-bit Data Source Administrator.  On the Drivers tab you'll see your 32-bit drivers.  It sounds like you have Access 2007 installed so you should see the Access driver there.  If you don't have Access 2007 (or 2010) installed, you can download the Access Database Engine from the following location to get the driver.

    2007 Office System Driver: Data Connectivity Components (32-bit)
    http://www.microsoft.com/en-us/download/details.aspx?id=23734

    Microsoft Access Database Engine 2010 Redistributable (32-bit and 64-bit)
    http://www.microsoft.com/en-us/download/details.aspx?id=13255

    If you have the driver installed you can create a DSN connecting to an Access database.  When creating the DSN, you'll see an option to test the connection to see if a connection can be successfully established.

    For steps to create a new DSN, open Windows Help and search for ODBC.  In the search results, click on "ODBC: frequently asked questions" and then on "How do I add a data source to my computer?

    I hope this helps!


    Sharon M, Microsoft Online Community Support

    Friday, May 11, 2012 10:52 PM
  • See this for a complete list of ConnectionStrings:

    http://www.connectionstrings.com/


    Ryan Shuell

    Tuesday, May 22, 2012 10:03 PM