none
Sharepoint 2013 workflow - people picker return field is grayed out

    Question

  • Hello,

    I have a Sharepoint 2013 SP1 (15.0.4569.1506) environment where I'm trying to get a simple email/approval workflow to work. 

    1. User fills out infopath form and submits it
    2. Workflow starts and sends approving manager email (based on people picker)
    3. When ApprovalStatus field changes to approved, send helpdesk an email with a link to the form or as a pdf attachment (haven't figured out pdf yet)

    The problem - Sharepoint 2013 email workflow:

    I select the To: field, select the ApprovingManager field (people picker), the "Return field as" is grayed out. So the email doesn't get sent out because it can't find the user. Send email to user works fine if I choose Sharepoint 2010 workflow so I know the smtp server is configured correctly. Hope someone can help!

    Thank you,

    Ricky


    Thursday, July 31, 2014 4:54 PM

Answers

  • Hi Rebecca,

    Nevermind! I figured it out!

    You need to set the people picker field as a variable first, then at the To: field, when you pull the variable, you can change the "return field as" to "Email". This might not be the proper way but it works!

    Thank you,

    Ricky

    Thursday, August 07, 2014 7:07 AM

All replies

  • Hi Ricky,

    I tried to reproduce the issue, however, it worked in my SharePoint 2013. I added a person and group column from list > create column and a people picker control in InfoPath form. Then I opened SharePoint Designer and created a workflow for the list.

    In the to field > select users > workflow lookup for a user… > Current Item, column name, email address (semicolon delimited). It worked for both columns.

    As I understand the issue is that the return field as is grayed out. Please try add column from list page > create column and see if it works.

    Regards,


    Rebecca Tu
    TechNet Community Support



    Friday, August 01, 2014 7:11 AM
    Moderator
  • Hi Rebecca,

    Thank you for your response, though I am a bit lost with your instructions at the end.

    You want me to go to the list of the infopath template and add a column/create column? or is this something you want me to add in the "To:" field in the workflow?

    I've read somewhere that this might be caused by a bug. Which Sharepoint version are you using?

    Thank you,

    Ricky

    Monday, August 04, 2014 9:11 PM
  • Hi Ricky,

    I might not make myself clear. People picker control you added from InfoPath remains 2010 sytle and it displays different with the one which you added from list column.

    I'd recommend you add a column and test it again.

    Regards,


    Rebecca Tu
    TechNet Community Support

    Tuesday, August 05, 2014 9:07 AM
    Moderator
  • Hi Rebecca,

    I started from a blank infopath 2013 form so everything is 2013 including the people picker .. The property promotion on the form creates the column for the list in Sharepoint so I don't really have control over the generated fields in the list.

    I'm not sure what you mean by add a column... Are you asking me to create another column and have that lookup the people picker value?

    Thank you,

    Ricky

    Tuesday, August 05, 2014 8:43 PM
  • Hi Rebecca,

    Nevermind! I figured it out!

    You need to set the people picker field as a variable first, then at the To: field, when you pull the variable, you can change the "return field as" to "Email". This might not be the proper way but it works!

    Thank you,

    Ricky

    Thursday, August 07, 2014 7:07 AM
  • Hi Ricky,

    Glad to hear that. Have a nice day.

    Regards,


    Rebecca Tu
    TechNet Community Support

    Thursday, August 07, 2014 10:00 AM
    Moderator
  • ahh nevermind.. spoke too soon.

    Although I was able to select the To: field as an email address using a variable, it didn't actually send out the email.

    I also was able to make a column on the list as a "people" column and have a workflow set the field with the people picker field from infopath. When I did this I was able to set the To: field using the new column I made, with the option of selecting the return value as email, but that still didn't work.

    i found out my problem was because the email field in the user profile service for the users were not populated. my original question was answered so please close this one. ill open a separate thread for my new problem.

    thank you,

    Ricky



    • Edited by tinosux Monday, August 11, 2014 6:37 AM
    Thursday, August 07, 2014 5:04 PM