none
MS Project 2010 and Macros

    Question

  • I recorded some simple macros in a Project 2010 schedule and when I sent it to a couple of team mates they could not see the macros. Enable macros was checked. They renamed the file and sent it back. I could see the macros. This was done from my laptop. I took the file to my desktop by way of thumb drive and could not see the macros. I appears that the macros can only be seen on the system they were developed on. I am running windows 7 ult.

    It has been some time since I tried to share macros, what am I doing wrong or not doing?

    Thanks.....Bill

    Friday, June 04, 2010 2:06 PM

Answers

  • Billy --

    When you record a macro, Microsoft Project 2010 stores the VBA code in the Global.mpt file by default, and NOT in the project.  This is why your users cannot see it when they open the file.  Here's what you need to do:

    1. Open the project in question.
    2. Click the View tab to display the View ribbon.
    3. Click the Macros pick list and Visual Basic item on the pick list.
    4. In the Visual Basic window, click the expand button (+) to the left of the ProjectGlobal (Global.mpt) in the sidepane on the left side of the screen.
    5. Expand the Modules folder below the ProjectGlobal item.
    6. Drag the module in which you recorded the macro (probably called Module1) from the ProjectGlobal item to the project opened in step #1.
    7. Close the Visual Basic window.
    8. Save your project.

    Hope this helps.

    Dale Howard [MVP]


    Dale Howard, MVP VP of Educational Services msProjectExperts http://www.msprojectexperts.com http://www.projectserverexperts.com We write the books on Project Server
    Friday, June 04, 2010 3:46 PM

All replies

  • Billy --

    When you record a macro, Microsoft Project 2010 stores the VBA code in the Global.mpt file by default, and NOT in the project.  This is why your users cannot see it when they open the file.  Here's what you need to do:

    1. Open the project in question.
    2. Click the View tab to display the View ribbon.
    3. Click the Macros pick list and Visual Basic item on the pick list.
    4. In the Visual Basic window, click the expand button (+) to the left of the ProjectGlobal (Global.mpt) in the sidepane on the left side of the screen.
    5. Expand the Modules folder below the ProjectGlobal item.
    6. Drag the module in which you recorded the macro (probably called Module1) from the ProjectGlobal item to the project opened in step #1.
    7. Close the Visual Basic window.
    8. Save your project.

    Hope this helps.

    Dale Howard [MVP]


    Dale Howard, MVP VP of Educational Services msProjectExperts http://www.msprojectexperts.com http://www.projectserverexperts.com We write the books on Project Server
    Friday, June 04, 2010 3:46 PM
  • Thanks,

    You are correct they were stored as Global.

    Friday, June 04, 2010 5:29 PM
  • Billy --

    You are more than welcome for the help, my friend!  :)

    Dale Howard [MVP]


    Dale A. Howard [MVP]
    VP of Educational Services
    msProjectExperts
    http://www.msprojectexperts.com
    http://www.projectserverexperts.com
    "We write the books on Project Server"

    Friday, June 04, 2010 7:41 PM
  • BTW: When will your Project 2010 books be available? I checkd last week and they were not available.
    Friday, June 04, 2010 10:33 PM
  • Billy --

    The What's New Study Guide to Microsoft Project 2010 is already available.  Our Project Server 2007 book for administrators is ready to hit the market.  Other books are in development, even as we speak!  Thanks for asking.  :)

    eDale


    Dale A. Howard [MVP]
    VP of Educational Services
    msProjectExperts
    http://www.msprojectexperts.com
    http://www.projectserverexperts.com
    "We write the books on Project Server"

    Sunday, June 06, 2010 2:35 PM
  • In our company we are using MsP 2010 and in the Organizer some of the individuals Modules tab is greyed out and some are not. Is there a solution?

    thanks,

    Wednesday, May 02, 2012 5:12 PM
  • I would check to see if the Trust center settings are the same.  File > Options, Trust Center button.  Check the macro settings.

    Julie

    Wednesday, May 02, 2012 8:15 PM
  • Julie, I did the above description to adjust de Macro - security settings.

    Now the tab developer is availble, but all the options are grayed out!

    Therefor I can't select "Record Macro" "View Macro" etc...

    Do You have a solution for this problem to, it would help me a lot!

    thx in advance

    Monday, July 23, 2012 11:32 AM
  • What did you adjust the macro settings to?  No matter what I select, the developer tab and record macro is available.

    Julie

    Monday, July 23, 2012 12:32 PM
  • Hi,

    I would like to know if there is a macro that does the following:

    save .mpp file of several schedules on the project server using project pro 2010.

    thanks,

    Sam

    Wednesday, March 27, 2013 10:09 PM
  • I too face this issue, the options are grayed out.. did any one know how to make it work

    Monday, June 24, 2013 9:37 AM
  • What are your trust center setting?
    Monday, June 24, 2013 3:42 PM