none
Unable to save chinese character in CSV file (Excel 2007)

    Question

  • Hi,

    I facing problem to save chinese characters in CSV file (Excel 2007). After I save and close, then I re-open it, all the chinese character become "?".

    I have tried to put my comma separated values into to notepad and save it as CSV format with Unicode encoding, then I open it using Excel 2007, the chinese characters are displayed nicely, but only the first column in excel has values (comma deliminated string).

    I need to create a CSV file with chinese character in it. Can anyone tell me the solution?

    Thanks.

    Regards,
    Fenny

    Wednesday, May 19, 2010 5:41 AM

All replies

  • I'm not an expert on multi-language programming, but I don't think there is a known solution for this on common search engines.  If the language settings are correct and it's still not working, you may have to look for a language pack if it exists.  It might be a bug or simply not included with the general software release.  I've seen this question on other forums, none of which seem to have a solution. 

    http://www.experts-exchange.com/Programming/Languages/Visual_Basic/Q_27212218.html

    I don't have an account there so I can't view the answer, but it claims the issue is solved if you want to create one and look.


    May the fleas of a thousand camels feast happily on the lower regions of your enemies. And may their arms be too short to scratch!

    Wednesday, April 10, 2013 7:08 PM
  • I found instructions at http://www.ehow.com/how_8387439_save-csv-utf8.html, but I couldn't confirm the solution works.  I kept getting the garbled output.

    The issue is that Excel saves CSV as plain ASCI, not UTF-8, but you are able to save as Unicode Text, which will preserve the UTF encoding; please see my screenshot below of a Unicode Text document saved from Excel and opened in EditPad Pro of the Japanese words for each day of the week.

    Thursday, April 11, 2013 6:04 AM