none
Microsoft Office has identified a potential security concern. File Path: c:\....\Temporary Internet Files\Content.Word\~...tmp

    Question

  • I have developed a VSTO addin that I am currently testing.
    I have been working on it for several months. Yesterday I started
    get these errors.

    The addin opens some files that seems to cause this issue. The files
    are located in a subfolder as specified in my Word's trusted locations.

    Using Word 2010 and VSTO 2010.

    I am not aware of any changes that I have made to my machine.

    Error:
    Microsoft Office has identified a potential security concern.
    File Path: c:\....\Temporary Internet Files\Content.Word\~...tmp

    Note the path. Appears that it is doing some caching???

    I have tried the wizard at "How to Delete the Contents of the Temporary Internet Files Folder" (http://support.microsoft.com/kb/260897).

    Thanks in advance.


    Tim

    Wednesday, May 16, 2012 11:27 PM

All replies

  • Hi Tim,

    What's platform you used? I suppose you use Win7 (32-bit) system.

    Please check whether the key HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Common\Scurity exists. If it doesn't exist please add it. Then check the value HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Common\Scurity\DisableHyperlinkWarning (This is a DWORD value) to see whether it is 1. If it isn't please set it to 1. Let's see whether it can help you out.

    Have a good day,

    T.X.

    Thursday, May 17, 2012 2:06 AM
  • Using XP.

    Found the key. It was set to 0.
    Changed it to 1 and the problem has gone away.

    Thanks


    Tim

    • Marked as answer by Tom_Xu_WXModerator Tuesday, June 05, 2012 7:10 AM
    • Unmarked as answer by Tim_Shaf Thursday, July 12, 2012 8:39 PM
    Thursday, May 17, 2012 12:35 PM
  • Oops. I replied too fast.

    I am not getting the error with an existing document, but when
    a create a new document that accesses this functionality in the addin,
    the errors are re-appearing. Will do some more testing.

    Any suggestions are appreciated.


    Tim

    Thursday, May 17, 2012 1:11 PM
  • Now I am also getting "Security Warning, Macros have been disabled"

    I have the folders for both the documents and the folder for the attached template identified as Trusted Locations.

    What is interesting is that without enabling the macros., the functionality provided in the template and addin are working.

    Pretty confusing and frustrating.

    I also repaired my "Microsoft Office Professional Plus 2010".

    Appreciate any help.


    Tim

    Friday, May 18, 2012 6:13 PM
  • Hi Cindy,

    Any update?

    Have a good day,

    Tom


    Tom Xu [MSFT]
    MSDN Community Support | Feedback to us

    Monday, May 21, 2012 2:11 AM
  • No sure why, but this issue seems to have gone away.

    Thanks for your help.


    Tim

    Tuesday, June 05, 2012 5:24 PM
  • This issue is still occurring. It re-started quite some time ago and I am just now taking the time to deal with it.

    Running VSTO 2010 and Office 2010 on XP.
    Using doc & dot (Office 2003 binary formats).

    I have removed all Active Application Add-Ins.
    I put the following test together in an attempt to identify the issue.
    It appears the template is being copied to 
    C:\WINDOWS\Temporary Internet Files\Content.Word\ before it is being opened.
    I suspect that is my problem.

    Appreciate all help.
    Tim

    **************************************************************
    Trusted Locations: \\Dcppzzz\NetPrograms\Template2010
    Selected - "Allow Trusted Locations on my network (not recommended)"

    Other Locations
    Documents: \\Dcppzzz\MaintenanceSvcs\PROC\Projects\Word14\TBS2
    Workgroup templates: \\Dcppzzz\NetPrograms\Template2010

    Word 2003 Template - NoAutoOpen.dot: Contains AutoNew routine with MsgBox

    NoAutoOpen.dot Test
    1. Created a new document based upon NoAutoOpen.dot.
    2. Msgbox "AutoNew" presented as expected.
    3. SaveAs "NoAutoOpen.doc", type: "Word 97-2003 document (*.doc)"
    4. Close document.
    5. Re-open document - Getting "Security Warning Macros have been disabled.
        Without selecting the "Enable Content" button,
         File,Info,click down arrow on "Enable Content",Advanced Options indicate
         File Path: C:\WINDOWS\Temporary Internet Files\Content.Word\~WRC0000.tmp
      
    C:\WINDOWS\Temporary Internet Files\Content.Word contains the
       ~WRC0000.tmp file which is the same size as NoAutoOpen.dot.

    Appears that it is copying the template to 'Temporary Internet Files' which
    causes the Security Warning.


    Tim

    Thursday, July 12, 2012 3:02 PM