none
Project 2010 Visual Reports

    Question

  • Problem Description: When running visual reports in MS Project I get the following Microsoft Excel Error
    "XML for Analysis parser: The localeIdentifier property is not overwritable and cannot be assigned a new value"

    Then the second error from MS Project
    "Excel is Busy. This may be because Excel is currently waiting for user input (for example, a dialog may be open). Switch to Excel to correct the problem, then try again.
    I do not have excel open! 

    SQL Server recently unloaded of the computer.

    Computer is not on the a network
    I have recently reverted back to the factory settings and reinstalled programs, still no change.
    Are there settings I need to change to correct this?
    Operating System: Windows 7
    Wednesday, August 11, 2010 1:26 AM

Answers

  • Hi All,

    I just found a way to fix this that worked for me. The problem for me was that when the templates were created for these Excel templates, the data connection points to a cube that does not exist. You can see this by following these instructions:

    1. Press the [visual reports] button in the Projects tab of the ribbon.

    2. Select the report you are interested in

    3. Press the [Manage Template] button

    At this stage a windows explorer window will appear with one of the templates selected (e.g. adr4.xlt for the Baseline cost report)

    4. Double click the selected template to open it.

    There may be a security warning that Data connections have been disabled. Ignore this for now, if you try to enable data connections, it will fail becuase the cube does not exist.

    5. On the Data tab of the ribbon, press the little down arrow under the [refresh all] button and select Connection Properties

    6. Open the definition tab and you will see a link to a connection file that probably doesn't even exist on your computer. In my case it is "D:\Documents and Settings\PKMACCT\My Documents\Assignment Usage.cub"

    THE SOLUTION:

    in order to fix this, we will generate the connection and then save it as a file that we can reference instead of this wrong connection. So i did it this way.

    1. Press the [visual reports] button in the Projects tab of the ribbon.

    2. Select the report you are interested in

    3. Press the [New Template] button.

    4. Select the data type to create a template on (you will need to do this once for each of the data templates)

    5. Press [Ok]

    Excel will open up with a blank pivot table. It will have a working data connection thought, so we are going to export that data connection to a file.

    6.  On the Data tab of the ribbon, press the little down arrow under the [refresh all] button and select Connection Properties

    6. Open the definition tab press the [Export Connection File] button and save the connection as something like "ProjectAssignmentUsage.odc" By default this will be in "Documents/My Data Sources"

    7. Close the template without saving it.

    8. Back in Project, Press the [Manage Template] Button

    At this stage a windows explorer window will appear with one of the templates selected (e.g. adr4.xlt for the Baseline cost report)

    9. Before you open the template to edit it, copy the current directory into the clipboard (using CTRL + C)

    10. Double click the template to open it.

    11. On the Data tab of the ribbon, press the little down arrow under the [refresh all] button and select Connection Properties

    12. Open the definition tab press the browse button to select the previously saved connection "ProjectAssignmentUsage.odc" in this case. Remember it is in Documents/My Data Sources by default

    13. Select "Save As" in Excel

    14. Change the type to Excel 97-2003 TEmplate (*.xlt)

    15. Paste in the folder you coped earlier
    (default will be %userprofile%\AppData\Roaming\Microsoft\Templates\1033)

    16. save the template over the top of the existing template

    17. Close the template in excel

    18. Try to View the report from Project

    I hope this is detailed enough for others to follow. All the best

    Thursday, August 02, 2012 11:29 PM
  • Hi Chrisfiona,

    The initial error is a SQL error.  When you create a visual report, a local OLAP cube is created on your PC, it would appear that somehow the locale is set differently.  Worth setting your regional settings to a different locale?


    Ben Howard [MVP] http://appleparkltd.spaces.live.com/
    Wednesday, August 11, 2010 9:57 PM

All replies

  • Hi Chrisfiona,

    The initial error is a SQL error.  When you create a visual report, a local OLAP cube is created on your PC, it would appear that somehow the locale is set differently.  Worth setting your regional settings to a different locale?


    Ben Howard [MVP] http://appleparkltd.spaces.live.com/
    Wednesday, August 11, 2010 9:57 PM
  • Hi Ben

    Thanks for the comment, I tried changing to English (United States) with no success. English (Australia) is my correct region. The change was made via regional settings.

    I seem to have SQL Server 2005 Compact Edition, which is all new to me. I have installed SP1 & SP2 with no results. If I have excel open before trying to create a visual report, then it will show up in excel. However when I click on the window, the first error message appears. Excel then closes the window.

    Frustrating to have bought a package from Office and project from Microsoft to recieve know support or solutions when it does not work. From reading other posts it seems I have to change the localeIdentifier property, but how?

    Regards Chris 

    Thursday, August 12, 2010 11:54 AM
  • I don't know.  It would be worth checking if you still need SQL CE on your PC, or whether you can stop the service.  As it appears to be an issue with Excel/SQL, then I would post the question in the Excel / SQL forums.
    Ben Howard [MVP] http://appleparkltd.spaces.live.com/
    Thursday, August 12, 2010 7:37 PM
  • Hello Ben, Chrisfiona,

    I'm having exactly the same issue here as Chrisfiona describes. You wouldn't have an answer to this one just yet?

    Thanks

    Kind regards

    Kurt

    Thursday, September 16, 2010 4:18 PM
  • What was the answer?

    Regards,

    Tuesday, October 12, 2010 7:58 AM
  • I have the same issue as Chrisfiona. I checked the list of programs installed on my computer and I also have Microsoft SQL Server 2005 Compact Edition (ENU) version 3.1.0000. I understand that this is installed by applications that need it, but I don't know which those are.

    I'd still like an answer regarding the Project 2010 Visual Reports in Excel. But there doesn't seem to have been a satisfactory one posted in the last 8 months, even though several users are having the same issue. How to we find the solution?

    Terri


    Terri Cheeseman
    Saturday, April 16, 2011 7:42 PM
  • I also have this error.

    Brand new Dell Lattitude with Win 7 Pro, with Office Pro 2010.

    Crashes Project 2010 every time I click on any Visual Report.

    Not a good look.

    Geoff

    Thursday, May 19, 2011 6:21 AM
  • Geoff,

    Do you have SQL server installed?  What are your regional settings?  On another thread a poster noted that he had success changing his regional settings from Dutch to English US.  He then ran Visual Reports without trouble.  He was also able to change his regional settings back to Dutch and the Visual Reports continued to function as expected.

    Julie

    Tuesday, May 31, 2011 1:28 PM
  • Julie,

    Like others, all is not well with Visual Reports

    I've tried all of the above and that shown on other threads, and not working.  Sometimes the computer tells me "Excel is Busy" (when it is not), or when Excel does work (unusual), simply closing Excel causes it to crash (unhandled exception the computer says). Sometimes it says "Unknown Error".  Sometimes Project says "the file is read-only, shall I save" (it is not read-only) and then whether I say "yes" or "no", i get a file save dialog box then then after saying "ok", Project Crashes.   SQL server is not running or installed.  I have US English as the ONLY language in Windows, Office, (even though it is not the language I want).  Only Office 2010 and Project 2010 (no Office 2007 or 2003 anymore).

    I am unable to discern any pattern for the failures.  It seems different all the time. How odd. The one recognised pattern is that Visual Reports consistently fails.

    I need what Visual Reports is supposed to do. Any suggestions on how to get access to the raw data (no more database in Project)? Or other ideas.  I need a cash flow graph for real project.

    (This first time I've had the courage to use Project 2010 for a real gig and it's letting me down badly. I'm sure it's something i'm doing wrong, but ...)


    --rms www.rmschneider.com
    Wednesday, June 15, 2011 5:20 AM
  • Hi Rob,

    Sorry you're having this trouble.  Can you email me removed the file?  I'll pass it along to the team as (yet) another example.  I've not heard anything from the other files I've sent -- but I can keep bumping it.

    I'll also see if I can get the report to work and send it back to you.  The reporting database is still available in the meantime.  Click the Save Data button in the Visual Reports - Create Report dialog.  I was able to create a Pivot Table Query from the Reporting database that approximated the Cash flow report.

    I hope this helps.

    Julie


    Wednesday, June 15, 2011 11:15 AM
  • Hi Julie,

     

    This was brought to my attention by a client, here in the UK, and happens to me too.

    Really don't want to change my Regional Settings so please get the team to sort it out.

    Laurence

    Wednesday, July 06, 2011 1:31 PM
  • Hi,

    When I see this error, it is because I have seem to have asked for more information than my machine can handle. I can generate reports with the same query if the time period is Months. The query fails when the time period is Weeks.

     

    Norm

    Wednesday, November 16, 2011 4:35 PM
  • Norm,

    This is an older thread and I'm not sure if anyone is still monitoring it but the scenario you mention reminds me of a similar thing that happens when an array is insufficient to hold the data. I occasionally run into this while developing a macro or when a user finds a limitation in a macro I've written. I tend to use a lot of arrays. If the array isn't properly dimensioned, an "out of range" error occurs. I don't know if the visual reports function in Project is executed by a set of VBA macros but I'm sure it is something similar. An "out of memory" or "busy" error could well be an indication that the underlying code has either gone "astray" (e.g. endless loop), or run out of a resource (i.e. memory - real or allocated).

    Nonetheless, it sounds like Julie has already forwarded this issue up the chain.

    John

    Thursday, November 17, 2011 4:21 PM
  • Until Microsoft solves this problem, we have discovered a workaround. To generate a Visual Report and avoid the fatal error, select the copy of the Visual Report that you want and then click “new template.” The new template is created based on your selection. No error occurs.

    Thursday, April 12, 2012 5:28 PM
  • @ Brian Mullen

    the proclaimed workaround is not a workaround. it doesn't work.

    excel opens but there is no data, just an excelsheet in which you may insert fields into a pivotchart. there is no graph. there is no new template based on anything. i guess it is considered a success that ms project doesn't freeze...

    My regional settings are English (US). i use ms office 2010 and ms project 2010.

    the problem of "XML for Analysis parser; The LocaleIdentifier..." exists now for more than a year.

    this is embarassing.
    Thursday, August 02, 2012 12:55 AM
  • In an earlier post I noted that changing from weeks to months solved some of my problems. However, even the New Template path would not consistently work. What did solve my problem was systematically disabling the COM addins in Excel and Project. In my case, I have been trouble-free since disabling an add-in from Nuance.

    Thursday, August 02, 2012 9:39 PM
  • Hi All,

    I just found a way to fix this that worked for me. The problem for me was that when the templates were created for these Excel templates, the data connection points to a cube that does not exist. You can see this by following these instructions:

    1. Press the [visual reports] button in the Projects tab of the ribbon.

    2. Select the report you are interested in

    3. Press the [Manage Template] button

    At this stage a windows explorer window will appear with one of the templates selected (e.g. adr4.xlt for the Baseline cost report)

    4. Double click the selected template to open it.

    There may be a security warning that Data connections have been disabled. Ignore this for now, if you try to enable data connections, it will fail becuase the cube does not exist.

    5. On the Data tab of the ribbon, press the little down arrow under the [refresh all] button and select Connection Properties

    6. Open the definition tab and you will see a link to a connection file that probably doesn't even exist on your computer. In my case it is "D:\Documents and Settings\PKMACCT\My Documents\Assignment Usage.cub"

    THE SOLUTION:

    in order to fix this, we will generate the connection and then save it as a file that we can reference instead of this wrong connection. So i did it this way.

    1. Press the [visual reports] button in the Projects tab of the ribbon.

    2. Select the report you are interested in

    3. Press the [New Template] button.

    4. Select the data type to create a template on (you will need to do this once for each of the data templates)

    5. Press [Ok]

    Excel will open up with a blank pivot table. It will have a working data connection thought, so we are going to export that data connection to a file.

    6.  On the Data tab of the ribbon, press the little down arrow under the [refresh all] button and select Connection Properties

    6. Open the definition tab press the [Export Connection File] button and save the connection as something like "ProjectAssignmentUsage.odc" By default this will be in "Documents/My Data Sources"

    7. Close the template without saving it.

    8. Back in Project, Press the [Manage Template] Button

    At this stage a windows explorer window will appear with one of the templates selected (e.g. adr4.xlt for the Baseline cost report)

    9. Before you open the template to edit it, copy the current directory into the clipboard (using CTRL + C)

    10. Double click the template to open it.

    11. On the Data tab of the ribbon, press the little down arrow under the [refresh all] button and select Connection Properties

    12. Open the definition tab press the browse button to select the previously saved connection "ProjectAssignmentUsage.odc" in this case. Remember it is in Documents/My Data Sources by default

    13. Select "Save As" in Excel

    14. Change the type to Excel 97-2003 TEmplate (*.xlt)

    15. Paste in the folder you coped earlier
    (default will be %userprofile%\AppData\Roaming\Microsoft\Templates\1033)

    16. save the template over the top of the existing template

    17. Close the template in excel

    18. Try to View the report from Project

    I hope this is detailed enough for others to follow. All the best

    Thursday, August 02, 2012 11:29 PM
  • Andy,

    I think you've identified the real problem - I can see the D:\ link when I follow the first part of your response. However, when I try the second part at step 5, instead of opening a blank pivot table, the application tries to generate a report, which fails. Now, until yesterday, every report was working perfectly, even saved my own templates. Today, every template fails with same error message. A search of the hard drive turns up the proper .odc file, but Excel rejects every attempt to make the proper connection.

    Any thoughts? Anybody?

    Norm

    Thursday, December 20, 2012 10:32 PM
  • Dear Colleagues,

    After Andy Blanks steps (thank you), I solved this issue creating new templates based on the currents templates.

    Regards,

    MNZ's (Luciano Menezes)

    Friday, January 04, 2013 4:44 PM
  • Andy,

    I found a different solution, apparently caused by a different problem. What I ended up doing was systematically disabling a bunch of .com add-ins. For me, removing an add-in from Nuance, made the problem go away instantly. For others in my company it was a different add-in. Disabling add-ins is simpler than the 18 steps in your answer. I highly recommend trying that first.

    Best regards,

    Norm

    Wednesday, November 27, 2013 2:16 AM