none
SP 2013 ECT - Created an External Content Type in SPD But Not Appearing in BCS

    Question

  • Hello Community,

    I have created an External Content Type in SP Designer 2013, and the connection and operations all seem to work fine, but the ECT List throws an access error, and when I check the BCS Service Application the ECT doesn't even appear in the list.  Has anyone else ever seen this kind of problem and if so please brovide guidance and examples for resolving it.

    Thanks!

    Tom


    Tom Molskow - Senior SharePoint Architect - Microsoft Community Contributor 2011 and 2012 Award - Linked-In - SharePoint Gypsy

    Wednesday, September 03, 2014 8:25 AM

Answers

  • Hi Tom,

    Have you created external content type from SharePoint designer 2013 successfully prevously?

    And was it displayed in BCS service applicaiton previously?

    Have you executed "External Content Type Operations" and saved it back successfully in SharPoint Designer like the following article?

    Please check if it is related to the permission issue by using SharePoint Farm Administrator account to create this external content type.

    If all above don't solve the issue, please check the ULS log for more information for troubleshooting when create the external content type.

    http://www.c-sharpcorner.com/UploadFile/anavijai/create-external-content-type-using-sharepoint-designer-2013/

    Thanks,
    Daniel Yang
    Forum Support
    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Daniel Yang
    TechNet Community Support

    • Marked as answer by Tom Molskow Tuesday, September 09, 2014 5:50 PM
    Friday, September 05, 2014 6:25 AM