locked
A connection was successfully established with the server, but then an error occurred during the pre-login handshake. (provider: SSL Provider, error: 0 - The wait operation timed out.)

    질문

  • Has anyone else seen this error? 

    I thought I had my environment worked out.


    Derek

    2012년 4월 18일 수요일 오후 5:47

모든 응답

  • Haven't seen it myself... have you taken a look at this post?

    My Blog: dotnetlore.com/lightswitch Twitter: @DotNetLore

    2012년 4월 18일 수요일 오후 7:09
  • Yep, but the fix was to uninstall vs11 and framework 4.5 :( not a very good fix if you want to keep using it :)

    Trying a repair right now.


    Derek


    2012년 4월 18일 수요일 오후 7:13
  • Update...

    I was able to get this to work but only by establishing that the connection uses Named Pipes.

    I don't think this is a solution but it is a workaround for those who have this problem.

    By the way this could have something to do with kerberos as I have not set my spn for the new box.  If anyone checking into this is also having trouble if you are using kerberos or windows security I will post further updates.


    Derek

    2012년 4월 19일 목요일 오후 3:31
  • Update...

    This does not fix the connection if the server cannot be made to support named pipes :(


    Derek

    2012년 4월 19일 목요일 오후 4:14
  • Derek,

    Only a suggestion - Do you need to open up the Firewall - Port 88 or the likes? Not sure what additional ports, if any, are required for kerberos!

    Keith


    E tenebris lux. ±


    • 편집됨 PlusOrMinus 2012년 4월 19일 목요일 오후 5:46 Can't spell!
    2012년 4월 19일 목요일 오후 5:43
  • I have turned the firewall completely off, no joy.  I have no problem anymore connecting to servers using Named Pipes even with no kerberos (no spn set).  Just that when I try to connect to a hosted db at arvixe and discountasp.net I get this same error.


    Derek

    2012년 4월 19일 목요일 오후 5:57
  • Derek, 

    Thanks for feedback, just to confirm that there won't be an issue if you self-host, ie intranet / control the host firewall?

    Keith


    E tenebris lux. ±

    2012년 4월 19일 목요일 오후 6:06
  • Yeah I don't think the firewall has anything to do with it.  I beleive it has to do with the tcp connectivity.  I also cannot connect to a hosted database through the 2012 SSMC.  This is maddening.

    Derek

    2012년 4월 19일 목요일 오후 6:26
  • I'm having the same problem.  SSMSC works fine but I get that error with both versions of LS when i try to connect to our server.

    I gave up and got a copy of the remote DB on my box and am happily developing again.. well, I was until I ran into the next bug..

    but at least my DB works.. all 12 gb of it..

    Gus

    2012년 4월 19일 목요일 오후 10:34
  • I have the same problem.

    I have not been able to find any solution for it, except uninstall .Net 4.5.

    /Lars

     
    2012년 4월 20일 금요일 오후 4:27
  • I am still working this problem.  I have another machine on which this is working but the debugging of extension is not.  So I am trying to compare machines.  So far no luck.  Maybe we could compare systems to see similarities to help identify the culprit.

    Windows 7 Ultimate 64 bit.

    Visual Studio Ultimate 2010 (works fine until installation of VS 11)

    SQL Server 2008 Express installed from VS 2010.

    SQL Server 2008 R2 Developer installed by me.


    Derek

    2012년 4월 23일 월요일 오후 10:00
  • Can you create a .udl file (create an empty file called "foo.udl" in notepad -- make sure its not getting saved as foo.udl.txt, and double-click on it in your desktop), Fill it out exactly the way you would from lightswitch, and then press "test connection" ?  Does the problem happen when you do this?

    The message suggests that there is a certificate exchange going on with the SQL server.  Are you aware of any certificate configuration on the SQL server side?  Can you add "Encrypt=false" to the SQL connection string and retry?

    This thread might be relevant: http://www.sqlmonster.com/Uwe/Forum.aspx/sql-server/54524/error-occurred-during-the-pre-login-handshake-microsoft-SQL

    2012년 4월 23일 월요일 오후 10:36
  • Results:

    Created foo.udl.

    First attempt default settins chose OLEDB for sql as a provider when I double clicked the file.  This attempt failed with an Invalid Connection Error.

    Changed provider to Sql Native 10.  Worked fine.

    Changed provider to Sql Native 11.  Worked fine.

    Doesnot work in VS Server Manager.

    I have tried Encrypt=False.  No joy.


    Derek

    2012년 4월 23일 월요일 오후 11:11
  • Is there any further information here?  Anything else I can give anyone.  I have rebuilt my box (3 times).  It was working as of this morning.  I ran the updates for the VS 11 beta and bang. It stopped working.   BTW VS 2008 works.  VS 2010, VS 11 not so much.  Is there something in the differences in the registry which might affect this.  Is there something that may be causing VS 2010 and VS 11 to use the wrong driver?  Just throwing things at the wall to see what might stick.  REALLY need some help here.

    Derek



    2012년 4월 30일 월요일 오후 9:39
  • Worked perfect for me unistalling VS11

    2012년 5월 29일 화요일 오후 4:10
  • I seen the error once other day when having dns issues IIRC.
    2012년 6월 1일 금요일 오전 3:20
  • Yes but that was not really an option.  I am supporting both versions of LightSwitch with my extensions so I need both.

    Derek

    2012년 6월 4일 월요일 오후 4:28