none
Opzioni Internet

    質問

  •            

    Buona sera, qualcuno può aiutarmi ?

    Su di un pc Windows 7 home Premium 64 bit, facendo pannello di controllo\rete e internet\opzioni internet\connessioni\impostazioni lan  trovo checked la checkbox 'utilizza un server proxy....'. Se deseleziono questa scelta e faccio ok, quando poi riavvio il PC la trovo di nuovo checked.

    La guida di windows, in poche parole, dice che per selezionare/deselezionare il proxy basta agire sulla CheckBox.

    E' possibile che all'avvio di Windows qualcosa imposti questa opzione ?

    Il fatto che il proxy sia utilizzato, si ripercuote sul funzionamento di una applicazione VB .Net, che tramite un oggetto WebClient, deve trasferire dei file a mezzo Ftp.

    Quando il proxy è utilizzato (checkbox checked) l'applicazione non funziona,nel senso che l'oggetto webclient solleva un'eccezione.  Altrimenti si.

    E' possibile tramite un'applicazione VB .Net impostare le Opzioni Internet ?

    Grazie.


    mario formosa



    2012年5月11日 15:29

回答

  • Buona sera, qualcuno può aiutarmi ?
     
    Su di un pc Windows 7 home Premium 64 bit, facendo pannello di controllo\rete e internet\opzioni internet\connessioni\impostazioni lan  trovo checked la checkbox 'utilizza un server proxy....'. Se deseleziono questa scelta e faccio ok, quando poi riavvio il PC la trovo di nuovo checked.
     
    La guida di windows, in poche parole, dice che per selezionare/deselezionare il proxy basta agire sulla CheckBox.
     
    E' possibile che all'avvio di Windows qualcosa imposti questa opzione ?
     
    Il fatto che il proxy sia attivo, si ripercuote sul funzionamento di una applicazione VB .Net, che tramite un oggetto WebClient, deve trasferire dei file a mezzo Ftp.
     
    Quando il proxy è attivo (checkbox checked) l'applicazione non funziona.  Altrimenti si.
     
    Grazie.

    mario formosa

    ciao io ho trovato una soluzione

    testato è funzionante anche con 64 dovrebe funzionare

    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings\ProxyEnable - Set to 0

    img keys


    2012年5月12日 6:18

すべての返信

  • Buona sera, qualcuno può aiutarmi ?
     
    Su di un pc Windows 7 home Premium 64 bit, facendo pannello di controllo\rete e internet\opzioni internet\connessioni\impostazioni lan  trovo checked la checkbox 'utilizza un server proxy....'. Se deseleziono questa scelta e faccio ok, quando poi riavvio il PC la trovo di nuovo checked.
     
    La guida di windows, in poche parole, dice che per selezionare/deselezionare il proxy basta agire sulla CheckBox.
     
    E' possibile che all'avvio di Windows qualcosa imposti questa opzione ?
     
    Il fatto che il proxy sia attivo, si ripercuote sul funzionamento di una applicazione VB .Net, che tramite un oggetto WebClient, deve trasferire dei file a mezzo Ftp.
     
    Quando il proxy è attivo (checkbox checked) l'applicazione non funziona.  Altrimenti si.
     
    Grazie.

    mario formosa

    ciao io ho trovato una soluzione

    testato è funzionante anche con 64 dovrebe funzionare

    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings\ProxyEnable - Set to 0

    img keys


    2012年5月12日 6:18
  • Grazie 1000  eugnioteo.

    Solo una cosa : Hai riprodotto lo stesso mio caso ?

    Voglio dire che, spostando l'opzione da opzioni internet\connessioni\impostazioni lan la scelta non rimane, diciamo così, persistente mentre rimane persistente agendo sul registro ?

    Grazie !


    mario formosa

    2012年5月12日 6:32
  • Oltre alla soluzione proposta da eugnioteo, aggiungo che qualora si deve mantenere l'impostazione dell'utilizzo di un proxy http, senza scomodare il registro, è possibile fare in modo che l'applicazione che deve trasferire files a mezzo ftp utilizzando un oggetto webclient ignori il proxy, semplicemente impostanto a Nothing,dove serve, la proprietà Proxy dell'oggetto WebClient.

    ad esempio :

    MyWebClient.Proxy = Nothing

    In questo modo le opzioni internet non verranno toccate.

    Ciao.


    mario formosa


    2012年5月12日 9:43
  • Grazie 1000  eugnioteo.

    Solo una cosa : Hai riprodotto lo stesso mio caso ?

    Voglio dire che, spostando l'opzione da opzioni internet\connessioni\impostazioni lan la scelta non rimane, diciamo così, persistente mentre rimane persistente agendo sul registro ?

    Grazie !


    mario formosa

    si praticamente ho voluto ricreare il tuo stesso problema 

    comunque sincero avevo pensato ad un malware ...

    poi vedendo il registro ho capito

    ciao

    2012年5月12日 10:28