none
Anonymous access in blog in mysite 2010

    Domanda

  • Hi

    I create blog (through My Content tab)in mysite in sharepoint 2010.now I want to grant permission to anonymous users to see my blog, first I enable anonymous access in mysite web application, then enable anonymous access in mysite(parent of blog site) and finally enable anonymous access for blog site. But anonymous users can not access to my blogs. Why?

    What is wrong? Can I grant permission to anonymous users to mysite?

    mercoledì 18 aprile 2012 05:58

Risposte

Tutte le risposte

  • What's the need for anonymous access luckstar?  Assuming this is a MySite and therefore internal, are you trying to expose this to anonymous visitors outside of your company?  If it's for internal people to view then Domain Users or Authenticated Users would be sufficient.

    Paul Turner http://redmanta.co.uk/blog Twitter: @RedMantaUK MCTS:WSS,MOSS,2010 MCITP:2010.
    Please remember to click "Propose As Answer" if a post solves your problem or "Vote As Helpful" if it was useful.


    • Modificato Paul Turner _ giovedì 19 aprile 2012 07:23 spelling
    mercoledì 18 aprile 2012 08:20
  • Hi luckstar,

    Thanks for your post!

    If you do really need to enable anonymous access in mysite, you can refer the below link for step by step guide:
    http://www.topsharepoint.com/enable-anonymous-access-in-sharepoint-2010

    Thanks,
    Simon


    Simon Huang

    TechNet Community Support

    • Contrassegnato come risposta Shimin Huang lunedì 30 aprile 2012 01:49
    giovedì 19 aprile 2012 06:00
  • I agree with Paul but out of curiousity can anonymous users access any part of your mysite? I'm just wondering if the blog site itself is being troublesome or if anonymous access is not working anywhere.

    Please mark my response as an answer if appropriate.
    Learn.SharePoint.com

    giovedì 19 aprile 2012 06:02
  • @Paul,

    Yes, I want to anonymous user outsite of my company access to my blog in MySite.

    @Shimin

    Thanks for your link,I set all of settings in the link, but anonymous users can’t access to MySite and Blog in it !

    I create Blog in MySite through “My Content>create blog” in MySite, and grant anonymous user permission to it, but they cant access to this blog. But when I create site such as team site or blank site or… and grant anonymous user permission to it, anonymous users can access it.

    It’s interesting for me!  blog in MySite is also site but why anonymous users can’t access to it, although anonymous users can access to team site or blank site in MySite?!   

    venerdì 20 aprile 2012 19:19
  • Hi luckstar,

    It seems my site did not support the anonymous access, please refer this thread:
    http://social.technet.microsoft.com/Forums/en-MY/sharepoint2010setup/thread/7d33d3f6-b512-470c-afe0-e66c56aded53

    Thanks,
    Simon


    Simon Huang

    TechNet Community Support

    • Contrassegnato come risposta Shimin Huang lunedì 30 aprile 2012 01:49
    • Contrassegno come risposta annullato luckstar martedì 1 maggio 2012 16:27
    giovedì 26 aprile 2012 07:05
  • @Shimin

    This link is discuss about anonymous access to MySite, but I want to anonymous user access to blog site in it. I mean blog that created  through “My Content>create blog” in MySite. Anonymous users can not access to it ,although if I create site with blog template ,anonymous users access to it. 

    martedì 1 maggio 2012 16:28