none
winCE4.2 and CF2.0 SP1(a strange problem) pls help

    Domanda

  • Hello,

    I want to develop a program with .NET2.0 on a winCE4.2 device. I used CF2.0 SP1 and could be able to run programs on the device. But weeks later, I hard resetted the device and installed .NET CF2.0 to the device again, and I uninstalled .NETCF2.0 SP1 and installed it again.It installed the files and at last tried to connect to device but an error occured:

    "Microsoft .NET CF 2.0 does not support the connected device type. Application Manager will make the applciation available for installation when a supported device type is connected."

     

    I wish I could explained my problem. If it is not clear, I try to explain more.

    mercoledì 29 novembre 2006 07:51

Risposte

  • If you could not find them you either looking in a wrong place or don't have SP1 installed. 

    These files can be normally found under this folder assuming NETCF V2 SP1 patch has been applied:

    %ProgramFiles%\Microsoft Visual Studio 8\SmartDevices\SDK\CompactFramework\2.0\v2.0\WindowsCE\wce400\

    If you removed original NETCF MSI and installed SP1 MSI instead of applying a patch files might be in a very different folder.

     

    If that’s the case run a system wide search for “NETCFv2.wce4.armv4i.cab”.

     
    sabato 2 dicembre 2006 18:46
    Moderatore

Tutte le risposte

  • It's clear enough - you're trying to deploy NETCF to CE 4.2 device via AS and that does not work. That's because deployment via AS or VS is not supported for CE 4.2, you have to deploy correct CAB file manually.

    mercoledì 29 novembre 2006 16:37
    Moderatore
  • Sorry,but let me explain more.I think,I couldn't define my problem clearly.

    I installed these files to my WinCE 4.2 device:

    1.    NETCFv2.wce5.armv4i.cab

    2.    sql.dev.ENU.wce5.armv4i.CAB

    3.    sql.wce5.armv4i.CAB

    4.    sqlce30.dev.ENU.wce5.armv4i.CAB

    5.    sqlce30.repl.wce5.armv4i.CAB

    6.    sqlce30.wce5.armv4i.CAB

    After that, I installed CF2.0 SP1 to my develop PC and created a very simple program,and built it with VS2005. Then, I copied the .exe to the device manually.

    When I click onto the .exe an hourglass appears and it disappears. I do not deploy using VS2005 or ActiveSync.I already deploy the .exe manually.

     

    P.S: I tried creating a .cab project and deploying with it,but nothing changes,the .exe still do not run.

     

    Thanks for your interest.

    giovedì 30 novembre 2006 10:40
  • These CABs are for CE 5 as "WCE5" in the name suggests. These files should refuse to install on CE 4.2 or at least show a warning, so it's not clear to me how exactly you've installed them. You should pick CE 4 CABs (with “WCE4” in the name) and make sure CPU type is correct (are you sure it's ARMV4I?). These CABs are included in NETCF V2 SP1, so it should be installed before you try to install CABs on to CE 4.2 device.

    Another potential issue with custom Windows CE devices - missing NETCF dependencies in the OS image. In that case your device is incapable of running NETCF.

    giovedì 30 novembre 2006 17:23
    Moderatore
  • Hello

    I'm really confused about that...I can not find NETCF2 for WCE4 devices and I think I should not find actually. If there is NETCF2 for WCE4 devices,so why did Microsoft prepare NETCF2 SP1 ?

    My device is Mobile Compia M3. It's processor is Intel X-scale PXA 255 400MHz. I tried to install other packages like sh4 or mips,but the device refused them, it only accepted ARMV4I. When I look at "C:\Program Files\Microsoft Visual Studio 8\SmartDevices\SDK\CompactFramework", I could not find a package like NETCF2 for wce4.

    I tried many things but I can not get success...I have done that 2-3 weeks before, but not I can't do now. Alse there's a one more strange thing: After installing CF2 SP1 to my develop PC, the packages in "SmartDevices\SDK\CompactFramework" directory are reduced.I mean, there were a lot of package but now there are several of them...

     

    I'm really confused...May someone write the steps basically? What should I do to run my program in the WCE4.2 device..

    Sorry for the unsuccessfull posts..

    sabato 2 dicembre 2006 09:24
  • If you could not find them you either looking in a wrong place or don't have SP1 installed. 

    These files can be normally found under this folder assuming NETCF V2 SP1 patch has been applied:

    %ProgramFiles%\Microsoft Visual Studio 8\SmartDevices\SDK\CompactFramework\2.0\v2.0\WindowsCE\wce400\

    If you removed original NETCF MSI and installed SP1 MSI instead of applying a patch files might be in a very different folder.

     

    If that’s the case run a system wide search for “NETCFv2.wce4.armv4i.cab”.

     
    sabato 2 dicembre 2006 18:46
    Moderatore
  • Hello

     

    .Ilya, thank you very much for your answer.It's ok now.. Installing the patch and installing the CF SP1 causes different effects.. Other friends pay attention to this i wish because it's really annoying.

    Thanks again Ilya.

     

    domenica 3 dicembre 2006 14:06
  • Actually effects from patch and MSI are exactly the same. Patch, however, updates existing installation without changing it's location and remove/install might change it unless you choose custom install and set installation folder the same way VS does.

    domenica 3 dicembre 2006 18:39
    Moderatore