none
User Information List not updating

    Domanda

  • We have recently starting uploading photos to SharePoint which works fine and writes back to the thumbnailPhoto attribute in AD. The exports are running fine. However, my user information lists are not updating for some reason. There are 1 or 2 photos in there but the majority are not and these would have been uploaded 2 days ago or more. My User Profile Sync Timer Jobs are running. I have an incremental sync running daily as there are not very many changes in AD and then a Full import runs every week. I did discover yesterday that the Full Sync actually wasn't running since January! I have hopefully fixe that now.

    Is there another timer job that I am missing for the user info lists to update? It's very frustrating as the lists that show people's pictures are just showing the person.gif image.

    any help is appreciated.

    mercoledì 4 luglio 2012 08:02

Risposte

  • It seemed obviously that the first problem was that the property was not replicable. Then it took about 48 hours after a full sync for the information lists to update. Problem resolved. Replicable option was not set. Obviously, it just takes this length of time for the lists to update. Thanks everyone
    • Contrassegnato come risposta SoapyJ giovedì 19 luglio 2012 10:17
    giovedì 19 luglio 2012 10:17

Tutte le risposte

  • Hi Soapyj,

    Full Sync would resolve the issue and update the pictures.

    You can verify it by using a tool called LDAP administrator .

    here is the link

    http://www.ldapbrowser.com/download.htm 

    to verify whether the picture has been updated or not.

    You can also cross check user pictures with Microsoft ForeFront identity manager(miisclient) last updated.Not the content of the picture

    mercoledì 4 luglio 2012 13:43
  • I did run a Full sync, does it take maybe 24 hours to update? Should this also get rid of the deleted users from AD?

    mercoledì 4 luglio 2012 13:50
  • Hi,

    There is a timer job called  User Profile to SharePoint Full Synchronization, it synchronizes user information from the user profile application to SharePoint users and synchronizes site memberships from SharePoint to the user profile application. By default, it runs hourly.

    Please check if the timer job running properly.

    If the issue persist, please try to run "stsadm -o sync -listolddatabases <num days>" and then run the "stsadm -o sync -deleteolddatabases <num days>" command to remove the outdated sync information.


    Xue-mei Chang

    TechNet Community Support

    giovedì 5 luglio 2012 07:48
    Moderatore
  • I did that as well but nothing worked. I have since realised the the picture property was not replicable. I have changed that now and ran full sync. It appears that my user information lists were updated at 3.15pm yesterday. I don't know what job did this or anything. The thing is that I didn't have my properties set as Replicable before then so it wouldn't have updated the pictures. How often should it get updated? I just ran a full sync again.
    giovedì 5 luglio 2012 13:26
  • Please run the full sync at SharePoint server. It will definetly resolve your issue
    giovedì 5 luglio 2012 18:48
  • I ran a full sync several times, this has not updated anything.
    venerdì 6 luglio 2012 08:04
  • You can cross check with ForeFront Identity manager,whether the sync is successful,and verify the picture attribute for any single user using this tool which will let you know.How much time is the full sync usually running for? Are there any multiple domains?

    giovedì 19 luglio 2012 05:56
  • It seemed obviously that the first problem was that the property was not replicable. Then it took about 48 hours after a full sync for the information lists to update. Problem resolved. Replicable option was not set. Obviously, it just takes this length of time for the lists to update. Thanks everyone
    • Contrassegnato come risposta SoapyJ giovedì 19 luglio 2012 10:17
    giovedì 19 luglio 2012 10:17