none
Combobox floating outside of gridview in certain computers

    Întrebare

  • I have published a website using Visual Studio .Net 2008.

    After publishing, I was informed that users were visualizing a combobox, that is designed inside a gridview's edit item template, floating outside of the gridview, to the far right.  The strange thing is that this behavior does not occur in every computer.  In my machine it works just fine so at first I thought it could be the version of Internet Explorer being used.  But I found that some users have IE 8 and others IE 9 and the floating combobox happens in either one.

    I have IE 9 and I cannot replicate this behavior on my machine.  I checked and modified the Advanced Internet Options in the machine's where this problem occurs and still it does not work.

    If anyone has had this problem before and knows or has an idea why this is happening please let me know.

    Thanks

    8 mai 2012 18:45

Răspunsuri

  • Found out what was causing this.  The problem occurs when the "Compatibility View" option in IE is checked.  I unchecked this option and combo box displays correctly in place.

    Below is an image of the settings with the "Compatibility View" option checked.

    • Marcat ca răspuns de jirizarry 9 mai 2012 19:21
    9 mai 2012 19:21

Toate mesajele

  • I ran the vb.net application in a computer where the error was displaying and if I use Visual Studio to play the web application in the machine, the problem does not display.  But if I run it using the published application address at the server, the problem does display.

    Below is a screenshot of the problem.  In the gridview, the last column named "Comentario" is supposed to have the combo box below it, but instead displays further to the right.  The version of IE on this machine is IE 8.

    9 mai 2012 18:06
  • Found out what was causing this.  The problem occurs when the "Compatibility View" option in IE is checked.  I unchecked this option and combo box displays correctly in place.

    Below is an image of the settings with the "Compatibility View" option checked.

    • Marcat ca răspuns de jirizarry 9 mai 2012 19:21
    9 mai 2012 19:21
  • You self answer is incorrect..... add the x-ua meta IE=Edge to your page or server response header to over-ride the Compatibility View setting on clients of "Display Intranet sites in compatibility view"... see the documentation link I provided AND Read IT.

    Rob^_^

    9 mai 2012 19:31