none
Missing pages when printing from IE9

    Domanda

  • Our application uses an HTML control to render and print documents.  It creates a TemplatePrinter to print the document from a Print Preview dialog.   For long documents, it only prints the first few pages.  For example, a 32 page document will only print the first 14 pages. 

    The printer being printed to is a Ricoh 6001 printer.  It only happens in IE9 (32-bit browser).  If IE8 is installed, it prints fine.  The OS is Windows Server 2008 R2 64-bit.  I haven't tested other operating systems.

    Printing to the XPS Document Writer prints the entire document as well as printing to a PDF Creator.  Printing from the PDF itself to the printer results in the entire document being printed.  Printing directly from the IE9 browser to the Ricoh 6001 printer nets the same incomplete result - printing a 35 page web page only results in 8 pages actually being printed.

    Is there a workaround for printing long documents using IE9?  Maybe a setting that I'm missing?  I've played with the "Use software rendering instead of GPU rendering" setting with no success.

    Thanks

    martedì 6 marzo 2012 18:08

Risposte

  • Turns out embarrassingly enough that it seems it was the printer driver.  It was two updates behind.  Updating the driver to the most recent one seems to have worked.  I'll let QA bang on it to make sure.

    Thanks for the help.

    mercoledì 7 marzo 2012 16:24

Tutte le risposte

  • Hi,

    Try

    Tools>Internet Options

    General tab, 'Accessibility' button check "Ignore font styles specified on web pages", uncheck "Ignore colors specified on web pages"

    or

    View>Style>No Style

    What document Mode does your page render with (by default) F12 to display the Developer tool?

    Does the issue go away if you use the IE8 or Emulate IE7 DocumentMode?

    Have you changed the IE Security Zone settings? (IE on server versions runs with higher security zone settings than client versions)...

    reset IE Security Zone settings to their default Tools>Internet Options>Security tab, click "Reset all zones to default"

    which zone does your page load in? (from IE File>Properties dialog)

    also compare the Compatibility View Settings... Tools>Compatibility View Settings, you may need to have "Display Intranet sites in Compatibility view" checked

    Regards.


    Rob^_^

    martedì 6 marzo 2012 19:44
  • Hi Rob,

    Thanks for the response.

    The Browser Mode was "IE9" and the Document Mode is "IE9 Standards".

    The issue does not go away if I switch it to IE8 or IE7 browser mode.  The browser mode options are only: IE9 Compatibility View, IE9, IE8, and IE7.

    I haven't changed the IE Security Zone Settings.  They're locked down.

    The zone is "Internet | Protected Mode: On"

    The Display Intranet sites in Compatibility view was already checked. 

    When I changed it to IE8 mode, the pages went from 32 to 30, and it only printed 6 pages instead of 8.  In IE7 mode, pages are 30 and it print 7 of them.

    I read somewhere that IE9 uses bigger page or spool files than IE8.  Could this be part of the problem?

    martedì 6 marzo 2012 20:29
  • Hi,

    There have been issues with Print Templates since IE8. Its a Trident only technology...

    see http://connect.microsoft.com/IE/SearchResults.aspx?SearchQuery=print%2btemplates

    and IE9 honors @media queries and the behaviours of break-before and break-after style rules are to standards...

    It is impossible to tell from my end... you will have to debug them from yours...

    If you have tried with printing with noStyle chosen, then that rules out media queries and style rules and unsupported fonts...

    Perhaps you are using absolutely or static positioned elements in your page, disabling styles may correct pint layout issues...

    Look for static or absolutely positioned elements in your page source. Add a stylesheet for media="print" that sets the rules for staticly and absolutely positioned elements to

    display:none; visibility:hidden

    so they are ignored when the print viewport is rendered. Your printed pages will look completely different from what you see in the browser though.

    Regards.


    Rob^_^

    martedì 6 marzo 2012 21:00
  • Thanks.  I just tried with noStyle and no luck.  What I'm doing is just printing in the IE9 browser itself from a web page with a lot of info on it.  It reacts the same way as our application.  So I'm thinking it is not our application code or the template, since it reacts the same printing directly from the browser at a random website.

    Our code just uses the TemplatePrinter object using a startDoc, then iterating through each page calling printPage, then ending with a stopDoc.

    martedì 6 marzo 2012 21:50
  • Printing to the XPS Document Writer prints the entire document as well as printing to a PDF Creator.

    Is there a workaround for printing long documents using IE9?


    Looks like you found one?   <eg>

    Have you seen this thread in the other forum?

    http://social.technet.microsoft.com/Forums/en-US/ieitprocurrentver/thread/7e4156be-590d-42df-b393-dc95160cb2ff

    Also, I think there is a partial regression of a related patch that IE8 users had which IE9 users would only avoid if they had an LDR version of ieframe.dll.   So, perhaps ensuring you are on the LDR track for that module could change your symptom too?


    Good luck

    Robert Aldwinckle
    ---

    mercoledì 7 marzo 2012 04:11
  • Turns out embarrassingly enough that it seems it was the printer driver.  It was two updates behind.  Updating the driver to the most recent one seems to have worked.  I'll let QA bang on it to make sure.

    Thanks for the help.

    mercoledì 7 marzo 2012 16:24