none
.NET Framework 4 and Internet Explorer

    Pertanyaan

  • Hello,

    I have developed a control. NET (Framework 4, Visual Studio 10) programmed in C# that is hosted in Internet Explorer 9 and accessible via COM interface as if it were an ActiveX.

    The problem comes when debugging, when I have an error. Traditionally I've been doing through traces that write to a file, and although it is more uncomfortable, I was not too bad. However, when you want to go ahead or when you have a bug that crashes the browser, it gets tricky.

    Right now I'm having a bug that drops Internet Explorer and I am a bit blocked.

    Researching on the net and this forum, I found that the IEHost CLR is no supported anymore for Framework 4, so the control will be executed using the CLR of the system. This means that I cannot use the IEHost log to try to obtain more information about my bug... :( But the thing is that I need some way to debug my .NET object inside the Internet Explorer 9 and I have not succeeded by the moment... :p 

    Does anyone know how I can debug a .NET control inside the Internet Explorer 9? In the Internet it seems that Microsoft avoids the using of such scenario, but the truth is I need to use it! :( The thing is that I can not find the right way to do this and everything I've tried so far has not worked.

    I thank you in advance for your help.

    Domingo.


    • Dipindahkan oleh Mike Feng 11 Mei 2012 7:55 IE issue (From:Common Language Runtime)
    10 Mei 2012 11:44

Jawaban

  • Do you have issue in attaching debugger to the right tab? Visual Studio is having issue finding the right process attach, it attaches to the frame process, not the tab process. You can change TabProcGrowth or add a line Debug.Break on initialization.

    You can also turn off the automatic crash recovery so you can attach the debugger at crash time. 



    The following is signature, not part of post
    Please mark the post answered your question as the answer, and mark other helpful posts as helpful, so they will appear differently to other users who are visiting your thread for the same problem.
    Visual C++ MVP

    11 Mei 2012 20:26

Semua Balasan

  • Hi Dlopez,

    I have moved this thread to the dedicated forum for better support.

    Best regards,


    Mike Feng
    MSDN Community Support | Feedback to us
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    11 Mei 2012 7:55
  • Do you have issue in attaching debugger to the right tab? Visual Studio is having issue finding the right process attach, it attaches to the frame process, not the tab process. You can change TabProcGrowth or add a line Debug.Break on initialization.

    You can also turn off the automatic crash recovery so you can attach the debugger at crash time. 



    The following is signature, not part of post
    Please mark the post answered your question as the answer, and mark other helpful posts as helpful, so they will appear differently to other users who are visiting your thread for the same problem.
    Visual C++ MVP

    11 Mei 2012 20:26