none
IE8 auto switching to comptability view

    Question

  • I am developing a web page but when clicking a certain link, it causes the following message to appear:-

    "A problem displaying [address] caused Internet Explorer to refresh the webpage using compatability view"

    The page renders fine in every other browser I have tried (Firefox, Google Chrome, Safari, Opera), it is only IE that causes this message. The page still renders fine, but I want to stop the message coming up.


    I have identified the code that is causing this to happen

     

    <div id="config_grabbing_div" style="max-height:800px;overflow:scroll;"><table >....</table></div>

    If I remove the overflow:scroll bit of the code it stops the problem, but this breaks my site since the part of the page no longer has scrollbars even when the size of the contents means they are needed - so users cannot see some of the page.

    Could you please confirm if this is a known issue with IE and if there is a workaround?

    Thanks

    Jon

    Wednesday, April 07, 2010 3:11 PM

All replies

  • Hi Jon,

    What happens when you turn off "Automatically recover from rendering errors with Compatibility View" on the Advanced tab of Internet Options?

    When testing your site you should ensure that the above setting is disabled.

    Also

    Security tab, click "Reset all zones to default"

    Also to rule out Addons, uncheck "Enable third-party browser extensions" on the Advanced tab of Internet Options.

    Have you validated your markup? Developer tool... Validate>HTML

    Please provide a link to your site. Your markup snippet cannot provide enough information for us to guess an answer.

    Regards.


    Rob^_^

    This web search may give you some tips - http://www.google.com/search?q=overflow rules css

    Wednesday, April 07, 2010 8:34 PM
  • When I turn off the "Automatically recover from rendering errors with Compatibility View", whenever I move the mouse over the part of the screen with these tags, the whole screen flashes to completly white for around half a second and then returns. I'm afraid I can't provide a link to my site, as it's a web front end for an internal company application.
    Thursday, April 08, 2010 7:56 AM