none
Default search provider corrupted?

    Question

  • I just started receiving this error message today and I don't know why. I have not installed any programs prior to this happening.

     

    http://img253.imageshack.us/my.php?image=errormj4.jpg

     

    My default and only search provider is Live search, and the message doesn't even tell me what program corrupted it. The only add-on I am running is IE7pro.

     

    Has anybody else experienced this before and know how to get rid of it?

     

    I am using Internet Explorer 8 beta 2.

    Monday, September 22, 2008 9:08 PM

All replies

  • Hi,

     

    The error message tells you what to do..

     

    Tools>Internet Options - General tab, Search section - Settings button > Find Search Providers link (at the bottom of the dialog)

     

    Add new search providers, make a new one your default then delete the Live entry.

     

    Return to the Add Search Providers page and then Add the Live Search Provider, make it you default if you wish.

     

    Regards.

     

    Wednesday, September 24, 2008 6:43 AM
  •  

    well the  issue is that its corrupted to where it cant be changed or delete i can add google but not make default ... it just wont take
    Friday, October 10, 2008 9:52 PM
  •  

    yeah i am having the same issue too ... IE 8 beta 2 ... no ad on's just a fresh install of XP change change the default ....

    c'mon microsoft get it right ... i mean i know its beta ... but gosh!! how can so many other browsers can get it going ( safari , G Chrome, FireFox 2 and 3, even opera,)

    Saturday, October 11, 2008 11:44 PM
  • Well I'm glad I'm not the only one having this issue as well. About two days after I posted this thread, the problem just seemed to go away on its own, and I didn't do anything. It just went away.

     

    But now, today, the problem is back again for no reason. I mean its not stopping my web browsing in any way, its just an annoyance having to go through that message every time I start up IE.

     

    Hopefully in another month Microsoft gets the final version of IE8 out the door.

    Tuesday, October 14, 2008 2:08 PM
  • If you could do the following, I'll try to figure out why this is happening:

    1. Run regedit

    2. Go to each of the following keys, right-click and choose Export

    3. Post the content of the resulting files

     

    HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\SearchScopes

    HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\User Preferences

    HKEY_LOCAL_MACHINE\Software\Microsoft\Internet Explorer\SearchScopes

     

    Thanks!

    Friday, October 17, 2008 1:20 AM
  • Thanks for the report, Joachim. Does this dialog appear every time you start IE? It might be related to some add-on. Could you go to Tools -> Manage Add-ons, select all and copy, then paste the result here?

    Also, it looks like you're using some tool to print out the registry values. Just to double-check, could you run Regedit, go to HKCU\Software\Microsoft\Internet Explorer\User Preferences and confirm whether there are any values there? Thanks!

    Monday, December 01, 2008 8:07 PM
  • Thanks for the additional information. I can't reproduce this issue myself, but it sounds like the settings have been corrupted somehow. You can try deleting both HKCU\Software\Microsoft\Internet Explorer\SearchScopes and HKCU\Software\Microsoft\Internet Explorer\User Preferences, which will reset your search settings to the default values. Please let me know if you still have problems after doing that.

     

    Wednesday, December 03, 2008 6:49 PM
  • I know, so I'd like to find a way to fix it for you. Smile I appreciate your help with this.

     

    There must be some other program that's writing to these regkeys as well. Did you have any IE toolbars installed (MSN, Yahoo, Google, etc.)? You said you deleted all add-ons, but sometimes toolbars include other programs that run outside of IE, which may still be enabled. Also, do you have any security or anti-spyware programs installed? For example, Norton, McAfee, Ad-Aware, Spybot, ZoneAlarm, etc.

     

    If so, try disabling them, then deleting the abovementioned regkeys again, then launching IE.

     

    If not, or if that doesn't work, please try:
    1. Delete the regkeys, then launch IE with no add-ons by running: "%ProgramFiles%\Internet Explorer\iexplore.exe" -extoff
    2. If that doesn't work, reboot into Safe Mode, then delete the regkeys, then launch IE.

    Wednesday, December 03, 2008 10:28 PM
  • For the record, I was experiencing the same issues and the suggestion of "deleting both HKCU\Software\Microsoft\Internet Explorer\SearchScopes and HKCU\Software\Microsoft\Internet Explorer\User Preferences" worked for me! Thanks, AlexGI and good luck, JoachimJ!!!
    Monday, January 12, 2009 4:15 PM
  • I've got the same problem.  I've tried deleting the searchscopes keys, but I do not have a user preference key to delete.  It has not fixed the problem.  Could the missing User Preference keys be the problem?

    This is on Media Center 2005 sp3 with IE8 RTW
    • Proposed as answer by Michael Agens Saturday, April 18, 2009 4:03 PM
    Tuesday, March 24, 2009 2:24 PM
  • All,

    I have had this issue since I installed IE8 on my XP Pro SP2 laptop.  I just did this and it fixed the issue for me.

    1.Make sure IE 8 is closed then navigate to registry key: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders

    2.Add a new “Expandable String value” inside the above mentioned key with a value name of “AppData” and a value data of “%USERPROFILE%\Application Data”.

    3.Reopen IE 8 and see if you still get the error message.

    • Proposed as answer by JAlanD Tuesday, May 05, 2009 1:03 AM
    Saturday, April 18, 2009 4:04 PM
  • I finally got this resolved with media center 2005 sp3.  These are the steps I used.  There was alot of trial and error so I suspect there are some steps that weren't needed.  With only the live search provider installed and getting the error message I:

    1. Added google search provider
    2. exported HKCU\Software\Microsoft\Internet Explorer\SearchScopes
      1. The export file contained keys for both the live search and google search providers
    3. deleted the HKCU\Software\Microsoft\Internet Explorer\SearchScopes key
    4. deleted the HKLM\Software\Microsoft\Internet Explorer\SearchScopes key
      1. Alexi doesn't say to delete the HKLM SearchScopes, but I did after only deleting the HKCU key didn't work
    5. add the following key: HKCU\Software\Microsoft\Internet Explorer\User Preferences
      1. Alexi says to delete, but I didn't have it in the first place so I just created the empty key
    6. add the following key: HKLM\Software\Microsoft\Internet Explorer\User Preferences
      1. Alexi says to delete, but I didn't have it in the first place so I just created the empty key
    7. followed Michael Agens' steps
      1. navigate to HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders
      2. Add a new “Expandable String value” inside the above mentioned key with a value name of “AppData” and a value data of “%USERPROFILE%\Application Data”.
    8. started IE8 - no search providers were listed, no error message, but when I tried to install one it nothign happend.
      1. something actually was happening behind the scenes because i noticed searchscopes came back with some values about download retries
    9. clicking in the search provider text box crashed ie
    10. restarted ie, closed it out, ctrl+alt+delete to kill all iexplore.exe processes
    11. import the search scopes exported in step 2.
    12. open ie, search providers now worked.  was able to set google to default, add amazon, and switch live back to default without any errors.

     

    • Proposed as answer by Wilba Saturday, February 27, 2010 12:37 AM
    Monday, April 20, 2009 9:46 PM
  • i don't know why you people are making this so complicated. to get rid of that message is easy. go to Tools->manager add on then click on search provider, on the left bottom, choose Find more search provider. a page with list of search provider would pop up. choose any one of those search provider. it would pop up with a window "Choose Make it my Default Search Provider". close IE and viola, no more annoying message of corrupted search provider.
    Saturday, May 09, 2009 9:41 PM
  • i don't know why you people are making this so complicated. to get rid of that message is easy. go to Tools->manager add on then click on search provider, on the left bottom, choose Find more search provider. a page with list of search provider would pop up. choose any one of those search provider. it would pop up with a window "Choose Make it my Default Search Provider". close IE and viola, no more annoying message of corrupted search provider.

    Because that didn't work...  Perhaps you should read the entire thread before commenting next time.
    • Proposed as answer by wizard8011 Friday, June 05, 2009 3:51 AM
    Monday, May 11, 2009 4:13 AM
  • nothing shown under Reg_SZ so I can right click it?
    Also having a sudden problem with Outlook password
    It is constantly requiring I retype it in even though I don't need one and I have deleted and reinstalled pop server twice and rebooted UGH
    Thursday, May 14, 2009 3:01 AM
  • All,

    I have had this issue since I installed IE8 on my XP Pro SP2 laptop.  I just did this and it fixed the issue for me.

    1.Make sure IE 8 is closed then navigate to registry key: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders

    2.Add a new “Expandable String value” inside the above mentioned key with a value name of “AppData” and a value data of “%USERPROFILE%\Application Data”.

    3.Reopen IE 8 and see if you still get the error message.


    Great Answer- this worked for me too!  Thanks.
    • Proposed as answer by VBritt Wednesday, September 26, 2012 7:20 PM
    • Unproposed as answer by VBritt Wednesday, September 26, 2012 7:20 PM
    Monday, May 18, 2009 5:00 AM
  • The solution from "briane26" which included suggestions from "Michael Agens" and "AlexGl [MSFT]" corrected my issues also, Windows Media Center 2005 W/SP3, IE 8 Final Edition.   Thanks for the help!
    • Edited by NHeald Wednesday, May 27, 2009 11:59 PM
    Wednesday, May 27, 2009 3:17 AM
  • Many thanks Michael Agens,


    1.Make sure IE 8 is closed then navigate to registry key: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders

    2.Add a new “Expandable String value” inside the above mentioned key with a value name of “AppData” and a value data of “%USERPROFILE%\Application Data”.

    3.Reopen IE 8 and see if you still get the error message.


    This worked for me too. :) And I had another problem that XP/outlook/msn would not remember passwords. It's fixed too!!!
    Tuesday, June 02, 2009 8:39 PM
  • All,

    I have had this issue since I installed IE8 on my XP Pro SP2 laptop.  I just did this and it fixed the issue for me.

    1.Make sure IE 8 is closed then navigate to registry key: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders

    2.Add a new “Expandable String value” inside the above mentioned key with a value name of “AppData” and a value data of “%USERPROFILE%\Application Data”.

    3.Reopen IE 8 and see if you still get the error message.


    Thanks so much Michael Agens, this worked for me as well!  Was getting extremely frustrating and was even blocking me from getting online at times.  Kudos!
    Friday, June 05, 2009 3:16 AM
  •                           hey briane26  i did as u sugested brilliant work like a charm thanx

    Friday, June 05, 2009 3:54 AM
  • Can some one give me the text string or how to do step two?  Not a programmer just an engineer.  My PC started doing this last month and I've finally had enough. 
    Friday, June 12, 2009 8:15 PM
  • YES, YES!

    Your steps 1, 2 worked for me and also fixed the problem of Outlook not "remembering" my email passwords!

    Thanks for whoever came up with this simple solution!

    Gerald
    Sunday, June 14, 2009 3:55 AM
  • This worked for me as well.  There may be an entry in there that looks similar that points to local settings under the user profile, but this entry worked.
    Tuesday, June 16, 2009 7:22 PM
  • Michael,

    You don't know how much anguish you just relieved.  I have been dealing with this corrupted Default Search Provider message for 2 weeks -- worse yet I was being asked for
    my password to receive/send emails -- every 5 min in Outlook.  That was also instantly cured.  I had tried a half dozen fixes - even official Microsoft support.  Nothing worked until you provided this very easy & simple fix.  Thanks too much!!
    Thursday, June 18, 2009 8:10 PM
  • Well...I guess I am the odd-man out.  I have tried all the solutions proposed online including that of Michael Agens, checking each repeatedly to be sure that I had implemented each correctly and still I am getting the error message.  As an interim solution I have switched to Firefox until Microsoft can find and implement a real solution.

    Saturday, June 20, 2009 8:01 PM
  • I tried the above step 1 and 2 but it didn't work for me......any other suggestion?

    AppData\%USERPROFILE%\Application Data
    Sunday, June 21, 2009 4:08 AM
  • I had to do one more step which was to change the default provider to something other than Live Search and then I deleted Live Search.  (I couldn't delete Live Search before the HKEY change.)  After I deleted it, the problem went away.  Thanks to Michael who posted the solution! 
    Sunday, June 21, 2009 6:37 PM
  • I followed these steps briane26 outlined except I forgot to export my HKCU\Software\Microsoft\Internet Explorer\SearchScopes file. Iddidn't add the registry keys I didn't have. My IE didn't crash but I had to reboot before IE would come up without the corrupt message.

    1. deleted the HKCU\Software\Microsoft\Internet Explorer\SearchScopes key
    2. deleted the HKLM\Software\Microsoft\Internet Explorer\SearchScopes key
      1. Alexi doesn't say to delete the HKLM SearchScopes, but I did after only deleting the HKCU key didn't work,
      2. Didn't work until I also delete this entry
    3. followed Michael Agens' steps
      1. navigate to HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders
      2. Add a new “Expandable String value” inside the above mentioned key with a value name of “AppData” and a value data of “%USERPROFILE%\Application Data”.
    4. Started IE8 still same problem, rebooted
    5. started IE8 again problem gone, but no google search provider.
    6. clicked on manage search providers added google but won't let me set a default.
    7. restarted IE8 still can't set google as default.
    Sunday, July 05, 2009 9:18 PM
  • I just started having this issue and I have followed your instructions and have tried to add to my registry but there is already a registry key called "AppData", am I safe deleting that or should I be calling it something else.

    Your assistance is appreciated.

    Tuesday, July 14, 2009 5:00 AM
  • I just started having this issue and I have followed your instructions and have tried to add to my registry but there is already a registry key called "AppData", am I safe deleting that or should I be calling it something else.

    Your assistance is appreciated.


    Same here. I also all ready have the reg string. Nothing helped so far. Any suggestions?
    Saturday, July 25, 2009 12:39 PM
  • great briane worked for me managed to change search provider and set google as default but the view and manage addons dialog box still appears when i start ie. Any ideas anyone how to get that to stop popping up
    Monday, July 27, 2009 12:58 PM
  • Just wanted to say I have had the same problem with the search providers.  I deleted Google Toolbar, I added another search provider - But I cannot delete or change google from the default.  I still get the same message when I start IE.
    I looked at the registry and AppData is already there, I just modified it and that didn't work so I changed it back.

    I suspect the culprit to be Google somehow; but others are reporting the same phenomenon who used or had Live as their default search provider.

    I'm about to get ugly with my registry.

    Help.
    Tuesday, July 28, 2009 4:09 PM
  • I had this issue sometime back and I posted about it about on my blog, and lots of people have since commented about other possible fixes, etc. Read the comments on the following blog post for more help.

    http://blog.kirb.us/2009/03/20/a-program-on-your-computer-has-corrupted-your-default-search-provider-setting-for-internet-explorer/


    I think enough of people are still having the problem that it would warrant an official fix from Microsoft.
    Saturday, August 01, 2009 8:41 PM
  • Ialso started having the same problem about a week ago. I have tried "All" of the sugested fixes with no avail.
    I can't even change to default search which is Live Search or delete it.

    C'mon microsoft a patch is deffinately here.
    • Proposed as answer by marlinspoke Thursday, August 20, 2009 4:49 AM
    Thursday, August 06, 2009 6:40 PM
  • My computer is doing this. It isn't easilly fixed by using the simple user toolbars and settings. I'm not going into 5 different folders and adding and removing values, give me a break! I say this is due to Microsoft not wanting Google as a default search provider. If I wanted this kind of big brother control I'd have bought a Mac. Firefox seems to work great I'll just use that until Microsoft fixes it with an automatic update.

    Thursday, August 20, 2009 5:18 PM
  • Yippee!!  Deleting both these keys did it for me!  The other solutions didn't work in my case.  Alex, thank you!  This issue was driving me crazy!

    Thursday, September 03, 2009 6:53 PM
  • I had this same problem after I installed IE8, too.  I did what you said to do and it worked!  I am so glad I can finally pick my own search provider for "default".  It was so inconvenient to have the "search provider default" window pop up every time I went into IE.  Thanks for your help!
    Monday, September 14, 2009 1:05 AM
  • I tried your way first, but it didn't work. It would have been easier for sure.  I guess there isn't a "fix all" remedy.  I tried several before the one Agens gave me worked. 
    Monday, September 14, 2009 1:16 AM
  • i don't know why you people are making this so complicated. to get rid of that message is easy. go to Tools->manager add on then click on search provider, on the left bottom, choose Find more search provider. a page with list of search provider would pop up. choose any one of those search provider. it would pop up with a window "Choose Make it my Default Search Provider". close IE and viola, no more annoying message of corrupted search provider.

    Because that didn't work...  Perhaps you should read the entire thread before commenting next time.

    Exactly; if that worked ; nobody would be having this problem.  I have had the same problem ever since I downloaded Explorer 8.  I want Google to be my home page (as that is the way I have always had it and like it.) I got rid of the Windows live option; I click on the option to use ONLY the current website (Google) and it always changes it back. 
    Another problem (don't know if its related is that I don't want that page to come up that says "you unexpectly closed your last session; do you want to reopen it" and private browsing.  I understand some people may want it but I don't.  I like to click on the arrow in the subject? line and go to one of the prior websites I was on.  Like in Explorer 7!!
    Thanks
    Sunday, September 20, 2009 7:35 PM
  • The problem is that I don't want to go into all them different folders; adding and deleting things.  I don't know how to do that and I do not want to ruin my brand new laptop by deleting something that I shouldn't have.  Why doesn't Microsoft come up with a fix for this as it was their fault (when it upgraded to explorer 8)?  Is it possible to just go back to an earlier version of Explorer and use that?
    Thanks,
    Tracy
    P.S.  I agree with a writer who said Microsoft probably doesn't want us using Google as our default.
    Sunday, September 20, 2009 7:43 PM
  • Forget all of the above. Here are 2 good fixes to this problem http://cuteautoposter.net/FAQ/index.php?action=artikel&cat=8&id=71&artlang=en
    Saturday, October 03, 2009 1:03 AM
  • Forget all of the above. Here are 2 good fixes to this problem http://cuteautoposter.net/FAQ/index.php?action=artikel&cat=8&id=71&artlang=en

    All of the above are the same fixes as you propose, and they DON'T WORK for most people. After searching and searching I've come to the conclusion there is no universal fix, so no one has found the root cause of the problem. It's up to MS to issue a patch and they seem to be very slow in doing so.
    Wednesday, November 04, 2009 7:49 AM
  • My REMOVE icon in that box is grayed out? I can Remove google but not live.com, Because I have the same prob. as the top poster!
    • Proposed as answer by Mackinny Monday, November 16, 2009 3:10 PM
    Sunday, November 15, 2009 5:56 AM
  • Here is what i found with this issue and it seemed to fix the problem i was having.  I found that the HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\User Preferences key had no permissions set for any user.  Once I added the permissions, I restarted internet explorer went through the default search provider ____ one time, but it fixed it.

    Hope this helps
    Monday, November 16, 2009 3:17 PM
  • Found what appears to be working for me so far at this site:

    http://foundsolutionz.blogspot.com/i...search-results



    PROBLEM #5
    An error after opening internet explorer 8: "A program on your computer has corrupted IE8 default search provider settings. IE8 will reset the search provider setting to default setting of xxx search. IE8 will open the search provider dialog where you can change your search provider".


    For the above error follow the below steps:
    1. Click Start. 2. Click Run. 3. Type in regedit and press enter. 4. In the registry editor, expand and navigate to the following registry key: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders. 5. Right click User Shell Folders. 6. Select New and then Expandable String value. 7. A new value is added in right pane. 8. Type in AppData and press enter. 9. Double click AppData. 10. Under value data type in:

    %USERPROFILE%\Application Data

    11. Note: If there is already AppData in the right pane, double click and correct it to %USERPROFILE%\Application Data

    If the above steps do not work,
    1. Click Start. 2. Click Control Panel. 3. Click User Accounts. 4. Click Create a new user account. 5. Choose appropirate name for the new user account. 5. Choose Administrator or Limited or Standard user. It's upto you. 6. Click Create. 7. Click Start, Log out from the current user account and log back in with the new one. 8. If the new user account is working for you, obviously, the old user account has got corrupted and you will have to use the new user account. Also, FYI: you can transfer old user settings and files to the new user account.
    Thursday, November 26, 2009 8:44 PM
  • I have struggled for days trying to correct the banner display and using Michaels suggestion my trobles are over. Thank you very much.
    Sunday, November 29, 2009 6:04 PM
  • Michael,
    Thank you so much.  The regkey addition fixed my IE8 problem and my Outlook requesting a password.  You are truly appreciated.
    Monday, December 07, 2009 2:05 PM
  • Exact same issues, "A program on your computer has corrupted IE8 default search provider settings. IE8 will reset the search provider setting to default setting of xxx search. IE8 will open the search provider dialog where you can change your search provider".
    Did everything twogrnthmbs suggested and it worked great. No more messages and outlook no longer prompts me for a password. I was finally able to get rid of Google as my default search provider. Thanks for the help.
    Wednesday, December 30, 2009 3:06 AM
  • I can't thank you enought TwoGrnThmbs!  I have spent an inordinate amount of time trying to fix my Mother-in-Laws search provider default.  Your answer was the 5th or 6th I had tried and it FINALLY worked!  Your instructions were perfect for a quasi techy like myself.  Very simple and very much appreciated!  Thanks again!
    Wednesday, December 30, 2009 5:02 AM
  • Yeah, so far it seems I've tried everything listed here, but so far, to no avail.

    I can't get the pop up box to go away, and instead AIM Search is set to default, the boxes are greyed out so I can't remove it, along with AOL and Live Search, which can be deleted, but nothing happens when I click the "Set As Default" button.

    Nothing works!

    Stupid thing is, it's only on one account, all the other User Accounts IE work perfectly fine without the annoying pop up and problem.

    Anyone have anymore ideas?
    Thursday, January 07, 2010 1:18 AM
  • All,  I am trying to use Michaels Fix and I am running into a problem when trying to create the new expandable string value.  When I right click and go to "new" and then "expandable string value" I type in "AppData" but it comes back and says:

     "The Registry Editor cannot raname New Value #1.  The specified value name already exists.  Type another name and try again".

    I checked and there is already something named "AppData" under the name column.  In the data field it is listed as "%USERPROFILE%\AppData\Roaming"   Do i want to delete this and re-add the new AppData that Michael is talking about?    It won't let me add the string Michael is saying to add because it shares the same name. 

    Anybody?  Any answers to this.  It is appreciated.  This thing is driving me crazy.  Thanks in advance

    Friday, January 08, 2010 2:59 PM
  • Thanks a lot.  This worked for me, too.
    Thursday, January 14, 2010 5:24 PM
  • I have tried many different solutions for this problem and none have helped.  I don't think it's actully a "Problem" that it has made out to be.  It's just Microsoft's way to try to get you to use bing.  notice how you can't remove bing as a search provider.  It's easy enough to do.  I can make a simple program to say that your computer will explode if you don't fix this.  In truth bing is no better then google.  the only difference ive seen is slower loading time due to all that appears on the page,  as opposed to Google,  who's options only appear if you move your mouse.   This makes google faster, and less complicated.   I searched ten random things on bing and Google  to see hwhich does it better,  and I found that they bring up the same results ( if not better on googles side).   So Google is faster with the same results as bing.    So why use bing?   I hope that microsoft changes this, not "Fixes" it,  and makes it able to be removed from IE alltogether.

    Friday, January 15, 2010 4:51 AM
  • Download the Google or Yahoo branded versions of IE8. Ditto for Google and Yahoo. Toolbar and BHO addons from FunWebProducts are known SearchProvider hijackers. Disable their hijacks from the Windows startup liist with msconfig. Restart your computer.

    Regards.
    Rob^_^
    Saturday, January 16, 2010 7:21 AM
  • SOLVED FOR ME!

    Today I also got this error message "Search Provider changed ..."
    !

    After googling for a while and not immediately found a good solution, I tested a bit myself.
    My Thought:
    Probably have things changed in my computer since yesterday (Window Update).

    Since I've worked some years with MSI-packaging, deployment and has much knowledge of rights in Windows, my first thought is always: Problems with Rights!

    The only thing I did was to start Internet Explorer as Admin
    1. Right-click, choose "Run as Administrator".
    2. Made my choices and preferences.
    3. Closed IE.
    4. Started as normal. No error message!


    Problem solved!!

    /SgxMan (SWE)

    • Proposed as answer by amylouisa Thursday, April 15, 2010 8:56 PM
    Thursday, January 21, 2010 8:51 PM
  • Hooray! The annoying problem has been solved thanks to you, Michael. I appreciate your sharing this solution and writing it in a way that was easy to understand and follow. Please give yourself a pat on the back for me.
    Saturday, February 06, 2010 1:20 PM
  • While tooling around in vista's registry trying to fix this same problem I came upon "HKEY_USERS\S-1-5-21-2518100289-1898487005-2557283693-1000\Software\Microsoft\Internet Explorer\Main" went to the "SearchPage" setting and changed that to what I wanted. restarted IE8, it did not automatically change the search options to my choice but it allowed me to add a new search provider and the error above went away. You may not have this "S-1-5-21-2518100289-1898487005-2557283693-1000" exact number but figure it out you will.
    Tuesday, February 09, 2010 5:35 PM
  • omg....after about an hour of searching and sweating by going into the registry....I just did what SgxMan_SWE said and it worked. THANK YOU!

    edit: well was a quick fix. have to keep right clicking on shortcut for it to stick...ended up making a new user account and that definately fixed it.

    Thursday, April 15, 2010 8:57 PM
  • I used the Alex deletions and the Michael add ons in reg edit, I also removed this key and value from registry key: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\User  Local AppData %USERPROFILE%\Local Settings\Application Data

    Then I noticed I had disabled everything but Microsoft Search Helper in tool bars and extensions. After disabling Microsoft search helper everything worked after nearly a year and a half of grief. No more manage search loading at IE start up and I can choose my default provider. I was stuck with Wilkipedia until I manually changed the search. Wow, 2 desktops again that I don't mind using for the Internet. Thank God for Alex and Michael. 

    • Proposed as answer by EkDecker22 Wednesday, May 12, 2010 5:42 PM
    Friday, April 16, 2010 2:06 PM
  • I have also created a brand new user account and it IE 8 doesn't crash anymore.  It must be in the user "appdata" that is corrupt. 

    Just create a new user account and copy docs and favorites over then go in to Computer Management and disable the account that has the corrupt default search provider issue.

    Wednesday, May 12, 2010 5:44 PM
  • After a lot of investigating and testing out I found the solution to this issue in windows 7 and this is the same solution to the 0x80070005(access denied,messenger not loging in and so on) problem that some may suffer

    it has to do with the permissions to your own Users folder and it goes like this:

    1. make sure that your in administrator account, if you dont know how: search the web for activating administrator account or you can use your own account if your admin.

    2. go to your profile folder usually like this "c:\Users\(your profile)" and right click it going to "Properties".

    3. go to "security" tab and click "advanced"

    4. go to "owner tab and change it from "system" (or what ever it is) by clicking "edit" choose your account name and tick/mark with a V the: "replace owner on subcontainers and objects". press the "Ok button".

    5. go to "auditing" tab and press the "edit" button, then press "add..." and enter your account name and "ok" button.

    6. make sure you mark with a V the "Replace all inheritable auditing.........." and press ok.

    7. and last go to "permissions" tab, choose your profile and "Change permissions" button.-> press "edit" on your account name and give it full access over all "folders, and all subfolders and files". press "ok". mark with a V the "replace all child object permissions......." ->press ok, ok and ok again and your done.

     

    Hope this helped it certainly helped me the issue was really the "credentials manager" folder in my user folder that appearently i didnt have access to.

    Saturday, May 15, 2010 1:21 PM
  • I followed TwoGrnThmbs's post and that worked for me.
    • Proposed as answer by Roy Hisburge Sunday, June 13, 2010 12:17 PM
    Thursday, May 20, 2010 10:20 PM
  • I faced the same problem recently.

    Tried many ways as suggested above for my Windows Vista but to none works.

    What I did to ratified the problems are as follows:

    1) Go to C:\Users

    2) Right click on User Profile & "select Properties"

    3) Uncheck "Read Only" and click "OK"

    4) Restart my PC and woolah.....it works.

     

    Just sharing it here hoping it helps.

    Sunday, June 13, 2010 12:21 PM
  • Thanks Mr. Roy Hisburge!!! Finally!!!

    System: Vista Enterprise, IE 8.0.6

    Monday, July 12, 2010 4:59 PM
  • Hey,

    I not a comp guru so i dont know where to begin far as regedit and regkey and all that. could someone please tell me how to get there to these locations on the comp so i can try some of your suggestions. thanks

     

    also, i dont have see "run" i have Windows Vista so how do i get there. thanks for your help.

    Wednesday, July 14, 2010 9:54 PM
  • All,

    I have had this issue since I installed IE8 on my XP Pro SP2 laptop.  I just did this and it fixed the issue for me.

    1.Make sure IE 8 is closed then navigate to registry key: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders

    2.Add a new “Expandable String value” inside the above mentioned key with a value name of “AppData” and a value data of “%USERPROFILE%\Application Data”.

    3.Reopen IE 8 and see if you still get the error message.


    Great Answer- this worked for me too!  Thanks.

    MICHAEL AGENS~  You are the BEST!  Doing this worked for me as well, who knew that such a stupid little problem could drive us all so crazy!  But after everything else was tried you found the fix!  Thank you SOOOOO much!
    Thursday, July 15, 2010 5:24 AM
  • I had changed my pop-up blocker settings to high just before this problem started for me. I changed the settings back to medium and the message stopped appearing. However, I can't change my default search provider, but for my needs, I'm happy.

    Thursday, August 05, 2010 4:56 AM
  • All,

    I have had this issue since I installed IE8 on my XP Pro SP2 laptop.  I just did this and it fixed the issue for me.

    1.Make sure IE 8 is closed then navigate to registry key: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders

    2.Add a new “Expandable String value” inside the above mentioned key with a value name of “AppData” and a value data of “%USERPROFILE%\Application Data”.

    3.Reopen IE 8 and see if you still get the error message.

     

    Thanks, this worked for me, Im running Windows XP Media Center 2005 SPealready had one key, I added the key above exactly and left the other key in there, existing key had following properties

    Name: Local AppData

    Type: REG_EXPAND_SZ

    Data: %userprofile%\Local Settings\Application Data

    After adding the key in the post above, left existing key in there, restarted IE and problem no longer exists, can now change default to any search provider.


    Wednesday, August 11, 2010 5:09 AM
  • Found what appears to be working for me so far at this site:

    http://foundsolutionz.blogspot.com/i...search-results



    PROBLEM #5
    An error after opening internet explorer 8: "A program on your computer has corrupted IE8 default search provider settings. IE8 will reset the search provider setting to default setting of xxx search. IE8 will open the search provider dialog where you can change your search provider".


    For the above error follow the below steps:
    1. Click Start. 2. Click Run. 3. Type in regedit and press enter. 4. In the registry editor, expand and navigate to the following registry key: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders. 5. Right click User Shell Folders. 6. Select New and then Expandable String value. 7. A new value is added in right pane. 8. Type in AppData and press enter. 9. Double click AppData. 10. Under value data type in:

    %USERPROFILE%\Application Data

    11. Note: If there is already AppData in the right pane, double click and correct it to %USERPROFILE%\Application Data

    If the above steps do not work,
    1. Click Start. 2. Click Control Panel. 3. Click User Accounts. 4. Click Create a new user account. 5. Choose appropirate name for the new user account. 5. Choose Administrator or Limited or Standard user. It's upto you. 6. Click Create. 7. Click Start, Log out from the current user account and log back in with the new one. 8. If the new user account is working for you, obviously, the old user account has got corrupted and you will have to use the new user account. Also, FYI: you can transfer old user settings and files to the new user account.
    For me, this is the best solution for this problem! especially the "create new account". At first, when i encountered these problems(my magic jack, internet explorer, M-Firefox and dekstop wallpaper were not working,) i thought my computer got a virus or whatever, then i also thought of using System Restore Point but was not working too and showed an error of 0x80070002 then i came to the point of reformating my Laptop but suddenly, i finally found this solution, it worked perfectly for me , thanks to you man! GBY!
    Sunday, August 15, 2010 1:13 PM
  • TwoGrnThmb's advice worked for me too.

    I tiped %USERPROFILE%\Application Data wrong though. Which is why it didn't work the first time for me.

    ___________________________________________

     

    brennstoffe holz holzbriketts | ofen
    Tuesday, August 24, 2010 1:01 PM
  • Doesn't work.
    • Proposed as answer by jeffdav Thursday, September 09, 2010 5:30 PM
    Thursday, September 09, 2010 5:17 AM
  • OK...I fought with this for a few weeks and tried a number of the solutions and the Appdata fix worked, BUT because I redirect my App Data, it messed up other programs on my network, so just changing the AppData registry key to %userprofile%/application data was not an acceptable fix for my workstations.  But after drilling down, drilling down, drilling down I finally found the underlying problem as to why that fixes it.  For whatever your Application Data folder is set to in the Current_user/Software/Microsoft/Windows/Currentversion/Explorer/User Shell Folders    Internet Explorer tries to create a folder for each unique user in the Microsoft\Protect folder inside of your Appdata location.  This is the problem.  If for whatever reason, the user logged in does not have Write access to the %appdata%\Microsoft\Protect folder, you will get that error.  So instead of changing my registry key to point to an Application Data directory that I didn't really want it pointing to, I used Group policy to give Everyone Write access to that %appdata%\Microsoft\Protect folder of the location I was already using and that completely fixed my problem.  I hope this helps someone else out there using Group Policy and folder redirection, because I was pulling my hair out on this one for weeks and seemingly nobody knew exactly why the error occured.
    Thursday, September 23, 2010 4:34 PM
  • OK...I fought with this for a few weeks and tried a number of the solutions and the Appdata fix worked, BUT because I redirect my App Data, it messed up other programs on my network, so just changing the AppData registry key to %userprofile%/application data was not an acceptable fix for my workstations.  But after drilling down, drilling down, drilling down I finally found the underlying problem as to why that fixes it.  For whatever your Application Data folder is set to in the Current_user/Software/Microsoft/Windows/Currentversion/Explorer/User Shell Folders    Internet Explorer tries to create a folder for each unique user in the Microsoft\Protect folder inside of your Appdata location.  This is the problem.  If for whatever reason, the user logged in does not have Write access to the %appdata%\Microsoft\Protect folder, you will get that error.  So instead of changing my registry key to point to an Application Data directory that I didn't really want it pointing to, I used Group policy to give Everyone Write access to that %appdata%\Microsoft\Protect folder of the location I was already using and that completely fixed my problem.  I hope this helps someone else out there using Group Policy and folder redirection, because I was pulling my hair out on this one for weeks and seemingly nobody knew exactly why the error occured.
    Thursday, September 23, 2010 4:34 PM
  • I have the exact same problem today Sept 2010. This problem has been talked more than 2 years and found in lots of places. Why did Microsoft not put a fix with it. I downloaded IE8 from windows updates yesterday. The popped message annoyed me for 2 full days. I tried several methods based on some suggestion but failed.  Today, I found a better way to remove this problem easily without messing up regedit. I downloaded toolbar from toolbar.yahoo.com And let yahoo search be the default search provider. It works beautifully without pop the annoying window box. I tried windows live essential and google toolbar and default to their search engines. Both were failed. Try yahoo if others failed.
    Friday, September 24, 2010 6:50 PM
  • One user ecounterd the same problem. I found it might be the same cause of msn won't remember user's information. The yahXX toolbar installer modifies the registry value to 

    [HKEY_USERS\xxxxxx\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders]
    AppData = %AppData% 

    But [AppData = %AppData%] should be [%USERPROFILE%\Application Data]

    So I suggest him to try "make messenger remember" to fix this problem. It worked.

    So if you encounter the same problem after installing yahXX toolbar, you may try this freeware to fix.

    Monday, October 11, 2010 3:48 AM
  • thank you
    Sunday, October 31, 2010 4:19 PM
  • Same problem here all of a sudden... last thing I remember I was installing a new Adobe flashplayer. It completed allright. I decided to tweak some settings on my router after which I had to reset it due an error on my part.

    Anyway: tried all the suggestions above, but none work for me. Yahoo toolbar doesn't stop the message, tweaking the keys manually doesn't either...

     

    Edit: hmmm... looks like it did... don't forget to reboot your pc... :)

    Sunday, November 07, 2010 11:23 AM
  • Thanks rtk217de.

    Changing the permissiosn works for me.

    I need to change the security on  "C:\Users\your user name here\AppData" and  "C:\Users\your user name here\Application Data".

    Right click the directory then choose "Properties->Security->Edit" to change the permissions and make sure it's writable.

    Friday, November 12, 2010 7:59 PM
  • Here's the ONLY solution that really WORKS!!!! I tried all the solutions here and nothing worked. Then, I installed Google Chrome Browser - and then, UNINSTALLED IT. After the uninstall, you will be asked if you want IE8 to be your default browser. Check "yes" - next, you'll be asked to choose a default search provider - (it doesn't matter which one you choose) - then, check the box on the bottom that your search choice will be your default search add on. AND THAT's IT!!!

    Forget about every other bizarre "solution" here - this takes 10 minutes and the problem is over - NO MORE POP-UPS to aggravate the ____ out of you.

     

    Wednesday, November 24, 2010 3:25 AM
  • Excuse my ignorance but, how do I "... then navigate to registry key:???
    Saturday, November 27, 2010 11:50 PM
  • HKLM is Good dont touch it

    ther's a problem with HKCU

    had the same problem with ie8 tried every possible thing reseting ie deleting keys add delete search providers. nothing worked.

    finally i had to remove the profile and that worked ..

     

    its easy to create another account move your stuff into new one

    and have fun.

    Sunday, November 28, 2010 10:06 PM
  • Thanks Michael.  This worked for me.
    Thursday, December 02, 2010 2:30 AM
  • This problem turned up again today.... The solution provided by "/SgxMan (SWE)" worked like a charm... log in as admin, and change the default search provider from there.

    Same can be applied for the Outlook account / password issue. Simpy run as admin, send / receive and close outlook.

    After a reboot the normal user account worked again.

    Monday, December 06, 2010 6:20 PM
  • Thanks twogrnthmbs!

    I just signed in to this forum just so that I can properly thank you.  After reading several forums top to bottom, I was considering to follow Michael Agens' proposal, which is basically a summary of your instructions.  I just followed your 1st set of instructions to 11. without deleting anything--as there was a "(default)" and "Local AppData" in the right pane--and I try not to delete things that I don't understand.  For really simple people like I you might have also added "don't forget to reboot!".  It did not corrupt--thus far--my Adobe either.  I've read that this solution did not work for some people.  I use XP Pro and so far that I read in various forums, it is not working well mainly for Vista users.  Thanks again.

    Thursday, December 09, 2010 10:45 AM
  • Thank you. It worked!!!
    Wednesday, January 12, 2011 5:57 PM
  • Today I had the same problem you did in April 2009!  Your solution took care of that irritating problem.

    Many thanks!!!


    Keith P

    Wednesday, February 02, 2011 6:09 PM
  • Im using a Vista Ultimate edition and am having this issue as eveyone else when i tried your suggestion no matter which alternitive search provider i chose it would not  respond to "make this search provider your default" not when the confermation window popped up not when i selected it from my search manager or even when i right clicked and tried the make default  selection.

    Sunday, February 13, 2011 2:23 AM
  •  

     

    wow. something finally clicked.....

    I've been fighting this problem for the last couple weeks, and reading lots of posts here, and generally feeling WAY over my head

    '.....and just edit the registry as an expandable string...."   what the ?!?  

    some of you folks ought to try and remember that many of us really need to be lead through these answers / solutions in tiny baby steps.....  assume that we know nothing!   several times in this long thread people post to 'edit the registry...' --  and then someone answers back "how do you do that?"  --  and sometimes an 'explainer' is never offered....

    but anyway, this is a "good news" story:

     

    I was scanning through this thread to try and find some help, and saw that checkpoint's post ended on the fateful words

     

    " ........ MAKE SURE IT'S WRITABLE"

     

    like most people who have the:

    "a program on your computer has corrupted your default search provider......."

    error message start plaguing them, I tried to figure out what had changed....

     

    checkpoint's comment jogged my memory that just before I had this problem begin I had a different IE8 problem, and in floundering around in my attempts to fix that I accidently 'write-protected' many of the files on my HDD (don't ask  --  it was a stupid mis-understanding on my part...) anyway, I realized That I had never un-done that error, so perhaps something somewhere (the registry?) was now write-protected and it therefore was not allowing changes to be made that would allow for default search providers to be changed, etc. etc.

     

    not knowing which file(s), or even where the registry resides, I just un - write-protected everything in my "documents and settings" file.

     

    --------steps--------

    open (double click) "my computer"

    open (double click) "C-drive"

    right-click "documents and settings", and select "properties" from the menu which appears.

    the "read only" box was filled, meaning some files were write-protected, some weren't. 

    I clicked it to clear it, and hit "apply".

    a dialog box opened asking if I wanted to apply this to all branches, sub-folders, etc  --  I hit "yes".

    a dialog box opened listing some file (I don't remember what) which could not be reset  -- I selected "ignore all".

    and then off it went.

    It took about 20 minutes but all the files were reset, and all my error messages and problems (locked-in default search provider, etc) have vanished!

     

    Halleluja!

     

    I certainly understand that mine was a sort of blunt-force method, removing the write-protection from damn-near everything.   hopefully this won't come back to bite me in the ass......   perhaps someone out there could suggest exactly what (the registry file?  other files?) should be checked for write-protection for a more finesse-ful solution to curing this problem in this way.

    as many have noted in this thread, there seem to be a number of things that can cause the "corrupted search provider" error message, and each different cause will probably need its own solution...

    but for me, removing "write protection" did it!

     

    btw, I'm running IE8 on a 6(?) year-old laptop with XP installed as the operating system.

     

    I hope this helps others.

     

    regards,

    andy

     

    Tuesday, March 08, 2011 9:39 PM
  • Not able to post anything. It's not allowing any changes
    Friday, April 15, 2011 5:03 PM
  • I finally got this resolved with media center 2005 sp3.  These are the steps I used.  There was alot of trial and error so I suspect there are some steps that weren't needed.  With only the live search provider installed and getting the error message I:

    1. Added google search provider
    2. exported HKCU\Software\Microsoft\Internet Explorer\SearchScopes
      1. The export file contained keys for both the live search and google search providers
    3. deleted the HKCU\Software\Microsoft\Internet Explorer\SearchScopes key
    4. deleted the HKLM\Software\Microsoft\Internet Explorer\SearchScopes key
      1. Alexi doesn't say to delete the HKLM SearchScopes, but I did after only deleting the HKCU key didn't work
    5. add the following key: HKCU\Software\Microsoft\Internet Explorer\User Preferences
      1. Alexi says to delete, but I didn't have it in the first place so I just created the empty key
    6. add the following key: HKLM\Software\Microsoft\Internet Explorer\User Preferences
      1. Alexi says to delete, but I didn't have it in the first place so I just created the empty key
    7. followed Michael Agens' steps
      1. navigate to HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders
      2. Add a new “Expandable String value” inside the above mentioned key with a value name of “AppData” and a value data of “%USERPROFILE%\Application Data”.
    8. started IE8 - no search providers were listed, no error message, but when I tried to install one it nothign happend.
      1. something actually was happening behind the scenes because i noticed searchscopes came back with some values about download retries
    9. clicking in the search provider text box crashed ie
    10. restarted ie, closed it out, ctrl+alt+delete to kill all iexplore.exe processes
    11. import the search scopes exported in step 2.
    12. open ie, search providers now worked.  was able to set google to default, add amazon, and switch live back to default without any errors.

     


    As I was following BRIANE26's fix above, I realized that the registry key on step #5 above was "protected" and I couldn't export or delete it. I had to first right click on the key and go to PERMISSIONS to that key and allow myself (administrator) to have full control. After that I was able to delete the step 5 key. Guess what? That fixed the "Manage Add-ons" window popping up on every IE8 start.

    BOTTOM LINE: The "User Preferences" key had been protected with DENY access to Administrator (corrupted maybe?), causing IE8 to not be able to write to it in the first place.

    Thanks Briane26 for pointing me to the right direction!

    Charlie

    Tuesday, April 19, 2011 7:45 PM
  • Thank  you Michael Agens,

    Worked for me!

    Saturday, May 21, 2011 4:09 PM
    • Edited by gsl27 Tuesday, May 24, 2011 3:47 PM linking and bold text
    Tuesday, May 24, 2011 3:45 PM
  • Dear Lake forest Andy,

     

    I don't know how to thank you !

     

    I was getting this problem with IE and also Outlook was affected during the past week ! I spent most of time during these 7 days looking around on the internet and trying everything possible including the registry editing, but only your solution was able to solve both my problems !

     

    I really owe you something ! It is quite a relief now everything seems so easy !

     

    Thanks again !

    • Proposed as answer by THE SlLVERF0XX Wednesday, June 01, 2011 11:59 PM
    • Unproposed as answer by THE SlLVERF0XX Wednesday, June 01, 2011 11:59 PM
    Wednesday, June 01, 2011 10:22 AM
  •  

    Vista Ultimate with IE9
    •  What worked for me was removing everything in "C:\Users\MyProfile\AppData\Roaming\Microsoft\Protect".  (had to use procmon.exe to see the cause)
    •  There was a file "CREDHIST" and a folder with my SID as its name. 
    •  I moved them to another directory. 
    •  Restarted my IE9 and the pop up stating that a program has corrupt the search provider stopped.

    What hasn't worked for me:

    • renaming "appdata\roaming" to "application data" in the "HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders\appdata" (this was a fix for XP users)
    • resetting IE to default in options
    • renaming "HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\User Preferences"
    • renaming "HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\searchscopes"


    Thursday, June 02, 2011 12:24 AM
  • SilverFox,

    I just fixed a Vista machine by adding one registry key and I suspect you have the same problem.

    Check the two following keys:

     

    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders\AppData = %USERPROFILE%\AppData\Roaming

     

    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders\Local AppData = %USERPROFILE%\AppData\Local
    Friday, June 03, 2011 5:40 AM
  •  

    Those were my first tries after google searching.  Those values were already in my registry.  The problem stopped when I did the below:

     

    "...removing everything in "C:\Users\MyProfile\AppData\Roaming\Microsoft\Protect". 

     

    I downloaded and ran procmon.exe from systernals.  I monitored what was occuring when the popup appeared. 

    At the exact moment the popup appeared procmon.exe showed something occuring in C:\Users\MyProfile\AppData\Roaming\Microsoft\Protect.

    Saturday, June 04, 2011 4:32 PM
  • I was able to get this to stop happening in IE8 (Windows 7 64 bit) by going to the Manage Add-ons -> Search Providers screen and checking the box labelled "Prevent programs from suggesting changes to my default search provider."

    Worked for me.

    Tuesday, June 14, 2011 11:18 AM
  • If you have been getting a pop-up when you open Internet Explorer that says, "A program on your computer has corrupted your default search provider setting for Internet Explorer. Internet Explorer has reset this setting to your original search provider, [insert provider here].  Internet Explorer will open Search Settings, where you can change this setting or install more search providers."
    We have dealt with this on multiple computers and have decided to try and help everyone that has come across this issue.  We offer both a way to fix the program manually or through a utility provided by Cloud Tek Software.

    Manual Steps For Correcting Error
    Step 1:
    Close out of all programs, especially Internet Explorer
    Step 2: 
    Go to Run and type in regedit
    Step 3: 
    Local and remove the registry key HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\SearchScopes
    Step 4: 
    Locate and remove the registry key HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\User Preferences
    Step 5:
    Locate and remove the registry key HKEY_LOCAL_MACHINE\Software\Microsoft\Internet Explorer\SearchScopes
    Step 6:
    Locate and delete the folder RootDrive:\Users\[Your User]\AppData\Roaming\Microsoft\Protect
    Step 7:
    Exit out of regedit, and restart your computer.

    Or, if you do not feel comfortable doing this yourself, you can use the utility provided by Cloud Tek Software.  They provide it free of charge, and all they ask is that if helps you that you donate any amount you feel like it was worth.  Just download and run the utility and it will make all the necessary changes for you.  Be sure to run the utility as an administrator.

    Wednesday, June 15, 2011 2:05 PM
  • Manual Steps For Correcting ErrorStep 3: 
    Local and remove the registry key HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\SearchScopes
    Step 4: 
    Locate and remove the registry key HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\User Preferences
    Step 5:
    Locate and remove the registry key HKEY_LOCAL_MACHINE\Software\Microsoft\Internet Explorer\SearchScopes
    Step 6:
    Locate and delete the folder RootDrive:\Users\[Your User]\AppData\Roaming\Microsoft\Protect

     Thank you for adding this information as I am now experiencing the same issue which apparently has been a long lasting issue.

    Although it did indeed stop the popup in IE8 it has no search engine as an option and when I go to add one nothing seems to happen. I have tried Google as a default and Bing both as a default and not as a default. I had closed and restarted IE8 a couple of times but no joy. If I click on the search box it quickly closes IE8.

    One interesting note is that I had previously uninstalled IE8 and reverted to IE7 (automatically) and the popup no longer happened and the search options (i.e. changing the default search engine) was working fine. I find that a little strange.

    I hope I am not responsible for the fact that I can no longer do a search as I deleted (including) the top level of what is listed. For instance ....... Microsoft\Internet Explorer\SearchScopes -- I deleted SearchScopes and everything below it. Same with User Preferences and HKLM.....SearchScopes.

     

    On a side note for anyone with WinXp the location of the Protect folder is: RootDRive (i.e. c:) \documents and users\userprofilenamehere\Application Data\Microsoft\Protect.

    ---------------------------------------------------------------

    Although I do not know for certain but I am pretty sure that at least part of the issues occurred after I was running a defragmentation program that for some reason suddenly rebooted the system and the next day WinXp Home told me that that the image file WINMM.exe and after restoring that from the XP CD said that the image file for WINSPOOL (Both .DLL, I think) were incorrect. Getting both those replaced yielded no further booting up error messages but something like the day after that there was an issue with compacting Outlook Express 6 and the message store was corrupted. I know have an issue with not being able to log onto the administrator account, files/directories I am not used to seeing are popping up as well as this issue with the search engine options in IE8.  I don't know if any of it can be connected to what others are experiencing but wanted to add it just in case.

     

    What should I do know?  Restore? I assume everything will go back in place other than the deleted protect sub-directory.

     

    Thank you much,

    Mumford68

    Wednesday, August 31, 2011 5:28 AM
  • After considering my post and reading others I tend to think that at least some are affected by a permissions issue or a corrupt profile.

     

    I have seen the suggestions for settings permissions for a couple of directories but am not sure what/if any security issues that can entail or to start a new profile (which I would think would correct my issue but I have no idea how to get everything from my current profile to a new one, that is if nothing corrupt is transferred over).

     

    Most people (including myself) do not have the ability to tweak the registry or try to transfer a complete profile over and may not be able to correct an issue should something go wrong along the way.

    I was amazed to see such a long history of this issue which just shows that there are a lot of factors that go into programming an OS such as this and although a new profile would probably do it I hope a simpler solution that works for at least most will be found.

    Wednesday, August 31, 2011 7:24 AM
  • Guys, real simple - I noticed that newer installations from IE8 onwards all had this problem which seemed to stem from Microsofts new presentation of Default Search Providers.

    If you click on this link:

    http://www.microsoft.com/windows/ie/searchguide/en-uk/default.mspx?dcsref=http://runonce.msn.com/runonce2.aspx#

    It will bring you to their previous, original listing which still works a treat!

     

    No need for the PHD in registry modification!

     

    Enjoy!

    Tuesday, September 06, 2011 11:30 AM
  • I also discovered this problem as soon as I used windows media centre. brand new computer too. Windows gives no specific description as to problem or solution. trading for MAC. these kind of things should not happen, inferior programs, software and opperating systems. thats why theres an app for that. if it wasnt for downloading, computers would be useless
    Saturday, February 11, 2012 1:43 AM
  • All,

    I have had this issue since I installed IE8 on my XP Pro SP2 laptop.  I just did this and it fixed the issue for me.

    1.Make sure IE 8 is closed then navigate to registry key: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders

    2.Add a new “Expandable String value” inside the above mentioned key with a value name of “AppData” and a value data of “%USERPROFILE%\Application Data”.

    3.Reopen IE 8 and see if you still get the error message.

    Doing this allowed me to install Google search provider and FINALLY delete Live Search.

    THANK YOU!!!

    Friday, May 04, 2012 5:35 PM
  • All,

    I have had this issue since I installed IE8 on my XP Pro SP2 laptop.  I just did this and it fixed the issue for me.

    1.Make sure IE 8 is closed then navigate to registry key: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders

    2.Add a new “Expandable String value” inside the above mentioned key with a value name of “AppData” and a value data of “%USERPROFILE%\Application Data”.

    3.Reopen IE 8 and see if you still get the error message.

    Tried first deleting

    HKCU\Software\Microsoft\Internet Explorer\SearchScopes

    HKCU\Software\Microsoft\Internet Explorer\User Preferences

    That didn't work, then I tried this, and it fixed it, was able to set google as the default and delete Live Search.

    Don't ask me how, I don't understand any of it, but I know how to follow directions, and now it is fixed.

    • Edited by MoSeS6533 Tuesday, June 26, 2012 3:14 PM
    Tuesday, June 26, 2012 3:13 PM
  • Thanks Michael your answer solved it for me.

    All,

    I have had this issue since I installed IE8 on my XP Pro SP2 laptop.  I just did this and it fixed the issue for me.

    1.Make sure IE 8 is closed then navigate to registry key: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders

    2.Add a new “Expandable String value” inside the above mentioned key with a value name of “AppData” and a value data of “%USERPROFILE%\Application Data”.

    3.Reopen IE 8 and see if you still get the error message.

    Saturday, August 04, 2012 12:03 AM
  • Beautiful. Worked like a charm, thanks. 
    Friday, February 08, 2013 2:33 PM
  • I found a very simple solution to this problem see pasted text from this link below - this fix worked when the others listed here did not - I don't know if what was in my resistry for the value that was replaced as per the instruction below (value was shdocvw.dll) is representative of malware or a virus or something else - but when I replaced it with the value listed below which I found to be correct on other "working" computers (XP, Vista, Win 7) I changed it and it worked like a charm -- good luck.

    they wont let me post the link where I got this because I am new - sorry

    _________________________________________________________________________________________________________________________

    My problem on an XP SP3 with IE8 was I could not change or add search providers through normal MS Add On Page bit could add obscure Search providers by visiting web sites that used them for example - You Tube and Amazon - they do not use Yahoo or Google - but some home grown search that I was able to add cia the IE search provider button at the top of the IE page (upper right hand corner pull down menu) only this way did the Java script activate bringing up the pop up menu to add a new provider - when I tried this thru MS add on website - and I selected lets say Google - I would get to the Google page but when I clicked to Add Google - the page did not bring up pop up menu to confirm add on and I got a script error (small font message at the lower left hand side of the page - can hardly see it when you click the button to add) - this simple fix worked like a champ

    Chris

    Most Helpful Reply

    Riker 2335

    replied on
      I understand that ControlX was able to copy the registry from one computer to another to resolve this problem in the first place, I've also had a similar problem that was rectified using the method detailed here:

    In case the web link falls over in the future, the summary is as follows:

    Open Regedit and navigate to HKCR\TypeLib\{EAB22AC0-30C1-11CF-A7EB-0000C05BAE0b}\1.1\0\win32\

    Ensure the default key in this registry entry references the file c:\Windows\system32\ieframe.dll

    If not, edit it so it does.

    I'm sorry for bringing up an old thread but I thought it worthwhile to include that info in case anyone else struggles to find the answer in the future.

    Riker.

    Friday, May 10, 2013 2:11 AM
  • This is the only thing that worked for me and I tried pretty much everything else to try.  No more manage search providers window coming up.

    THANKYOU!!!

    Saturday, July 27, 2013 6:50 PM
  • I have this problem with Vista Ultimate and IE9. Just started. I gave up and disabled seach from the address bar to get rid of this anoyance.
    Saturday, July 27, 2013 6:53 PM
  • I take it back, still have the problem
    Saturday, July 27, 2013 7:04 PM
  • Visit the IE forum on answers.microsoft.com. This forum is for help in writing web sites, and web developers assume their visitors have a working browser to reach their web sites.


    Visual C++ MVP

    Sunday, July 28, 2013 3:28 AM
  • For the record, I was experiencing the same issues and the suggestion of "deleting both HKCU\Software\Microsoft\Internet Explorer\SearchScopes and HKCU\Software\Microsoft\Internet Explorer\User Preferences" worked for me!

    Thanks!

    Monday, February 17, 2014 10:31 PM
  • Deleting the following key solved this issues for me:

    1. deleted the HKCU\Software\Microsoft\Internet Explorer\SearchScopes\DefaultSearch key

    After removing some malware, the error started popping up when I would open IE11. I had to change the permissions "SearchScope" Folder in the registry because it would not allow me to delete it. Seems like the malware set the permissions to "Deny". Remove the "Deny" permissions and deleting the key resolved my issues. 

    Thanks for pointing me in the right direction. Hope this helps other out.

    Wednesday, April 02, 2014 12:43 AM