none
How to disable security warning "Your current security settings put your computer at risk"

    Question

  • Hi,

    I wonder if able to disable the security warning bar at the bottom of the IE window.  I enabled the ActiveX control and plug-ins in the IE Option settings, this caused the  security warning "Your current security settings put your computer at risk" pop up whenever load the pages.  Is there a way can turn off this warning?

    Thanks a lot for helping!

    Wednesday, September 26, 2012 2:07 AM

All replies

  • Hi

    This feature can be controlled using Group Policy but we do not provide a way in the user interface of turning off this feature. This is because putting your security settings at a non-recommended level has been one of the most common vectors of attack for spy ware in the past. Users of older versions of IE often put their computers at risk temporarily to avoid application compatibility issues with other applications and would then forget to set their security settings back to the recommended level. Spyware would then use this opportunity to effectively take over the computer. Although we want to continue to provide the ability to set your settings to a level that allows you to work with other applications, we also want to prevent you from keeping your settings in an insecure state for a long period of time in order to reduce the attack surface area that spyware has on your computer.

    Hope heipful to you.

    Friday, September 28, 2012 1:43 AM
  • Works like a charm! 

    This is exactly I'm looking for.  Thanks for the appropriate answer!

    Monday, October 01, 2012 4:18 PM
  • This was simple and worked. Microsoft should consider including option to disable the annoying messages!!!
    Thursday, March 14, 2013 6:20 PM
  • this crap doesn't work.
    • Proposed as answer by Carlos Ch Saturday, September 14, 2013 5:56 PM
    • Unproposed as answer by Carlos Ch Saturday, September 14, 2013 5:56 PM
    Sunday, September 08, 2013 9:17 AM
  • Hi Denis, to use this recommendation, I had to go to the key HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Internet Explorer\Main\FeatureControl\FEATURE_SECURITYBAND, because my machine is a 64 bit system.

    It may be your case. Regards!

    • Proposed as answer by Carlos Ch Saturday, September 14, 2013 5:58 PM
    Saturday, September 14, 2013 5:58 PM
  • Ok @Angie Lu, you really haven't given us a solution, have you?  Please don't dance around the question.  The only remotely useful answer I got is from Carlos Ch.  My question now is, what should I do with that registry key?  I'm at the key but not sure what to do in order to disable this annoying security risk prompt. 
              
    Sunday, November 03, 2013 12:48 AM
  • Setting the registry key Carlos cites is a terrible idea because it breaks many of the notification bars in IE, not just the one mentioned.

    The correct way to get rid of this prompt is to reconfigure your security settings so that they are secure, using either the notification bar's button or the RESET button inside Tools > Internet Options.

    As Angie notes: there's no option in IE's UI to turn off this warning. The warning means, literally: "You are browsing with security settings that will allow any website to take over your computer without any warning." Browsing with such settings is akin to handing out copies of your debit card and PIN to every stranger you pass on the street and hoping that none of them will take advantage of your foolishness.

    If you need to have insecure settings for a particular site (still risky, but not entirely insane) you should add that specific site to the Trusted Sites zone and configure the Trusted Zone's security settings to be dangerously insecure.


    Monday, November 04, 2013 5:10 AM
  • There are cases where a knowledgeable user would want to turn this "feature" off.  I use IE solely for managing an internal web app, and I know it is safe, and it runs directly from a file on my machine.  It links via ActiveX code to some internal sites and is perfectly safe to run on this particular machine.  Having this message pop up every time I open the page that controls all this fun activity is just an annoyance, but one I would like to be rid of.  Is there an easy way to add a local file as a "Trusted Site"?

    • Proposed as answer by Sojourn87 Friday, November 22, 2013 7:47 PM
    • Unproposed as answer by Sojourn87 Friday, November 22, 2013 7:47 PM
    • Proposed as answer by Sojourn87 Friday, November 22, 2013 7:48 PM
    Thursday, November 21, 2013 3:01 PM
  •  and it runs directly from a file on my machine.

    Use HTA.


    Rob^_^

    Saturday, November 23, 2013 4:44 AM
  • Using Trusted Sites still brought up the totally irratating warning (on every single page) so I just downloaded Firefox and may never come back to Internet Explorer.  If you don't make this feature more user friendly and a whole lot less irratating, you are apt to lose a lot more customers.

    Saturday, December 14, 2013 6:50 PM
  • Your suggestion doesn't work.  Added the site to Trusted, still pops up.

    Not everyone is even accessing the Internet!  I use it inside a VM, connecting via a VPN to only one site EVER (a single Citrix server).  It won't go away, it's highly annoying.  Thanks M$, but leave the control to the end-user.  It's nice that they feel the need to be a bunch of nanny-state socialists with non-disableable "warnings", but some of us actually know what we're doing.

    So, is there are REAL solution, or should I seriously push for my company to just abandon M$ and go to Chrome / FF?

    Sunday, December 15, 2013 8:20 PM
  • @Mathew.

    f12>Console tab, refresh the page... the IE developer tool will list the resources that are not using the https protocol. Correct your website as required.

    tip: use a protocol-less resource call like api.google.com recommends.


    Rob^_^

    Monday, December 16, 2013 7:36 AM
  • People who use PCs like to configure and customize things, otherwise they would use a Mac. This attitude that "we are doing this for your own good", and "there's no way to change this" are poor responses, and an ever-growing mindset from MS. We the users accept the risks that we take. Furthermore, this annoying warning shows up when you set unsigned activeX controls to PROMPT you when they want to install, so it's not automatically turning your PC into a zombie, it's offering a choice. You are incorrect. There is no reason to come across as an all-knowing school master.
    Friday, January 10, 2014 10:15 PM
  • How I fixed this for me by using gpedit.msc which is your local policy editor. Opened Computer Configuration, Administrative templates, Windows Components, Internet Explorer, Security Features, Local Machine Zone Lockdown Security, I then disabled Internet Explorer Processes.  I'm working on a some local JavaScript and wanted all pops to not be there.  I then reset all the security settings on IE to low settings, no more pop ups :).


    Gary Newman MCSE, MCT, CCNA MCDBA, MCAD, MCSA MCTS SharePoint 2007 Dev & Admin MCPD SharePoint 2010 Development My Blog www.sharepoint2010now.com

    Friday, April 04, 2014 5:22 PM