none
Internet Explorer 8 and Internet Explorer 9 not playing Flash streaming media

Answers

  • "We are unable to connect to the content you've requested. We apologize for the inconvenience" is  message from the facebook cdn servers... which confirms the 404 response code.

    You may like to try the FB developers forums...

    In IE ensure you have set the default security zone settings... Tools>Internet Options, Security tab, click "Reset all zones to default"

    and that you have not turned on InPrivate Filtering (content blocking) and are accepting third-party cookies and of coarse that one of your IE Addons is not also filtering content (test by running IE in noAddons mode).

    Regards.

    There was some mention about incompatible FB apps on the PBS newshour... I have not looked into this further, but you may like to search pbs.org to see if you can find further information.

    Oh, also... Facebook have only recently added fbcdn.net to their domains... previously static.facebook.com was the primary cdn... In the public answers forum there are a few new questions about blocked FB content. I think these are related and may be just a dns issue, but probably a content blocking issue, although a 404 response indicates a dns issue.

    No problems accessing

    http://video.ak.fbcdn.net/cfs-ak-snc6/78749/825/107419042660481_61727.mp4

    from my browsers. (InPrivate Filtering Off.... COM Addons disabled).


    Rob^_^
    Monday, January 03, 2011 9:17 PM

All replies

  • "We are unable to connect to the content you've requested. We apologize for the inconvenience" is  message from the facebook cdn servers... which confirms the 404 response code.

    You may like to try the FB developers forums...

    In IE ensure you have set the default security zone settings... Tools>Internet Options, Security tab, click "Reset all zones to default"

    and that you have not turned on InPrivate Filtering (content blocking) and are accepting third-party cookies and of coarse that one of your IE Addons is not also filtering content (test by running IE in noAddons mode).

    Regards.

    There was some mention about incompatible FB apps on the PBS newshour... I have not looked into this further, but you may like to search pbs.org to see if you can find further information.

    Oh, also... Facebook have only recently added fbcdn.net to their domains... previously static.facebook.com was the primary cdn... In the public answers forum there are a few new questions about blocked FB content. I think these are related and may be just a dns issue, but probably a content blocking issue, although a 404 response indicates a dns issue.

    No problems accessing

    http://video.ak.fbcdn.net/cfs-ak-snc6/78749/825/107419042660481_61727.mp4

    from my browsers. (InPrivate Filtering Off.... COM Addons disabled).


    Rob^_^
    Monday, January 03, 2011 9:17 PM
  • Hi,

    I am a bit confused... mp4 is an unexpected format for a Flash player (using object or embed tags)... the mime type is usually associated with WMP or the new HTML5 <video> tag...

    In IE9 Beta you need the document to render in IE9 mode (document.documentMode==9) AND your page needs to be using the HTML5 DTD.

    Observe the Document Mode that your FB page renders in... Facebook is probably in the "Include updated website lists from Microsoft" (Tools>Compatibility View Settings) and IE9 is forcing it to use IE8 or IE7 Emulation rendering, which will ignore the <video> tag and will fall back to the <object> and <embed> tag fallbacks.

    see http://iecustomizer.com/MSMVP/HTML5/HTML5Tags.aspx

    At the bottom of the page your will see the <video> tag listed... It uses a html5 video tag (which uses the native video player of the browser) with an <object> and <embed> fallbacks.... here is a html snippet of the source...

    <td><p>&lt;video&gt; tag with empty src attribute</p><video class=style1 title=video src="" preload="" loop="" controls="controls" autoplay="" height="264" width="640">
    <p>your browser does not support the video tag</p></video>
    <p>Fallback test</p><video id=example_video_1 class=video-js preload="auto" controls="controls" height="264" width="640" poster="oceans-clip.png"><source src="http://video-js.zencoder.com/oceans-clip.mp4" type='video/mp4; codecs="avc1.42E01E, mp4a.40.2"' /><source src="http://video-js.zencoder.com/oceans-clip.webm" type='video/webm; codecs="vp8, vorbis"' /><source src="http://video-js.zencoder.com/oceans-clip.ogg" type='video/ogg; codecs="theora, vorbis"' /><!-- Flash Fallback. Use any flash video player here. Make sure to keep the vjs-flash-fallback class. -->
    <object class=vjs-flash-fallback data="http://releases.flowplayer.org/swf/flowplayer-3.2.1.swf" width=640 height=264 type=application/x-shockwave-flash>
                                        
                <!-- Image Fallback. Typically the same as the poster image. -->
                <img src="oceans-clip.png" width="640" height="264" alt="Poster Image"
                 title="No video playback capabilities." />
               </object></video></td>

     

    In IE9 view my test page and use the Developer tool to toggle the Document Mode between 7,8 and 9 to see how the fallbacks work when then Document Mode is toggled.

    As I said observe the Document Mode that your FB page loads in IE9... I suspect it will not be 9... go Tools>Compatibility View Settings and uncheck "Include updated website lists from Microsoft" and then reload your FB page... I expect that this time it will render in DocumentMode==9, honoring the HTML5 DTD, and (maybe) using the <video> tag....

    In IE9, documentMode==9 elements with an empty scr value do not raise a request to retrieve the empty resource value... other browsers do not yet comply with the standards... (load my above test page in another 'standards' compliant browser).

    Is it a bug? The FB api's are probably using userAgent sniffing to determine whether to use (inject with document.writes) either <video> or <object> or <embed> tags based on the UAS browser version. It may be incorrectly detecting the (new) IE9 userAgent value in the Request header. (use Developer Tool>Tools>change user Agent string to test this).

    Do you have a publicly accessible link to a test harness page or you can give directions as I have a FB account. A link to the FB developer documentation would also assist.


    Rob^_^
    Tuesday, January 04, 2011 4:02 AM