none
<meta http-equiv="X-UA-Compatible" content="requiresActiveX=true"> doesn't work in IE10 Metro / Windows 8 RTM

    Question

  • Hi, 

    I've tried to make a very simple page to illustrate the switch between IE 10 metro and IE 10 desktop but it doesn't work. I don't see any popin that propose user to switch to Desktop mode.

    Here is the code of my page

    <!DOCTYPE html>
    <html>
    <head>
    <meta http-equiv="Content-Type" content="text/html; charset=UTF-8">
    <meta http-equiv="X-UA-Compatible" content="requiresActiveX=true">
    <title>test redirection on IE 10 metro</title>
    </head>
    <body>
    <object class="silverlight box" data="data:application/x-silverlight-2," type="application/x-silverlight-2" height="310" width="512">
    <param name="source" value="/wptv/services/common/widgets/player/silverlight/bin/CorePlayer.xap"/>
    <param name="background" value="transparent" />
    <param name="initParams" value="jsId=monPlayer,JSEnabled=true,mode=VOD,logUrl=toto" />
    <param name="minRuntimeVersion" value="4.0.0" />
    </object>
    </body>
    </html>

    does anyone success on displayin popin with last verstion of Win8 and IE10 metro ? Like it is annouced in this article : http://blogs.msdn.com/b/ie/archive/2012/01/31/web-sites-and-a-plug-in-free-web.aspx

    thanks for your answers

    Thursday, August 23, 2012 1:51 PM

Answers

  • is your server already sending an x-ua response header? the server header x-ua takes precedence over any inline x-ua meta....

    only one x-ua meta is recognised.... so you may have x-ua server Ie=edge already... change to IE=edge,requiresActiveX=true

    add a fallback to your <object> tag to determine if the SL object sucessfully loads....

    or debug in IE10 desktop mode with the Developer tool visible so that you can see all script errors. or any x-ua resets... we cannont use your snippet... please provide a link to your website or to a mashup that has all of the required resources and links. We also need to see your servers response headers for any x-ua directives.

    <object ........>

    ........

    .......

    <p>Silverlight failed to load.... try turning off ActiveX filtering or download the latest silverlight version from here...</p>

    </object>

    further see: http://blogs.msdn.com/b/ieinternals/archive/2011/07/18/optimal-html-head-ordering-to-avoid-parser-restarts-redownloads-and-improve-performance.aspx


    Rob^_^


    • Edited by IECustomizerMVP Friday, August 24, 2012 3:09 AM
    • Proposed as answer by IECustomizerMVP Tuesday, August 28, 2012 5:01 AM
    • Marked as answer by mbrechet Wednesday, August 29, 2012 10:27 AM
    Friday, August 24, 2012 3:03 AM

All replies

  • is your server already sending an x-ua response header? the server header x-ua takes precedence over any inline x-ua meta....

    only one x-ua meta is recognised.... so you may have x-ua server Ie=edge already... change to IE=edge,requiresActiveX=true

    add a fallback to your <object> tag to determine if the SL object sucessfully loads....

    or debug in IE10 desktop mode with the Developer tool visible so that you can see all script errors. or any x-ua resets... we cannont use your snippet... please provide a link to your website or to a mashup that has all of the required resources and links. We also need to see your servers response headers for any x-ua directives.

    <object ........>

    ........

    .......

    <p>Silverlight failed to load.... try turning off ActiveX filtering or download the latest silverlight version from here...</p>

    </object>

    further see: http://blogs.msdn.com/b/ieinternals/archive/2011/07/18/optimal-html-head-ordering-to-avoid-parser-restarts-redownloads-and-improve-performance.aspx


    Rob^_^


    • Edited by IECustomizerMVP Friday, August 24, 2012 3:09 AM
    • Proposed as answer by IECustomizerMVP Tuesday, August 28, 2012 5:01 AM
    • Marked as answer by mbrechet Wednesday, August 29, 2012 10:27 AM
    Friday, August 24, 2012 3:03 AM
  • Hi,

    Effectively I've already a x-ua positionned in my apache damned !

    thanks for your help !

    MBrechet

    • Marked as answer by mbrechet Wednesday, August 29, 2012 10:26 AM
    • Unmarked as answer by mbrechet Wednesday, August 29, 2012 10:27 AM
    Friday, August 24, 2012 10:33 AM