none
IE7 Internet Explorer hangs indiscriminantly on opening New Tab or Browser

    Question

  •  

    When I have a few IE7 windows open, I am  often getting one browser page that will hang,lock up, not respond at all when I "Open in New Window" or "Open in New Tab" - it doesn't discriminate as I can have 2 or up to 10 tabs/browsers open on any of thousands of websites I visit. I never have more than about 10 TABS or browsers open at once although I know I can have many many more if I wish to

     

    It can happen at any time. I can have 2 or more tab browsers open or 2 or more separate  browsers open and at any time when I "Open in New Window" or "Open in New Tab" - no particular number at all. Then the hang occurs.

     

    I therefore am stuck with a hang that can cause all of the open IE windows/browsers to crash or I manage to close the window if I am quick enough before all IE windows crash at once. Many times I cannot close the hanging browser and can only work with the current browsers that are open only.

     

    Once this happens I also lose the RIGHT CLICK function on the mouse

     

     Therfore, I have learnt that it is a good idea to then close down all IE browsers altogether and start fresh

     

    Once I do this I regain the RIGHT CLICK function on the mouse again and the browsers work as normal till the next hang

     

    Ultimately, I find that to clear whetever is happening in IE7, is to restart my PC which is a TOTAL suck and inconvenience

     

    No error messages pop-up either

     

    If you were to ask in what area I have the more hangs - the Answer is - when I "Open in New Tab" and probably around opening up the 4th - 7th tab 

     

    Anyone have any ideas or know of any fixes

     

    WinXP SP2

    3GB RAM

    2.4 GHz processor

    IE7

    All updates are up-to-date

     

    No viruses or spyware

    All temp files etc cleaned

    No Yahoo addon

    Wednesday, December 26, 2007 10:42 AM

Answers

  • I have this problem also. 

     

    Noticed it after KB943729 was installed but I fixed it by disabling all the "Windows Live" plug-ins (Tools->Internet Options->Programs(Tab)->Manage Add Ons).

     

    Am happy not having these installed; perhaps I wont even bother activating them again even if a fix is released.

     

    Wednesday, April 09, 2008 7:49 AM

All replies

  •  

    this is happening to me also.. but it just started doing it in the past couple days. Happens every time i click a link and select "Open in new tab". If i click the stop button and then focus in the address text box and hit 'enter' the page loads immediately. The loss of right click function of mouse just seems to be because the thread is blocked for the whole tab (spinning wheel wait cursor shows in whole page)... clicking stop gives me the right click again.

     

    Never happened before and I've been running vista for at least 6 months. All updates are up to date.

    Saturday, December 29, 2007 9:31 PM
  •  

    I just noticed that if I start IE with Admin priviledges that this problem does not occur and everything works accordingly... I tested this 3 times to make sure this is the case. Did something happen recently in a recent update? something strange is happening.

    Saturday, December 29, 2007 9:41 PM
  • not sure if its related or not but pressing ctrl-f or clicking edit/find no longer brings up the find dialog... wish there was a way to reapir ie in vista as its the only item im having problems with.

     

    Sunday, December 30, 2007 1:02 AM
  • Phishing filter also does not work - constantly says the microsoft online service is down.

    Also the hang also happens when clicking a link that has a target set to open in another window.

     

    Click stop and then enter always works to load the page.

    Sunday, December 30, 2007 1:10 AM
  • Running IE with Admin priviledges fixes all the above mentioned problems. This shouldnt be required.

     

    Sunday, December 30, 2007 1:17 AM
  • 2008-Apr-05

    This just started happening on one of my PC's; has anyone found a solution?  On mine it happens just when I click on the 'blank' tab to open a new browser; it just constantly says 'Connecting...' then if I close the main tab it all locks up; I can't even kill it from the Task Manager; I have to log out - then I get a not responding window to something called 'Search_Glow'.

    Saturday, April 05, 2008 3:26 PM
  •  

    This has started happening to me in the last week.  It is always on the first new tag I open.  This is a pain as it means I have to start a new browser each time I want to look at something.  Was it a Microsoft update that caused it?  I'm using Firefox until a fix has been found as it is seriously inconveniencing me.

    Cheers

    Tyrone  

    XP Professional

    IE7

    Anti virus uptodate

    Saturday, April 05, 2008 4:23 PM
  •  

    Absolutley the same problem for me.  As soon as I open the second tab it locks up.  If I then open a new window of IE7 then the first one need to be hard closed (forced).

     

    Also saw the "Search-Glow" message when tried a restart.

     

    I have unlaoded IE& and re installed - no change.

     

    I am guessing this is a mess courtesy from Microsoft auto update.  Anybody got any ideas.

     

    Sunday, April 06, 2008 2:37 PM
  • I've got exactly the same issue.  Started a couple days ago.  Hope someone has got a solution.

     

    Tuesday, April 08, 2008 3:40 AM

  • I am having the same problem.. Any response from MS yet?

    Tuesday, April 08, 2008 5:40 PM
  • How and when can we expect a fix for this; obviously a lot of people have the same problem - does anyone know how to report the issue to MS?  I have a pending 'Auto Update' on my other PC and I am afraid to install it thinking it will screw up the one PC where this isn't happening!!!

     

    I am tempted to revert back to IE6!!!!!!

    Wednesday, April 09, 2008 1:53 AM
  • I am also having the same problem. Suddenly it happened to me today. When I try to open a new tab it is hanging. After that I am not able to close the IE. I have to kill the process manullay. Any solution?
    Wednesday, April 09, 2008 1:55 AM
  • I have this problem also. 

     

    Noticed it after KB943729 was installed but I fixed it by disabling all the "Windows Live" plug-ins (Tools->Internet Options->Programs(Tab)->Manage Add Ons).

     

    Am happy not having these installed; perhaps I wont even bother activating them again even if a fix is released.

     

    Wednesday, April 09, 2008 7:49 AM
  • I have the same or a similar problem.  IE seems to hang whenever I open a new tab.  I don't generally have issues opening a new window.

     

    I have noticed that I don't have problems if I start IE without add-ons.  I'll experiment by adding in my add-ons one at a time to see if I can narrow it down to a culprit.  I'll write again if I can determine which add-on, or combination thereof, is causing the problem.

    Wednesday, April 09, 2008 12:30 PM
  • Thanks - that worked for me too --- at least now I can browse without it hanging; kinda miss the tool bar short-cuts but can live until there is a fix...

     

     

     

    Thursday, April 10, 2008 1:18 AM
  • Happening for me too - getting VERY annoyed at it....but only happens on my account, my husband's account on same computer is working fine???

     

    Thursday, April 10, 2008 3:15 AM
  • Thanks very much for the post Burtie!!! That fixed my problem. What OS is everyone uses? I don't have this problem with my Vista machine only with my XP machine. Just wondering if it is an Live/XP problem.

     

     

     Burtie wrote:

    I have this problem also. 

     

    Noticed it after KB943729 was installed but I fixed it by disabling all the "Windows Live" plug-ins (Tools->Internet Options->Programs(Tab)->Manage Add Ons).

     

    Am happy not having these installed; perhaps I wont even bother activating them again even if a fix is released.

     

    Thursday, April 10, 2008 1:35 PM
  • This behaviour started on my IE7 (XP SP2) yesterday as well. In my case, the solution was to disable the Google Toolbar Notifier BHO. Hope this helps.

     

    Thursday, April 10, 2008 9:34 PM
  •  

    Same problem happened to me today.

     

    I fixed it by disabling WindowsLive plugins in IE.

     

     

    Thursday, April 10, 2008 11:53 PM
  • You're the greatest Burtie. I'm running XP Home, and the problem started right after I singed up for Windows Live so I could access the MCP sites

     

    Thanks again

     

    Jamie Hunter

     

    Friday, April 11, 2008 1:22 AM
  •  Burtie wrote:

    I have this problem also. 

     

    Noticed it after KB943729 was installed but I fixed it by disabling all the "Windows Live" plug-ins (Tools->Internet Options->Programs(Tab)->Manage Add Ons).

     

    Am happy not having these installed; perhaps I wont even bother activating them again even if a fix is released.

     

     

    Burtie you are a star - all fixed!!!

    Friday, April 11, 2008 2:04 AM
  • Disabling Windows Live plug-ins worked for me, too.  Thanks.

     

    Friday, April 11, 2008 3:23 AM
  • For me, (just) disabling the Windows Live Toolbar plugin worked.  Thanks for the advice.

     

    Friday, April 11, 2008 4:43 PM
  • I am having this problem and it's Yahoo! Toolbar causing it. When I disable Yahoo! Toolbar the problem goes away. Seems like there's some general problem with toolbars and tabs in IE7 (or 8 Beta for that matter since I have the same problem there).

     

    //C

     

    Saturday, April 12, 2008 8:38 AM
  • Do what Burtie said. This started happening to me yesterday for some reason. I did nothing to cause it....I disabled the 2 windows live as per his direction and now all is well again. I hate how stuff hangs up for no apparant reason.

    Saturday, April 12, 2008 2:53 PM
  • Thanks, Burtie - uninstalling Windows Live Toolbar cured the same problem for me too. Seems like MS shipped us a problem in the latest update - at least, that's the 'apparent reason' for me. I hate it even more when the cause is a 'recommended update'!

     

    In the hope that someone from Microsoft is monitoring this board, here are my symptoms: all was fine for me until I let Automatic Update install the latest set of recommended Windows updates. After that, all the following symtoms occurred:-

    - right-click a link to open in a new tab created the tab but never opened the page; clicking on the new tab showed a frozen display (moving another window over it leaves un-refreshed trails of color)

    - click on the 'New Tab' icon or Ctrl-T gave a similar result - even though my home page is the 'blank page'

    - click IE window back to the original tab when one of these dead tabs is started and it responds OK, but only in the original tab

    - when I closed the IE window, the 'do you want to close all tabs' dialog was displayed - clicking close tabs left the whole thing visible, but it would not respond to anything. Task manager did not show any active IE applications, but the processes tab did list iexplore.exe as a running program with 00 CPU usage

    - attempting to log off or shut down, 'program is not responding' dialog was shown for Search_Glow (that's how I found this thread - Googled for search_glow hang); clicking to 'end it now' the PC appeared to be completing the logoff, but then hung again; I had to use the big switch to complete shutdown and restart.

    - right-click a link to open in a new window gave similar results, but in a new browser window :-)

    - symptoms were the same for admin and non-admin accounts

     

    I'm on Windows XP SP2, all updates applied including SP1 for Office 2003.

     

     

    Saturday, April 12, 2008 6:53 PM
  • Again - if MS are monitoring - Can I have another vote as I have almost exactly the same symptoms as Stevie_M except I never get the "Do you want to close all tabs"  I can start a new single TAB instance of IE and this can be used but the previous one is completely dead and has to be closed using [X] and "End Now". 

    There is clearly a problem - Just needed to un-check the Windows Live Toolbar in the View Menu to fix the issue for me.  It started yesterday after latest updates ran.  Also after a friend used Windows Live Messenger on the PC last night (I still tend to use Windows Messenger!).

    Anyway hope this helps everyone.

    I will try un-install and re-install of Windows Live sometime soon.

    My System Windows XP, Office 2003, all latest patches and SPs.  I have Google toolbar running fine.

    Cheers
    Saturday, April 12, 2008 7:41 PM
  • Thanks a lot Burtie

    that was really helpful.  Smile

     

    Sunday, April 13, 2008 9:11 PM
  •  Burtie wrote:

    I have this problem also. 

     

    Noticed it after KB943729 was installed but I fixed it by disabling all the "Windows Live" plug-ins (Tools->Internet Options->Programs(Tab)->Manage Add Ons).

     

    Am happy not having these installed; perhaps I wont even bother activating them again even if a fix is released.

     



    This solved the problem for me also. 

    The error first started occuring after the latest update from Apple Itunes - where safari installs as an alternate browser.

    There also seems to be a critical update for MS Messanger Live from 4.7 to 5 - this may also be part of the problem. So i upgraded this also.


    Monday, April 14, 2008 12:01 AM
  •  

    I'm about to try the add-ons fix.  But I believe this started happening too after I installed the Itunes update which installed Safari.  I thought "what the hell - I'll install it anyway".  So it was either that - or the windows update that happened after Safari was installed.

     

    Wasted a lot of the morning closing IE and submitting error reports!!

    Monday, April 14, 2008 3:51 AM
  •  

    Just a quick note, I never did install Safari, yet I still had the problem until I disable the Windows Live plug-ins.
    Monday, April 14, 2008 4:29 AM
  • "Search_Glow" is definitely linked to "Windows Live Toolbar" and possibly to "Desktop Search".

    Both of these add-on apps are available to users of IE7 running Windows XP and Vista.

    Despite rumours on the web, Search Glow is not a virus, nor is it spyware. It appears to be an anomoly in the

    coding of the add-on's. I would imagine that MS will put a fix out for this very soon.

    "Search Glow" can make your browser do strange things, opening multiple windows that cannot be shut down.

    Going into ADD/REMOVE PROGRAMS from the Control Panel will reveal nothing about Search Glow.

    Even opening the Task Manager sometimes fails to close the offending program.

    Remember that you can live without the Live Toolbar for now, you could use the Google toolbar instead.

    If this is driving you crazy or rendering your browser unstable, here is the fix until MS puts out the patch.

     

    1. Disconnect from the Internet and close any running programs and turn off screensavers.
    2. Go to the Control Panel and open  ADD/REMOVE PROGRAMS, wait for the list to be populated.
    3. Look down the list and uninstall "Windows Live Toolbar" and "Desktop Search" if they appear.
    4. Also uninstall "Java Runtime" as this may have also become corrupted (you can download it again later)
    5. When the uninstall is complete, close all windows.
    6. Now, right click on the IE icon on the desktop and choose PROPERTIES, in this window click the DELETE button
    7. Click "Delete Files", "Delete Cookies" and "Delete History" to clear out all the caches of visited sites.
    8. Close the Internet Properties window down and any other windows.
    9. Reboot the computer and when everything has settled down, open IE7 and see how it performs.

    This should now have got rid of the Search Glow problem

    You can download the Windows Live Toolbar again at a later date when the heat has died down, same for Java Runtime.

     

    Remember the three most important things that you need on a PC with Internet access today are:

    Anti-Virus program

    Anti-Spyware program

    Firewall to be active (Check Control Panel/Firewall settings.

    If you are even one of the above short, you're leaving yourself wide open to attack. Its worth getting the paid versions for peace of mind, as the free versions of antivirus and antispyware tend to be cut down versions which do not offer the same level of protection. Hope this helped. LOL

    Monday, April 14, 2008 7:03 PM
  • Great and very simple solution. This worked instantly for me.

     

    Just as everyone else had said, the problem started about 2-3 days ago. Anytime a second tab was opened, the entire Internet Explorer would freeze up, and I would have to kill it using the Task manager. I had started using Firefox for the last 2 days and was about to make that my default browser.

    Thanks for posting the solution!

    Monday, April 14, 2008 7:14 PM
  • Disabling "Windows Live Toolbar" & "Windows Live Toolbar Helper" worked for me.

    Monday, April 14, 2008 7:56 PM
  •  U649 wrote:

    "Search_Glow" is definitely linked to "Windows Live Toolbar" and possibly to "Desktop Search".

    (...)Remember that you can live without the Live Toolbar for now, you could use the Google toolbar instead(...)

     

    A caveat wrt using the Google Toolbar: like everyone else in this thread, I started seeing this problem a few days ago, But I had never installed the Windows Live Toolbar. In my case, the culprit was the Google Toolbar Notifier BHO; disabling brought IE7 tab behaviour back to normal. (Note that I've left the Google Toolbar and the Google Toolbar Helper BHO add-ons active.)

    Monday, April 14, 2008 9:44 PM
  • Hi,

     

    I am having this problem with Yahoo! Toolbar. I was hoping the new version of the toolbar (7.2.0.0) would fix it, but no. I still get new locked tabs with the label "connecting". The only way to get rid of them is to kill the IE process and start over. As soon as I uninstall Yahoo! Toolbar the problem goes away. Seems like this has to do with how toolbars works with IE7 in general. Interestingy enough I installed IE8 Beta 1 and had the same problem there with Yahoo! Toolbar. It is really annoying since I need the toolbar having used it for years and have my bookmarks on Yahoo!. I usually at some point find solutions to almost all problems I encounter with Windows, but this one leaves me stumped. Removing the toolbar is not an option for me. Then I would rather use Firefox with working Yahoo! toolbar.

     

     

    Tuesday, April 15, 2008 12:13 AM
  • I disabled all of my IE Add-Ons and enabled them one by one and determined it was Sun Java Console or SSV Helper Class causing the problem.  Since they are both classified as "ssv.dll" files, I disable both of them.

    Tuesday, April 15, 2008 4:19 PM
  • thanks so much - i did what you described above and VIOLA! now i can open addl tabs w/o hang ups. don't know what MS has done, but this was a real hassel. Mahalo!

     

    Tuesday, April 15, 2008 5:38 PM
  • Thank goodness for Burtie!  I just disabled the windows live toolbar and it fixed immediately.  No need to restart or anything.  I am so glad I found this post.

    Thursday, April 17, 2008 12:59 AM
  • I am also faced with this problem since about 3 days. I wasted some hours trying to repair IE7. First I set Firefox as my standard browser. But some web pages I use can only be opened with IE. Finally, disabling the Add-ons for Windows Live Toolbar was the solution in my case. I am quite disappointed with Microsoft since in the past year I lost several hours with resolving MS software problems on several MS platforms as SBS 2003, XP, etc.

     

    Tuesday, April 22, 2008 4:38 AM
  • Yup. The problem is certainly caused by Windows Live add-ons (including Windows Live Toolbar). I disabled all of them and the tabs are back to normal...

     

    Tuesday, April 22, 2008 11:33 AM
  • narrowed it down to jus the Windows Live Toolbar.  The rest of the add-ons are running and everything is working as it use to.  Who would have thought that a Microsoft written add-on would crash a Microsoft product.  Lab testing or is this still Beta.
    Tuesday, April 22, 2008 2:10 PM
  • I am yet another person with this problem which happened funnily enough just after I downloaded updates from Microsoft. Thank you very much for your solution, I did exactly as you advised and it worked, so pleased as I was worried I had a virus or something. Thanks again!

    Tuesday, April 22, 2008 3:16 PM
  • THANKS!!!  Disabling the Windows LIVE add in fixed this for me. 

     

    Tuesday, April 22, 2008 5:17 PM
  • winxp,sp2, ie7 --- I had the same problem, when selecting open in new tab, the IE7 instance would hang.  I resolved it by uninstalling the MS Live toolbar, now it's back to normal.

     

    thanks,

     

     

    Tuesday, April 22, 2008 11:03 PM
  • jee jee, good solution with lovely IE or any other MS product: always find solution by yourself and usually disabling something. Very nice and handy indeed.

     

    Wednesday, April 23, 2008 11:39 AM
  • This fixed my browser!!  Thanks for the post.

     

    Windows Live is worse than Win ME...and that's bad, it's done nothing but cause me pain over and over again.

    Thursday, April 24, 2008 7:08 AM
  • Burtie !!   I love you !!!   I want to have your babies !!!         (Well... not really - but you know what I mean...)

     

    Thank you for that info - Tabs hanging up has been driving me mad   

     

    You got the problem sorted in two seconds flat...

    Friday, April 25, 2008 4:49 PM
  • Burtie's post sorted me out - But I forgot to say that all I disabled were the Live toolbar plugins (Live Toolbar & Live Toolbar Helper)

     

     

     

    Friday, April 25, 2008 4:55 PM
  •  Paul Saxelby wrote:

    Burtie's post sorted me out - But I forgot to say that all I disabled were the Live toolbar plugins (Live Toolbar & Live Toolbar Helper)


    I did the same thing and now IE does not hang anymore! M$ definitely have a problem!

    I hope they read this forum!?!


    /Andrew

    Saturday, April 26, 2008 8:08 AM
  •  

    Thanks Burtie.  You were right on for my situation. 

     

    Cheers.

     

    Sunday, April 27, 2008 8:22 PM
  • Search_Glow is a managed Add-on of IE7.

       1. Go to the IE7 Add-on's

        2 DISABLE Windows Live Toolbar Add On

        3. DISABLE Windows Live Browser Helper Object.

       4. Close IE.

        5. Reopen IE.

     

    ************This will stop Search_Glow from opening and cease its operation****

     

     

    Monday, April 28, 2008 6:32 PM
  •  

    I have the same problems...IE hangs when opening a new tab or window.  I did not have any Windows Live toolbars running so I just disabled all available add-ons (yes, including Java).  Same problem.

     

    Went so far as to uninstall Java completely.  Same problem.

     

    Any other ideas on ways to fix it other than using Firefox Smile

    Tuesday, April 29, 2008 8:42 PM
  • Does it hang indefinitely? I am also experiencing problems when a page contains Java! But the browser returns to normal after several minutes (when the Java engine is running) :-(

     

    What the **** did you do Microsoft?

    Tuesday, April 29, 2008 8:52 PM
  • This is exactly what has just started happening to me... just in the past two weeks.   After 1 or 2 tabs are open, if I open a new tab, it constantly says "connecting"... and then all internet explorer threads just lock up.  Same thing... can't kill it from Task Manager... and I've gotten the "Search_Glow" error.

     

    I noticed that this started around the time that I added a toolbar... I think it was "Allot"... something that came a long with emusic.  I removed that toolbar and it seemed like things got a little better... but it's still happening a couple of times a day... total pain in the butt.  I wonder if it has something to do with added toolbars... may just reinstall explorer.

     

    Thursday, May 01, 2008 12:10 PM
  • Go into Add Ons and disable Windows Live Toolbar and Windows Live Toolbar Helper

     

    This is all I needed to do also. I have been using ie7 for as long as it's been available and this is very recent behavior. I noticed it when links in  one browser window would request a new tab and that tab wouldn;t open. Then it would require the task manager to close the iexplore process. I recently did a group of updates so I am sure it is related to that. Now everything is fine.

     

    Thanks to all of us who are willing to share our experience and knowledge.

    Saturday, May 03, 2008 10:37 AM
  • I also disabled the windows live add ons and it worked many thanks.

     

    One thread here said it was teh yahoo toolbar, well I dont have that installed and the problem still happened. It was definately the windows live add ons

    Saturday, May 03, 2008 3:57 PM
  • Thanks for the work around. I hate when MS does these updates and breaks useful features like this. Anyway, thanks again.

     

    Mikeyb

     

    Sunday, May 04, 2008 5:38 AM
  • This worked for me as well. I would try this before I disable all of the add ons.

    Thanks for the information.

    Monday, May 05, 2008 2:03 AM
  • Yeah, I had this problem too and fixed it by disabling the Google Toolbar Notifier in Tools > Internet Options > Programs > Manage Add-ons.  I think it might have to do with a conflict between the google toolbar and the last IE update.

     

    X&V,

    K.D.S.

    Monday, May 05, 2008 7:34 PM
  • Thank you very much!!
    Wednesday, May 07, 2008 1:51 AM
  • For me, the fix was to disable Google Toolbar! After switching it on and off again to confirm the fix, I uninstalled Google Toolbar and reinstalled it. That seems to have done the trick... I now have all my add-ins enabled (including Google TB) and IE7 is back to working as expected.

     

    WinXP SP2

    1GB RAM

    2.5 GHz processor

    IE7

    All updates are up-to-date

    Friday, May 09, 2008 7:23 PM
  • This fixed the problem for me! 

    Thank you

     

     

     Burtie wrote:

    I have this problem also. 

     

    Noticed it after KB943729 was installed but I fixed it by disabling all the "Windows Live" plug-ins (Tools->Internet Options->Programs(Tab)->Manage Add Ons).

     

    Am happy not having these installed; perhaps I wont even bother activating them again even if a fix is released.

     

    Tuesday, May 13, 2008 2:32 PM
  •  

    I'm not quite sure this is as recent an issue as most of you think. I actually had this same problem at the end of last year, and discovered it was the windows live toolbar.

     

    The only features that were the most useful of the windows live toolbar were the mail notification, live favorites syncing, and weather add-on.  Otherwise, I don't need or want it.  So out of hope, I thought by now that issue with hanging was resolved-- obviously not.  I will remove it again and hope for a fix.

     

    For those of you that happen to like the favorites sync feature, you can use the folder share beta program that I've been using flawlessly for a few months now, and just sync your 2 computers "favorites" folder.

    Tuesday, May 20, 2008 8:10 PM
  • Burtie's solution worked perfectly for me, thank you.

    Tuesday, May 20, 2008 9:08 PM
  • I am having this problem but when I go in to change these settings I am unable to locate the windows live plug-ins. I did the step by step but was still unable. I can't even open the second tab without it freezing up and having to restart my computer. It always says it connecting.

     

    Wednesday, May 21, 2008 12:21 PM
  • Thank you, rgutter, and all who posted fixes. I am running XP SP2 (not sure I even want to try SP3, but I've ordered the cd) and have no other browsers on my computer. My problem started a month or two ago, so I unchecked Tabs. After reading this forum, I checked it again, and disabled only the Google Toolbar Notifier BHO, then restarted ie. No problems since.

    Thursday, May 22, 2008 6:21 PM
  • I think I have a cure!!

     

    go to control panel>internet options>advanced tab and at the bottom click on reset. This will wipe your history and some of the featured form the tool bar. I have also disabled add ons....

     

    It seems to have worked thus far!!!!

     

     

    Wednesday, May 28, 2008 2:44 PM
  • I also face the same problem before, when I close the "window live toolbar" the OK already!!!! try it good luck to you.

    Friday, May 30, 2008 2:37 PM
  • I am having a similar problem that started occuring some time in the last couple of days.  I think after an automatic windows update.  My problem seems to be related solely to windows that are opened from a page that create a new browser (<a href="some target" target="_blank">....).  If any window is opened like this, my browser locks up and I have to use the task manager to close the window.  The symptoms are the windows is locked and the hour glass is running.  Unlike many in this forum, I do not have windows live intalled.  The only thing that seems to have worked for me is to turn off all components.  I went for the ones mentioned in previous messages and still had the problem.  I have several tool bars that are tied into debugging web pages, so it is not an option to turn them off permenantly. 

     

    In case someone from Microsoft happens by and looks here, some additional information.

    I am running Window XP Pro Table Edition 2005, SP2.  My IE is version 7.0.5730.13.  I have automatic update active and did a critical update yesterday manually after the problem started.  This made no difference.

     

    Sure woudl be nice to get this fixed. 

    Friday, June 06, 2008 9:15 PM
  • This is caused by "Google Toolbar Notifier BHO". You need to disable it in your IE7 Add On. Go to Tools > Internet Options > Programs > Manage Add-ons then disable it.

     

    Sunday, June 08, 2008 12:34 PM
  • Kudos to Burtie!  Appreciate the tip - worked for me.  Another example of Microsoft's "helpfulness" not being helpful!

    Wednesday, June 11, 2008 10:01 PM
  • Thanks for that i have disabled them and it is working fine now

     

     

    really helpfull .

    Saturday, June 14, 2008 12:20 PM
  • Thanks.  Disabling worked.

     

    Monday, June 16, 2008 4:34 PM
  • Same problem here, but it has been going on for over 1 month. It also blocks my computer from shutting down Vista 64 Home Premium. Pathetic.

     

    Monday, June 16, 2008 7:28 PM
  • Similar problem, but with differences.

     

    XPsp2

     

    Installed (via auto update::allow)...

    KB932823-v3

    KB950759

    KB950760

    KB950762

    KB951376

    KB951698

     

    IE works fine for a while (a few minutes), then when IE is suppose to open a new tab, it instead opens a new window. Whether via a right click choice or normal click on a link with target="_blank" (as is my setting in options). Intermittantly hangs, sometimes on closing IE window.

     

    No Windows Live.

    No Toolbars installed or active.

     

    Tuesday, June 17, 2008 12:12 PM
  •  

    JUST DISABLE THE WINDOWS LIVE TOOLBAR ADD-ON

    PROCEDURE

    1. RIGHT CLICK ON THE WINDOWS TOOLBAR

    2. FROM THE MENU UNTICK Windows Live Toolbar

    3. CLOSE INTERNET EXPLORER AND START AGAIN

    Thursday, June 19, 2008 12:47 PM
  • Having the same problems and tired of being frustrated over it.  I am trying your suggestion of disabling add ons.  *fingers crossed*....hope it works!  Thanks!

    Thursday, June 19, 2008 2:16 PM
  • Thank you sooooo much, Stevie. You described all of the problems I had with IE. I got the "Do you want to close all tabs" message over & over & over (to infinity) and after a while the Task Manager screen would be blank (nothing running) and I would have to shut down the computer "Improperly" with the On/Off button (is that the Big Switch you refer to?).

    For anyone who reads this (including Microsoft if they're out there) I also had the Search_Glow symptom and fixed that with the posts by Burtie and U649. KUDOS to both of you.

     

     

    Thursday, June 19, 2008 10:50 PM
  •  

    It looks to me like it is the Live Toolbar that has gone up in smoke. I went through ever live service and disabled them then broght them back one by one. Once I reactivated the Live toolbar helper I started having problems again.
    Monday, June 23, 2008 5:45 PM
  •  Burtie wrote:

    I have this problem also. 

     

    Noticed it after KB943729 was installed but I fixed it by disabling all the "Windows Live" plug-ins (Tools->Internet Options->Programs(Tab)->Manage Add Ons).

      


    Burtie- You are 100% right on.  I installed Safari to fix the tabs, I got so use to them with ie7 I couldn't exist without them.  I disabled the "Windows Live" plug-in's and my ie7 is back to normal.  

    With all the discussion, why doesn't Microsoft fix this?  Surely it's happened to many employees at MS.

    Bruno
    Sunday, June 29, 2008 1:14 AM
  • I had the same problem.

    After reading the email trend, I tried turning off one particular add-on, which was Adobe PDF Reader.  This solved my issue.

     

    Thank you for the advice.

    Monday, June 30, 2008 4:07 AM
  • The inability to open an additional tab (the system clocks) has been a problem for me for months.  Disabling the Google Toolbar Notifier BHO fixed the problem for me.  Thanks. 

    Monday, June 30, 2008 4:10 PM
  • I have the same happening. I believe it is the java program. I have not found the fix yet.

     

    Thursday, July 03, 2008 12:44 PM
  • DISABLE THE WINDOWS LIVE TOOLBAR (RIGHT CLICK ON INTERNET EXPLORER TOOLBAR TO GET THE MENU)
    Thursday, July 03, 2008 12:49 PM
  • OK I give up.  How do I read your replies (or can I?).  I have the same problem.

    Thanks

    Sandy

     

    Tuesday, July 08, 2008 9:55 PM
  •  

    This is a Google toolbar and Microsoft IE incompatibility issue.

     

    It is very interesting since this is one of a series of these incompatibility issues between Google and MS IE that only started when Microsoft started getting interested in buying Google.

     

    This is probably a malicious attack on Google by Microsoft and we are getting caught in between!

     

     

     

    Sunday, July 13, 2008 4:36 PM
  • I didn't even have to uninstall Windows Live.  Just uncheck the toolbar in the IE toolbar context menu.

    It appears that the Windows Live toolbar is incompatible Internet Explorer 7, yet Google toolbar works just fine...  hmmm.
    Monday, July 14, 2008 2:14 AM
  • Thanks!

     

    This fixed the issue for me..

     

    Tuesday, July 22, 2008 2:38 PM
  • Thank you Burtie.  I followed your lead and it fixed my problem also.  I don't need the Windows Live plug-ins either.

    Thursday, July 24, 2008 3:22 PM
  • same problem, but how do you fix it??  i can't afford to pay to call tech support!  i called Dell, and they said i could uninstall it and it would default to IE6 and then reupdate.  so i went to add and remove but there was no remove button by IE7...?  it just started doing this about maybe about a month ago.  it's really a pain.  i got WinXP SP3...  and i also have no viruses, spyware or temp files either.  it happens every time i try to open the first tab!  sometimes it just happens when i am scaning an email message.. i don't know what to do!  is there a way to email microsoft for free??  it locks it up so bad i have to restart my computer!  did you get yours fixed ??  how do i go about it??? 

     

    Saturday, July 26, 2008 3:59 AM
  • What did you do that worked for you?

    All I have found so far where the issues, but not definite answers to the problem of hanging windows.  Where is the info

    please?

    Michael

     

     

    Thursday, July 31, 2008 8:28 AM
  • I have the same problem and went to try Burtie's suggestion, but I can't find any "Windows Live" add-ons.  Are they called something else.  Is Windows live just a name for a group of add-ons?

     

    Thanks for any info in advance,

    Michael

     

     

    Thursday, July 31, 2008 8:34 AM
  • just started with problem in past few days. oe6 was hanging so i switched to window live mail.  then ie 7 started hanging on tabs. last addon i turned off was the windows live toolbar. that fixed it

    Friday, August 01, 2008 12:18 AM
  •  michaelsurles wrote:

    I have the same problem and went to try Burtie's suggestion, but I can't find any "Windows Live" add-ons.  Are they called something else.  Is Windows live just a name for a group of add-ons?

     

    Thanks for any info in advance,

    Michael

     

    as people have mentioned, it might be other add-ons that cause this.

     

    look for anything that might seem uneccessary, google toolbars apparently also cause this issue so other similar ones might as well. I fixed the problem by disabling 3 add-ons that Skype had added, along with some sort of a Windows Live login aid.

     

    Saturday, August 09, 2008 10:21 AM
  •  

    in addition to the tab issue, I've also been experiencing the following:

     

    • in IE, if I have multiple tabs open, even just 4-5, opening a new one becomes inpossible. the new tab button does not do anything.
    • right clicking does not work, nothing happens. right click over a link does nothing, so I cant open links in new windows etc. right now this is happening, and I cant right click on the desktop either, no context menu.
    • launching new programs doesn't occasionally work. I just tried opening Windows Mail, and nothing happens. double clicking on it on the desktop has no effect, nor does opening it through the Start menu. no other programs open either.
    • some open programs are slow at responding, at one point I had Media Player running, if I close it, the music plays for about 8 seconds after the program has dissapeared. the whole system feels a bit frozen.
    • ctr + alt + del brings the screen, but when I click on "launch task manager" it doesnt open, just goes back to the desktop. or the manager pops up but closes in a blink.

    now, if I close a couple of the tabs or the whole IE window, everything seems to be ok for a while. However, if I run task manager after closing the entire IE window, I can see that iexplorer.exe is still running a 150k process, which seems odd, I dont think it should run anything in the background after closing?

    I think its also worth mentioning that during all this, I dont have a lot of programs open. after closing a single word document, I was able to launch the task manager. CPU usage is at 2-6%, memory however is at 1,86Gt with only IE (one window, 3 tabs), Windows Live and Windows Mail running in addition to Norton and the Vista side bar. Now I just noticed that with just this singe IE window with three tabs of techguy.org pages is running a 900k process.

    I'm not an expert but it seems like IE is somehow taking a lot of memory and causing inability to do certain tasks. the occurance of these issues seems to be increasing, and so far the only way around it is not using IE. without IE there doesn't seem to be any similar issues on Vista, so I'm guessing its the root of all these problems.

    Saturday, August 09, 2008 10:25 AM
  • Much better solution, Burtie/miller!  only 2 programs to disable, and windows live is dumb.

     

    Monday, August 11, 2008 3:31 AM
  •  Burtie wrote:

    I have this problem also. 

     

    Noticed it after KB943729 was installed but I fixed it by disabling all the "Windows Live" plug-ins (Tools->Internet Options->Programs(Tab)->Manage Add Ons).

     

    This cleared up my "new tab freezing problem" that started after the last updates were installed. Never use Windows Live anyway.

     

    Thanks!!!!

    Tuesday, August 12, 2008 3:33 AM
  • Excellent Burtie! Solved it for me!
    Friday, August 15, 2008 10:18 PM
  • Many thanks for that. Disabled "windows Live" plug-ins now tab works fine.

    Sunday, August 24, 2008 2:30 PM
  • Thanks - this seems to have cured my issie - now the big question - When is Microsoft going to do a propper fix

     

    Wednesday, August 27, 2008 1:58 AM
  • This was happening to me before Windows Live.  
    Now, I don't use IE unless I have to for authentication or coding test purposes.  Google Chrome is much faster and the AddOns in Firefox - well I love it!


    To control when IE hangs grab the most awesome utilities by Mark Russinovich - SysInternals.
    The pslist and pskill (pstiils.zip) are a life saver - because PSKILL...shuts down IE, clears the memory and I can restart it!


    There was an interesting post on this at eggheadcafe, but I haven't tried it:

    eggHeadCafe Forum Posting
    1. Does this behavior persist if you start IE7 in No Add-ons mode? To start IE7 in No Add-ons mode:
    2. Does the problem persist if you Reset IE7 Settings (RIES)? Read before using!
    3. Required reading IMHO before reinstalling IE7:

    Make *certain* that you check in at Windows Update immediately after reinstalling IE7 to install any critical updates offered. If Optional Updates category offers Root Certificates update, I recommend installing it to take full advantage of IE7's additional security.

     
     
     

    ~Robear Dyer (PA Bear)
    MS MVP-Windows (IE, OE, Security, Shell/User)
    AumHa VSOP & Admin http://aumha.net
    DTS-L http://dts-l.net/"

    Saturday, September 06, 2008 5:15 PM
  •  

    My tabs also froze, but this was prior to loading Safari.  Disabling Windows Live finally fixed my problem.  Thanks for the post!
    Sunday, September 07, 2008 8:27 AM
  • I fixed the error by:

     

    1)  Tools

    2)  Internet Options

    3)  Tabs - Settings - Choose Open "Blank Page"

     

     

     

    Thursday, September 11, 2008 12:29 PM
  • Here's the deal...  Chances are - one or more of the following DLL's are not registered properly due to a recent install or plug-in that accidentally unregistered itself...

     

    Perform the following actions...

     

    Copy the following to notepad or print this out first, because you'll need to CLOSE all of your browser windows before you perform these actions...

    Open Start ---> Run...

     

    Then apply each of the following one at a time...  (Some of these MAY NOT actually work - if they fail, don't worry, it just means that it didn't pertain to your system)

     

    regsvr32 actxprxy.dll
    regsvr32 shdocvw.dll
    regsvr32 oleaut32.dll
    regsvr32 shdocvw.dll
    regsvr32 actxproxy.dll
    regsvr32 mshtml.dll
    regsvr32 pdm32.dll

     

    Once you are done, you can reopen your browser and everything will be fixed...

     

     

     

    Friday, September 12, 2008 6:44 PM
  • This fix worked for me as well.  Thanks Bertie!

     

    Sunday, September 14, 2008 2:15 PM
  • Thanks for this post!  I haven't been able to use multiple tabs for months.  I disabled every add on for IE and I now have my tabs back!  yahoo!  thanks so much!

     

    Monday, September 22, 2008 2:42 AM
  • Click on Internet option on IE7 then go to Advanced then click on reset.

    Monday, September 29, 2008 9:42 PM
  • I have had same problem and done as suggested with add-ons (even though have no idea what I am doing) but who cares it now all works. Thanks

     

    Tuesday, September 30, 2008 4:57 PM
  • How to repair this problem.........

     

    This happens when there are many web toolbars in your browser. to fix this is to remove all the add-on toolbars in your browser (e.g. google toolbars, yahoo toolbars) or leave one web toolbar. restart your IE7. happy browsing

    Tuesday, October 07, 2008 9:27 AM
  • Nothing in the forum worked , so I wnet to the Internet explorer web site and t walked me through and I used method 8 and it solded my problem..

     

    The website is:    http://support.microsoft.com/gp/pc_ie_intro

     

    This is what they said.(For Vista)

     

     

    Open Notepad.

    Follow these steps if you need them to open Notepad:

    1. Click Start, and then click Start Search.
    2. Type Notepad in the Start Searchbox.
    3. Click OK. A blank Notepad window opens.

    Step 2 Create a command script.

    Next, you must create a command script to reregister Internet Explorer program files. To do this, follow these steps:

    1. Carefully select and then copy the following commands to the Windows clipboard.

      regsvr32 /u /s urlmon.dll
      regsvr32 /u /s mshtml.dll
      regsvr32 /u /s shdocvw.dll
      regsvr32 /u /s browseui.dll
      regsvr32 /u /s jscript.dll
      regsvr32 /u /s vbscript.dll
      regsvr32 /u /s scrrun.dll
      regsvr32 /u /s msxml.dll
      regsvr32 /u /s actxprxy.dll
      regsvr32 /u /s softpub.dll
      regsvr32 /u /s wintrust.dll
      regsvr32 /u /s dssenh.dll
      regsvr32 /u /s rsaenh.dll
      regsvr32 /u /s gpkcsp.dll
      regsvr32 /u /s sccbase.dll
      regsvr32 /u /s slbcsp.dll
      regsvr32 /u /s cryptdlg.dll
      regsvr32 /u /s oleaut32.dll
      regsvr32 /u /s ole32.dll
      regsvr32 /u /s shell32.dll

      regsvr32 /u /s initpki.dll
      regsvr32 /u /s msjava.dll
      regsvr32 /s urlmon.dll
      regsvr32 /s mshtml.dll
      regsvr32 /s shdocvw.dll
      regsvr32 /s browseui.dll
      regsvr32 /s jscript.dll
      regsvr32 /s vbscript.dll
      regsvr32 /s scrrun.dll
      regsvr32 /s msxml.dll
      regsvr32 /s actxprxy.dll
      regsvr32 /s softpub.dll
      regsvr32 /s wintrust.dll
      regsvr32 /s dssenh.dll
      regsvr32 /s rsaenh.dll
      regsvr32 /s gpkcsp.dll
      regsvr32 /s sccbase.dll
      regsvr32 /s slbcsp.dll
      regsvr32 /s cryptdlg.dll
      regsvr32 /s oleaut32.dll
      regsvr32 /s ole32.dll
      regsvr32 /s shell32.dll
      regsvr32 /s initpki.dll
      regsvr32 /s msjava.dll
    2. In Notepad, click Edit and then click Paste to paste these commands into Notepad.
    3. On the File menu, click Save.
    4. Carefully copy and then paste the following path and file name in the File name box:

      c:\reregisterie.cmd
       
    5. Click Save to create the command script.

    Step 3 Run the command script.

    1. Click Start and then click Start Search.
    2. Type c:\reregisterie.cmd, and then press ENTER. A Command Prompt window will open to run the script and then close.
    3. Restart Windows.

     

     

    Good Luck

     

    Monday, October 27, 2008 1:22 AM
  • To anyone having issues with IE 7 or 8 hanging or freezing when opening new tabs, Burtie was pretty much bang on with disabling Add-ons.

    Some people have found disabling any "Windows Live" plug-ins is the solution to their problem, whereas others (myself included) have found disabling Add-ons from Sun Microsystems is the solution.

    I started experiencing the issues after installing the Open Office Suite and installed Microsoft Office to get rid of the problem, discovering it didn't work I knew that Java or a similar Sun developed product was causing the issue. After reading Burtie's help I went to "Manage Add-ons" in IE 8 and disabled anything from Sun Microsystems.

    This included:
     - SSV Helper Class
     - Sun Java Console
     - Java Plug-in

    Although the Java Plug-in was probably just overkill, it was easier to disable all Sun products and run them as needed.

    Hope this helps!

    Windows 7 Public Beta
    Internet Explorer 8 Beta
    Tuesday, March 10, 2009 10:08 PM
  • I've looked at the forum and saw quite a few good ideas for this lockup problem, but I had already turned all my Windows Live, Java and some Google addins off from previous troubles.  The lockup from the new tab when connecting is shutting out my ability to even close the explorer and locking up other activities too for as much as 20 minutes!  I can't even force close it through the Task Manager.  Not wanting to go through the endless troubleshooting, I saved myself dealing with the new tab conflict by bypassing it.  Also, I don't want to disable my addins.  Why not disable the new tab instead.  Here was my fix: 

    Go to Tools-Internet Options and on the General Tab go to Tab Settings.  There I reset the scroll down box for 'when a new tab is opened' and set it to my home page instead of the new tab or blank tab.  It goes to my chosen page instead with no problems regardless of the addins.  It seems all the interesting features in the 'New Tab' are loaded with conflicts and I don't want to deal  with them now.  I'll come back and see if some fixes have been made in a few months.

    Hope this helps someone who is still stuck. 

    My system HP Pavilion Media Center PC Duo Core with 4 GB RAM/RAID using Vista 32.  Not a slow machine.  Oh I miss IE6!!
    • Proposed as answer by kjsacramento1 Friday, May 08, 2009 9:51 PM
    Friday, May 08, 2009 9:50 PM
  • I  also got it fixed by disabling all the "Windows Live" plug-ins (Tools->Internet Options->Programs(Tab)->Manage Add Ons).
    Monday, July 06, 2009 10:05 AM
  • Great discussion and lots of good ideas.  This problem has been documented by Sun Microsystems as a Java issue, and some of you may have seen it appear when you installe / updated Java with the various toolbars.

     

    There is an add-in that is no longer used by current (Ver 1.06.xx) versions of Java. By disabling this one add-in, your ability to right-click and open links in a new tab is restored (and it doesn't take 60 seconds to do it either).

     

    Look for Add-On "Java Plug-In 2 SSV Helper" in your IE Add-on list.  (Use Tools / Manage Add-in menu to get to your add-in menu).  Disable this one add-on, then close and re-start IE and you should be good.  After several hours reading forums like this, and trying different things, this is what cleared it up on my Win XP Pro / IE7 system. Disabling this add-on does not affect your ability to run Java scripts /applications or other goodies you may have installed as add-ons.   

      

    You can read more about it at Sun's

    bug reports about the delay and Sun’s admission that they not doing a clean uninstall:

     

    http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=6792558

    http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=6747116

     

    The result is this remnant file lingers into the install of a new

    version of Java. Disable this add-on and the slowdown goes away.

    Having it disabled will not interfere with the operation of Java applets

    (but make sure you have the latest version of Java).

     

    The file linked to this add-on is jp2ssv.dll. 

     

    Tuesday, November 10, 2009 7:24 PM
  • I have the same problem in IE 8 on windows 7. After disabling all Windows Live plug-ins it fixed this problem. Thanks.
    Wednesday, May 12, 2010 2:07 AM
  • I THINK I FOUND THE PROBLEM EVERYONE IS TALKING ABOUT. OK, HERE GOES AND DO NOT BE SURPRISED WHEN YOU HEAR THIS. The problem lies with not INTERNET EXPLORER but with the Flash player or any old files that are left behinde in your internet options click on the view objects button and if you see older versions of shockwave products delete them but first try to uninstall your flash player go to adobe.com to see how. See once adobe took over shockwave and Flash they did not uninstall the other companies active x stuff so the conflect in my case hasbeen the the simple overtaking of one company to the next. I have seen so many good programs die and become a waste after being bought out. Hopefully this is not the case for these great players.

    Let me know if this works for any one.

    Thursday, July 29, 2010 4:27 PM
  • Problem can be due to corrupted or lost IE9 registrations (new tabs are blank pages instead of website page). Below are three fixes (would try in this order as they are listed easiest to hardest). As always create as system restore point before trying any fix.

    1. Quit all programs that are running. Click Start, and then click Run. Type regsvr32 urlmon.dll , and then click OK. When you receive the "DllRegisterServer in urlmon.dll succeeded" message, click OK. If this does not resolve the problem, repeat steps 2 through 4 for each of the following files replacing Urlmon.dll with each of the following filenames: Shdocvw.dll, Actxprxy.dll, Oleaut32.dll, Mshtml.dll, & Browseui.dll .

     

    2. Run ie8-rereg.32-on-64.cmdwill usually fix the IE9 tab problem. This program can be found at http://iefaq.info/index.php?action=artikel&cat=42&id=133&artlang=en.

     

    3. Reset IE9 on the Advanced page of Internet Options but this method will require you to redo all your IE9 settings (General, Security, Privacy, Advanced, etc.).

    • Proposed as answer by JSiepmann Friday, August 19, 2011 3:32 AM
    Friday, August 19, 2011 3:31 AM
  • i get crashing problems and lockups so i just resetted my interenet explorer hopefully it will stop i'm a facebook player love their games

     

    • Proposed as answer by kemal dator Saturday, October 22, 2011 3:53 PM
    Tuesday, September 06, 2011 2:13 AM

  • IE 10 (not responding)

    Win 7 x65 IE10

    have run fixit and reset ie

    in tools the add on box is unreadable but should be clean at this point

    advanced protection mode is off

    have removed and reinstalled IE 10  using a ms script

    have java and shockwave and flash- all updated but do not current status after removals

    when closing IE Windows looks for a solution- evidently never finds one

    should I run the dll fixes and or reregisterie.cmd

    Sunday, July 07, 2013 2:42 PM