none
The F12 Developer Tools crashed ie

    Question

  • I was using the f12 developer tools to view java-script and identify coding errors as instructed by this basic tutorial . when I was in the middle of the debugging window having it display the error message i closed ie without exiting the developer tools manually by pressing f12. Now I cannot view pages with ie as all that will come up are blank pages and in the tools section the only highlighted options are file, safety and compatibility view settings. see attached image. I didn't do much here so this is a pretty weird bug not sure how to fix it besides un-installing and re-installing ie 11. I tried this but ie is integrated right into windows 8.1 so the only option was to try removing it as a feature and then restarting then addign it as a feature and restarting which had no effect. I still can only view this blank page. Has this happened to anyone else how fix it and how do i prevent it from happening?


    • Edited by reigh7 Saturday, December 14, 2013 10:49 PM
    Saturday, December 14, 2013 10:29 PM

All replies

  • Hi,

    close all open IE windows, then use the Tasks Manager to Kill any orphaned iexplore.exe (64/32) processes

    or

    Reboot.

    were you running in noAddons mode while debugging?


    Rob^_^

    Sunday, December 15, 2013 3:27 AM
  • I was not running in a mode called noAddons that I know of. I have tried a system reboot I even tried disabling the feature of ie and rebooting then re enabling ie as a feature since it is built into the windows 8 os. No results just still can only get a blank white tab with very few options in the menus available.
    Friday, December 20, 2013 2:05 AM
  • Hi,

    whats the url of the page you are debugging? Does this occur on all websites? Have you installed the latest Windows Updates.

    Start>Programs>Accessories>System tools>Internet Explorer (noAddons)

    does it contain PDF or XPS documents hosted in iframes or embed elements.

    Post consumer questions about IE to http://answers.microsoft.com (Help>Online Support menu from IE)


    Rob^_^


    Friday, December 20, 2013 3:05 AM
  • The page was a simple java script example that was opened from a local file. so there is no url. The problem just happened after trying to use f12 keys to debug it and occurs not mater what website url I try all I see is the above pictured screen shot. I do not have a Accessories folder in my start bar so I do not believe I ever ran ie without addons.
    Friday, December 20, 2013 10:07 PM
  • Please post the js file.

    or

    Correct your errors (JSON.parse(window)) or use VS2012's intellisence.


    Rob^_^

    Friday, December 20, 2013 11:59 PM
  • I don't think it was code specific. I got the code from the tutorial and setup an error as directed to try out using F12 developer tools to catch it. but here it is in all its simplicity.

    <!DOCTYPE html>
    <html>
    <head>
      <title>JavaScript Example</title>
      <script type="text/javascript">
        function substitute() {
          var myValue = document.getElementById('myTextBox').value
    
          if (myValue.length == 0) {
            alert('Please enter a real value in the text box!');
            return;
          }
          var myTitle = document.getElementById('title');
          myTitle.innerHTML = myValue
        }
      </script>
    </head>
    <body>


    • Edited by reigh7 Saturday, December 21, 2013 3:22 AM
    Saturday, December 21, 2013 3:21 AM
  • Hi,

    download the tutorials complete source code from http://media.ch9.ms/ch9/javascript/C9JS_Code.zip

    the code snippet you provided is missing closing <body> and <html> tags.

    Regardless of the markup errors I tested the snippet you provided, but could not reproduce the issue.... (reboot you computer and retest again).

    (1st step in debugging web applications is to validate and correct your markup errors... validator.w3.org. 1st step in troubleshooting IE issues is to test in noAddons mode)

    questions about third-party code and markup should be addressed to the author.

    these are public forums... we do not work for nor represent MS or ch9.


    Rob^_^

    Saturday, December 21, 2013 4:34 AM
  • Same problem, there is a workaround here: http://superuser.com/questions/701135/internet-explorer-11-stopped-working-on-windows-8-1

    Launch IE with add-ons disabled, open and close dev tools, restart IE normally. Leaving dev tools open when you close IE will cause it to fail again.

    • Proposed as answer by ewhitmire Wednesday, May 21, 2014 3:28 PM
    Wednesday, May 21, 2014 3:27 PM
  • I tried opening ie with no add-ons as suggested by going to run... then typing in "iexplore –extoff" since I do not have a shortcut on my computer to the no add-ons version of ie.

    After doing this the window for ie was the same and I could not open developer tools the option remains grayed out.

    Sunday, June 01, 2014 9:28 PM
  • When I have had this happen, a solution is to

    [1] unmark radio button:   o Start with tabs from last session    on first page of Internet Options.

    [2] delete registry key shown here   https://connect.microsoft.com/IE/feedback/details/883375/ie-11-frozen-because-of-dev-tools-not-fixed-by-kb2936597

     

    You may unmark an incorrectly marked Answer if you feel it does not benefit the community, reigh7.  You're allowed to.

    Sunday, June 01, 2014 10:59 PM
  • [2] delete

    HKCU\Software\Microsoft\Internet Explorer\Toolbar\WebBrowser\ITBar7Layout

    Explain please?  Can this affect even the case where the DT is never pinned?

    FWIW I currently have a crash of the DT when trying to insert breakpoints here:

    http://social.msdn.microsoft.com/Forums/en-US/61177c2b-6a38-4207-9cbe-ccd6c86b1d42/html5-local-storage-broken-in-ie11-win-81-x64-error-function-expected?forum=iewebdevelopment#fa61b265-a5f9-4b30-957f-71622690db68

    I am considering having to apply RIES to try to get things back to normal.

    Also, ever since discovering that  Reopen last browsing session  (e.g. Alt-o s)  will always be present regardless of the state  of the first condition mentioned I have always left that one off.  Makes for faster restarts most of the time.   <eg>

    C.f.

    http://answers.microsoft.com/en-us/windows/forum/windows8_1-networking/ie11-startup-tabs-restore-last-session-not-working/5d81bb08-fd59-4312-9f86-be35fd5c7258?page=5&msgId=b7c87c5b-fe03-4045-98c2-847f95f8ccad 

    <quote>

     somewhat startling thing that happened is I got prompted about how I wanted to close tabs, e.g. one at a time or all at once with no prompt.  I think this proves that some kind of re-initialization of the feature was done this way and thus got me out of the bug state. 

    </quote>

    Do you see that "mini-repair" effect from toggling that option off?  Then perhaps you should also be advising to toggle it from On to Off?  E.g. first toggling it on if necessary?



    Robert Aldwinckle
    ---

    Thursday, June 05, 2014 7:42 PM
  • still can only get a blank white tab with very few options in the menus available.

    http://support.microsoft.com/kb/2574731/en-us



    Robert Aldwinckle
    ---

    Thursday, June 05, 2014 7:57 PM
  • I just made a reply with three screenshots of my similar event, which happened just yesterday.

    http://social.technet.microsoft.com/Forums/ie/en-US/1f4f6dae-c305-4268-972a-012b2e77b4b4/internet-explorer-11-problem-in-windows-7#bbdc6ecc-0e7f-4102-93c2-24b239800465

     

    Here is one of the screenshots.  It looks much the same as reigh7's, except the tab has a phantom title, in mine.  Yet the address bar is empty, and most menu options could not work.  Of course you can see the page is blank also.

    http://bknndq.blu.livefilestore.com/y2pIbecx2VayvH5siD40W0uIDgcFc3Cbedy8kfn2cDPuCivO7AiYQD-JlsqK5LhcptxBS_8wN3gh0Qa5OovXj4vNyKTl_c4h-SVaslwHiIMH-g/godotengine.org2.png

     

    In this case, it was a lucky maneuver that I also had a second malformed session opened that was able to "Reopen last browsing session", which has retained a few tens of important open tabs I am currently working with.  Then I closed this mutant window in the screenshot.  This was just yesterday.

    I haven't tried to restart IE since then to see what might happen next.

    • Edited by thumbdоwn Thursday, June 05, 2014 8:33 PM
    Thursday, June 05, 2014 8:08 PM
  • I just made a reply with three screenshots of my similar event, which happened just yesterday.

    Were scripts in the Header section involved?  In the case of my "crash" I was trying to breakpoint in there.  But I just realized that in IE11 the debugger itself is supposedly being driven by scripting too, so perhaps there is some conflict from that as a result?  (E.g. concurrency problem?  Then try using processor Affinity to change the symptom?) Also, what exactly does Break on new worker (Ctrl-Shift-W) do? Should we try using it now? Note that the script sample being used by the OP predates IE11 and its new implementation of the DT.  In my case I actually start the DT and the Script debugger from About:Blank and then open the test page from there.



    Robert Aldwinckle
    ---

    Friday, June 06, 2014 4:10 AM