none
Why does my ActiveX control not work in IE9

    Question

  • Recently I upgraded to IE9 and tried to verify whether my ActiveX control can work correctly in IE9 with follow steps.

    1. Drag a file into IE9, which is binding with my ActiveX control

    2. Click 'Allow blocked content'

    3. As a result, ActiveX control does not start and the file displayed as binary like

    s�0��J���AR\G��~\�ik?n�ى!-&�b��k���vf�H�������� �i{H26�R�E�d�������ܬ��gV�s*$�Y�X�����*����ŷד���e3�_�|��F�S���SP���J�"��A�D}�6�`��Z��|�񫁛��Iiנ7 W�Ռ�Ry

    This ActiveX control can work well in all previous IE versions, so I doubt it is a bug of IE9, right? What should I do to let this control work in IE9?

    Friday, October 22, 2010 1:47 PM

All replies

  • SVG(Z) Document?

    Have you had a look at your Killbits and/or rollback some of your security updates. Use the Fiddler tool or the IE9 Beta Developer tool to inspect the content-type headers returned from your server when it retrieves the data. XML data? Validate its schema at validator.w3.org.

    We do not work for Microsoft.

    You can submit feedback for IE9 Beta at connect.microsoft.com/ie

    Hurry, the timeline is running away.

    Regards.


    Rob^_^
    Friday, October 22, 2010 6:53 PM
  • I have sent this issue to MS but not response.

    I think there is registry key used to control the opening under my application path but I don't know what and where it is.

     When I drag my file to IE9, the output is saying "

    HTML1113: Document mode restart from IE9 Standards to Quirks"

    Thursday, November 04, 2010 9:00 AM
  • And how does IE find my ActiveX control?
    Thursday, November 04, 2010 9:30 AM
  • It looks up the COM registration for the control in the registry.
    Thursday, November 04, 2010 10:32 PM
  • I have registried my ActiveX control and I have said it can work in all previous IE including IE8, 7, 6. Tricky.

    When I drag my file to IE9, the script is

    <HEAD></HEAD>
    <BODY leftMargin=0 scroll=no topMargin=0><EMBED height="100%" width="100%" src=file:///C:/Users/tank/Desktop/test.tka fullscreen="yes"></BODY>

    After I  click 'Allow blocked content', IE cannot find my ActiveX control and instead that it opened my file as Text. I doubt whether I need add a new MIME type to support IE9.

     

    Remark: If I checked the option 'Allow active contents to run in files on my computer' in 'Advanced' option, my file can be opened directly.

    Friday, November 05, 2010 1:29 AM
  • I think this issue should be marked for 'stopship' issue of IE9.
    Friday, November 05, 2010 9:25 AM
  • Maybe I have found the reason that IE9 cannot activate my control.

    When I drag my file to IE8 the script is

    <HEAD></HEAD>
    <BODY leftMargin=0 scroll=no topMargin=0><EMBED height="100%" width="100%" src=file:///C:/Users/tank/Desktop/test.tka type =model/vnd.tka fullscreen="yes"></BODY>

    However the MIME type dispeared in IE9 as

    <HEAD></HEAD>
    <BODY leftMargin=0 scroll=no topMargin=0><EMBED height="100%" width="100%" src=file:///C:/Users/tank/Desktop/test.tka fullscreen="yes"></BODY>

    Question is why IE9 missed the MIME type?

    Sunday, November 07, 2010 5:34 AM
  • Any MSFT experts can help me? Hurry.
    Tuesday, November 09, 2010 8:55 AM
  • Who can tell me when IE9 will release formally?

    If it is tool late we can tell our customers that our product does not support IE9 currently.

    Wednesday, November 10, 2010 1:24 AM
  • You should tell the IE team that.  They can be reached at http://connect.microsoft.com/ie
    Wednesday, November 10, 2010 11:31 PM
  • Yes, I have sent more than 4 messages to them about this issue, it is very bad that I did not get response. Now I just would like to know IE9 final release date, if it is 2012 year as someone said in Web I will also tell our customers that our product does not support IE9, because our product can support Firefox, Chrome and other web browsers well.

    Thursday, November 11, 2010 1:14 AM
  • I would like to know whether this is official forum. Because I am very curious why none of IE team members answer our questions?
    Friday, November 12, 2010 1:10 AM
  • OMG i discovered how to fix it...

    1. click tools

    2. click internet options

    3. go to the securety tab

    4. on internet zone (pic of world) click custom level (neer bottom)

    5. scroll down to activex controls and add-ins

    6. enable what you want but dont click promt it comes up with loads of boxes and it may worn u about securety settings but just ingnore...

    visit my web design site and in videos you will find more tutorails... click here

    • Proposed as answer by PCdocter295 Monday, February 28, 2011 7:34 PM
    Monday, February 28, 2011 7:34 PM
  • look im quite young and we all make mistakes...
    Saturday, May 07, 2011 9:53 AM