none
Logon failure: user account restriction. Possible reasons are blank passwords not allowed, logon hour restrictions, or a policy

    Question

  • I'm trying to create a website on an Intranet, but when i try to log in the main page this message appears:

    "Logon failure: user account restriction. Possible reasons are blank passwords not allowed, logon hour restrictions, or a policy restriction has been enforced."

    I'm sure that this error has to do with my IIS settings, but I can't figure out where exactly. so can anyone help please?

    I have winXP sp2, and my site is built using VS2005 C# code behind.

    Thanks

    Thursday, December 21, 2006 9:45 AM

Answers

All replies

  • i had the same problem. i got this solved. go to run type regedit.exe
    then go here HKLM\System\CurrentControlSet\Control\Lsa\limitblankpassworduse
    change from 1 to 0
    Friday, March 20, 2009 3:34 AM
  • you're a freakin' genius.  thanks.
    Thursday, June 25, 2009 4:54 AM
  • you are very welcome
    Thursday, June 25, 2009 1:45 PM
  • If you dont mine can you share with us How to create a website on an Intranet?
    Thursday, June 25, 2009 1:47 PM
  • how did u ever find this?
    Tuesday, July 14, 2009 7:32 PM
  • I LOVE YOU , YOUR GREAT ,   I WAS ALMOST READY TO JUMP OF THE BRIDGE    BUT SUDDENLY I FOUND UR POST   AND IT WORKS NOW   THANK YOU     ;)   WE NEED MORE NETWORKERS LIKE YOU ;)
    Tuesday, November 10, 2009 5:10 AM
  • friend, Thank you very much. You are great. Work fine.... Thank you again.
    Tuesday, November 24, 2009 10:23 AM
  • Great post! :)
    Wednesday, December 16, 2009 4:48 PM
  • Yeah, that worked.  Thank you much!
    Saturday, January 30, 2010 10:41 PM
  • i had the same problem. i got this solved. go to run type regedit.exe
    then go here HKLM\System\CurrentControlSet\Control\Lsa\limitblankpassworduse
    change from 1 to 0
    I have been struggling with this one for a while now and this quick tip worked! Awesome, thanks!
    Sunday, May 16, 2010 8:56 AM
  • Please note that this also fixes issues with network connectivity between two Windows Server 2008 boxes on a workgroup in addition to this error when adding a linked server between two SQL Server 2008 instances:

    "Login failed. The login is from an untrusted domain and cannot be used with Windows authentication."

     

    Thanks so much for the tip - this has literally saved me hours of work!

    Tuesday, August 31, 2010 8:57 AM
  • I agree with the other posts....you rock man!
    Sunday, March 13, 2011 3:32 AM
  • Thanks a lot, this helped me solving my networking problem.
    Wednesday, March 23, 2011 3:23 PM
  • That works, thanks.  But I experimented and found that another solution is to simply create a password for the administrator account. 

    The anti-virus people say that it's advisible to have a password on your administrator account.  I would imagine that getting rid of the LimitBlankPasswordUse flag would make that vulnerability even worse.

    So I went with creating a password.  But thanks for the information.

    • Proposed as answer by MarcSanders Monday, March 28, 2011 2:23 PM
    Monday, March 28, 2011 2:21 PM
  • The best Way is go to network sharing centre and left panel click on change network sharing setting>then go to turn on pasword sharing row, change it to turn Off. it will work.. Thankss
    Wednesday, June 29, 2011 4:11 AM
  • Thank you

    Also I found another solution:

    goto start->run->control userpasswords2

    you can see IUSR_MYSTATION user which is Guest user that could be an IIS user

    Reset password to anything except blank... DONE.

     

     


    Babak Omidvar
    Friday, August 12, 2011 5:08 AM
  • Thank you very much,your method is of great help to me,I also want to know why do you do like that.
    Wednesday, September 07, 2011 7:23 AM
  • Thanks dear, it helped me. but i coun't understand one thing, i was able to run scritps in IE8 w/o any issue even in Google Chrome, y i was getting login failure only in Mozilla FireFox?
    Thursday, September 15, 2011 10:59 AM
  • Great , I had the same issue . this post help me to get rid from that .

    Thanks


    Saturday, March 17, 2012 4:41 AM
  • OMG. This is really great post. It solved my problem. Thanks a lot to you. God Bless :)
    Monday, April 23, 2012 1:31 AM
  • thanks a lot to Geethan_368


    • Edited by Robiullm Tuesday, June 05, 2012 6:54 AM
    Tuesday, June 05, 2012 6:53 AM
  • It Worked, Thanks very much...!!!!
    Saturday, August 18, 2012 7:37 AM
  • Thanks Man... It worked... :-)

    Friday, December 27, 2013 11:38 AM