none
jQuery errors in debug mode. (machine issue?)

    Question

  • I'm getting an error(s) in VS 2010. I'm not sure if it's jQuery or not, but it's definitely js. I'm using Telerik controls (not sure if it's related to that). I seem to be the only one getting the error(s). If I run my project, on certain pages (most) I'll get ID is undefined and it breaks with a dynamic window showing only this: cr_real_detachEvent("onload", window.CR_IE8_EVENTS[ ID ].handler);

    If I continue on and ignore the error, it seems to work fine...just annoying. On subsequent postbacks I'll sometimes get (and it could be more than once) Object doesn't support this property or method. Here is the code where that happens:         element.detachEvent('on' + eventName, browserHandler);
    The eventName variable is "unload". 
    Somehow I think this has something to do with installing VS 2012. Even though I've uninstalled it and done a repair of VS 2010, I'm still having these problems. 

    One last thing. If I'm in IE and I change the Document Mode to IE9 through the developer tools (F12), the errors stop, but it basterdizes the styles on my page.
    Any help would be greatly appreciated!
    Wednesday, January 23, 2013 10:12 AM

Answers

  • Hi,

    What document Mode does your page load in IE10 in?

    (f12>DocumentMode

    it should be IE10 Standards (default)

    if its in IE10 Quirks

    then you are totally wrong....

    Add a valid dtd (document type declaration) and validate your markup ( validator.w3.org) and correct the markup errors that it finds.

    or

    In visual studio, turn on your markup error reporting options.... Tools>Options>Text Editor>HTML>Validation

    VS2010 SP1 settings

    display the Error list or see the red squggly lines under your markup and css schema errors.

    Additionally in VS2010 you have to install the Nuget Addon and then install the html5 and jQuery js Intellisence updates.

    Telerik will also add an additional Menu to the VS IDE... Telerik..... from there you can choose different project types and options to use jQuery or not...

    select the CDN options to ensure that the version of jQuery you are using is the latest.

    Regards.


    Rob^_^

    Thursday, January 24, 2013 1:05 AM

All replies

  • Hi,

    What document Mode does your page load in IE10 in?

    (f12>DocumentMode

    it should be IE10 Standards (default)

    if its in IE10 Quirks

    then you are totally wrong....

    Add a valid dtd (document type declaration) and validate your markup ( validator.w3.org) and correct the markup errors that it finds.

    or

    In visual studio, turn on your markup error reporting options.... Tools>Options>Text Editor>HTML>Validation

    VS2010 SP1 settings

    display the Error list or see the red squggly lines under your markup and css schema errors.

    Additionally in VS2010 you have to install the Nuget Addon and then install the html5 and jQuery js Intellisence updates.

    Telerik will also add an additional Menu to the VS IDE... Telerik..... from there you can choose different project types and options to use jQuery or not...

    select the CDN options to ensure that the version of jQuery you are using is the latest.

    Regards.


    Rob^_^

    Thursday, January 24, 2013 1:05 AM
  • I had the same error today on VS2008. The culprit was and internet explorer adon or toolbar .. one of those coupon adware that was installed as a side effect of installing a free software from CDnet.

    I just unistalled and problem solved.

    Thursday, January 31, 2013 7:57 PM