none
Add manually URL on Compatibility View List in IE10.

    Question

  • I need to add one URL to Compatibility View List in IE10. I want do this without user need to do anything, I will add the URL at Installation time of my application.

    How can I do that?

    It's some regkey to edit, or some file to change?

    It's very important for me right now.

    Thanks all for the help.

    Tuesday, March 05, 2013 7:52 PM

Answers

  • Hello Dante Basso,

    URL’s can be added to Compatibility View List in IE 10 by using the following group policy,

    User Configuration->Administrative Templates->Windows Components->Internet Explorer->Compatibility View->Use Policy List of Internet Explorer 7 sites.

    If you want to enter this information directly in the registry,

    i)Navigate to HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\BrowserEmulation\PolicyList (Create registry folders manually if not present)

    ii)Right Click PolicyList ->New->String Value->Enter the name of the website both under ‘Name’ and ‘Data’ (e.g. microsoft.com)

    Regards,

    Nanduri

    • Marked as answer by Dante Basso Monday, March 11, 2013 2:16 PM
    Monday, March 11, 2013 12:45 PM

All replies

  • Hello,

    Thanks for your post. I'm trying to involve some senior engineers into this issue and it will take some time. Your patience will be greatly appreciated. Sorry for any inconvenience and have a nice day!

    Regards,


    Damon Zheng
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Thursday, March 07, 2013 6:54 AM
  • Hello Dante Basso,

    URL’s can be added to Compatibility View List in IE 10 by using the following group policy,

    User Configuration->Administrative Templates->Windows Components->Internet Explorer->Compatibility View->Use Policy List of Internet Explorer 7 sites.

    If you want to enter this information directly in the registry,

    i)Navigate to HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\BrowserEmulation\PolicyList (Create registry folders manually if not present)

    ii)Right Click PolicyList ->New->String Value->Enter the name of the website both under ‘Name’ and ‘Data’ (e.g. microsoft.com)

    Regards,

    Nanduri

    • Marked as answer by Dante Basso Monday, March 11, 2013 2:16 PM
    Monday, March 11, 2013 12:45 PM
  • Thanks!
    Monday, March 11, 2013 1:49 PM
  • Checking this... Thanks!

    Monday, March 11, 2013 1:50 PM
  • Thanks a Lot this works very well!

    Before I use this:

    [HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\BrowserEmulation]
    "AllSitesCompatibilityMode"=dword:00000001

    Not a good way to solve the problem, but works...

    Now I just use this:
    [HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\BrowserEmulation\PolicyList]
    "example.com"="example.com"

    Thanks a lot.

    Monday, March 11, 2013 2:22 PM
  • Thanks Dante. Happy to know it fixed your issue.
    Monday, March 11, 2013 5:28 PM
  • I would like to add a note to Nanduri's answer:

    I skipped part 1 and did part 2 by using a GPO. If the path is not there, the GPO will create it automatically by using the "Update" as the Action:

    • User Configuration
    • Preferences
    • Registry

    Right-Click and select: New Registry Item

    Action: Update

    Hive: HKEY_CURRENT_USER

    Key Path: Software\Policies\Microsoft\Internet Explorer\BrowserEmulation\PolicyList\

    Value name: intranet.companyname.com

    Value data: intranet.companyname.com

    Success means:

    • "Compatibility View" greyed out from the "Tools" menu on the browser
    • "Compatibility View" icon not visible on the browser by the address bar
    • GPO settings showing up in the registry

    My intention was for IE10 only but this is OK for now. I am pushing alternative browsers out to the workstations as I am not going to waste my time and fix Microsoft's problems. Probably going to use an alternative browser as the default. This is the reason I wont allow SharePoint to be used; browser compatibility issues. SharePoint on fully works with IE.

    Also, "Display intranet sites in Compatibility View" was checked when viewing the settings in the browser. Not sure if the GPO did it or Microsoft did it. Either way, when using preferences, the user is allowed to make changes. The URL from the GPO did not show up in the list on the browser but did in the registry. Windows 7 did show the list. Nothing showed up for the one Windows XP machine without the GPO Preferences Pack (read below).

    Success
    Windows 7 Professional SP1 - X64 - IE10

    Success
    Windows Vista Business SP2 - X86 - IE 9

    Success
    Windows XP Professional Version 2002 SP3 - X86 - IE8
    I must have installed the GPO Preferences Pack

    Failed - Most likely does not have the GPO Preferences Pack installed.
    Windows XP Professional Version 2002 SP3 - X86 - IE 8

     


    "I am not discouraged, because every wrong attempt discarded is another step forward." Thomas Edison


    Thursday, May 30, 2013 5:41 PM
  • The best option is to uninstall IE10 and roll back to IE8 or Firefox. IE10 is not compatible with our SharePoint (our GP Business Portal Timecard) and Web Outlook.

    Firefox works well with SharePoint 2010.

    Monday, June 10, 2013 7:36 PM
  • Is there any specification what kind of content is supported for value name and data of the compat key? Host names like example.com work fine but what about placeholders *? or extended URLs like example.com/applicationA? The latter would help greatly to manage this more granularly. Thanks

    Friday, June 13, 2014 8:27 AM
  • This is a silly answer. IE10 works great with both SharePoint and OWA.
    Friday, June 13, 2014 6:10 PM
  • As far as I know, you cannot use either paths or wildcards within this key. Compat settings are inherently wildcarded, so if you put example.com in the Compat list, www.example.com and sub.www.example.com will also run in compatmode.
    Friday, June 13, 2014 6:11 PM