none
Don't work Google Calendar in WebBrowser (IE9 release)

    Question

  • Google Calendar working in IE9 very good, but in WebBrowser Google Calendar slowly working only IE7 mode.

    If I set FEATURE_BROWSER_EMULATION for WebBrowser App to mode IE8 or IE9 (8000, 8888, 9000, 9888, or 9999) - Google Calendar not react at any CLICK (Create Events). I try set step-bystep all Internet Feature Controls for WebBrowser ( http://msdn.microsoft.com/en-us/library/ee330720(v=VS.85).aspx ) - not any results

    Ideas? 

    P.S. My english - is very bad. I'm sorry.

    Thursday, March 31, 2011 4:47 PM

All replies

  • Apparently, even if in msdn no answer to this question, I can not hope ...
    Saturday, April 02, 2011 10:30 PM
  • Hi Alexander,

    I don't know if it helps to improve the performance, but it is worth to try.  Use FEATURE_GPU_RENDERING  to enable GPU rendering feature of IE9 based webbrowser. http://msdn.microsoft.com/en-us/library/ee330731(v=VS.85).aspx#gpu_rendering

    Cheers,

    Yi


    Yi Feng Li [MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Monday, April 04, 2011 4:39 PM
  • Thanks. But it is no solution. I already wrote that I tried all ways of http://msdn.microsoft.com/en-us/library/ee330720(v=VS.85).aspx (including FEATURE_GPU_RENDERING) - without result. Perhaps a workable is some combination of parameters in the registry. I can not figure out what's the problem.
    Monday, April 04, 2011 7:17 PM
  • I analize all reg events:

    http://my.jetscreenshot.com/226/20110416-bept-476kb

    and set 0 or 1 - any results.

    And I tried to put 1 and 0 for the WB and IE9. WB is not repaired, and IE is not broken. Trouble. Help, I really need to solve this problem with Google Calendar

    PS. If I rename exe-application with WebBrowser to iexplore.exe - calendar Google very good work.  I'm shocked
    Saturday, April 16, 2011 12:29 PM
  • Hi,

    Check that you don't have *.google.com in your IE Compatibility View lists or that you have not set "Show all sites in Compatibility View" and

    (Important) do a Windows Update so that your IE8 site compatibility lists are updated from MS. (IE9 does automatic updates of these lists)

     

    Google asked MS a while back to remove all their sites from the MS compatibility lists, as they converted all (well... they have missed a few we are finding) of their sites to the system Doctype.

    You may like to troll the google support forums or developer.google.com

    Regards.


    Rob^_^
    Sunday, April 17, 2011 1:08 AM
  • Thanks for the tips, although Google has nothing to do with it. Google Calendar's features work in IE9, but not working in WebBrowser (based on the same IE9) - here is a problem. In any case, further support is required, I found a suitable solution.
    Sunday, April 17, 2011 9:37 PM