none
Security Alert - Your current security settings do not allow this file to be downloaded

    Question

  • I am trying to download an Excel 2003 spreadsheet (.xls) using IE 6 SP2

    If *.domain.local is added to Trusted sites or Local intranet , when I click on the link to the spreadsheet
    Security Alert - Your current security settings do not allow this file to be downloaded.

    I doubled-checked Security Settings
    Automatic prompting for file downloads > Enable
    File Download > Enable

    Any ideas?




    Thursday, March 26, 2009 7:56 PM

Answers

  • Okay, the solution is adding registry key(s) for either the Local intranet and\or Trusted sites zones.

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings\Zones\1]

    "1807"=dword:00000000

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings\Zones\2]

    "1807"=dword:00000000

    • Marked as answer by Dude man Monday, April 13, 2009 5:53 PM
    Monday, April 13, 2009 5:53 PM

All replies

  • Okay, the solution is adding registry key(s) for either the Local intranet and\or Trusted sites zones.

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings\Zones\1]

    "1807"=dword:00000000

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings\Zones\2]

    "1807"=dword:00000000

    • Marked as answer by Dude man Monday, April 13, 2009 5:53 PM
    Monday, April 13, 2009 5:53 PM
  • is there any programtic way to access / change values for user's current zone???

    Wednesday, January 13, 2010 10:41 PM
  • Not from a web page. You can script registry changes as .reg files or do it through any number of WMI interfaces.
    Thursday, January 14, 2010 12:28 AM
  • Make sure you have the Custom settings for "Downloads" enabled for the Internet Zone. 

    You may be browsing a web page in the Trusted zone, but the links you are downloading from may be in a different domain; e.g.:   href="not_the_same_domain.com/file.xls"

    The advantage of using the standard settings rather than registry entries is that you can easily reset these settings back to their defaults.

    In my case; i.e. the download was in the Internet domain, applying the registry entries suggested did not work.  However, I didn't try adding the entry to "*\Zones\0"

    Windows Server 2008 R2 Enterprise/64 all current updates as of Sep 10, 2010.

    Friday, September 10, 2010 10:27 PM
  • Most excellent! Having the same issue with both firefox AND IE. adding the 1807 value to the registry was the key! My first time editing the registry...But it worked! Thanks!
    Sunday, October 10, 2010 4:44 PM
  • I did alot of searching, tried the registry, and set my file download to enabled which did not resolve the download issue "your current security settings do not allow this file to be downloaded" in Internet Explorer 10. Attempted the download in Chrome which was very helpful when it reported teh same error, along with the proper solution! I just became a Chrome fan ;-)

    Your computer may be set to block downloads completely. Check your Windows Internet security settings to ensure you’re able to download files:

    Changing these settings will affect Google Chrome as well as other Internet browsers on your computer.

    1. Go to the Start menu > Control Panel.
    2. Select Internet Options. This should open the Internet Properties window.
    3. Select the Security tab.
    4. Select Internet zone (globe icon).
    5. Click the Custom level button. This will open the Security Settings window.
    6. Scroll down to Downloads > File download.
    7. Select Enable.
    8. Scroll down the list further to Miscellaneous > Launching applications and unsafe files.
    9. Select Prompt.
    10. Click OK.

    If you are downloading a file from a website that belongs to a different security zone other than Internet, you should check the security settings for that zone. Some Internet settings, including Security Zone settings, are managed by your system administrator. 

    Tuesday, August 13, 2013 1:07 PM
  • Much easier for me than editing the registry!  This worked perfectly.  Thanks!!
    Monday, August 18, 2014 8:43 PM