none
Problem with a flash object in IE8

    Question

  • I developed a page in html which added the following flash object:

    <object classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=9,0,0,0" width="960" height="58" id="banerops" align="middle">
         <param name="allowScriptAccess" value="sameDomain" />
         <param name="allowFullScreen" value="false" />
         <param name="movie" value="banerops.swf" />
         <param name="quality" value="high" />
         <param name="bgcolor" value="#ffffff" />
         <embed src="/GTBC/Portals/0/banerops.swf" quality="high" bgcolor="#ffffff" width="960" height="58" name="banerops" align="middle" allowscriptaccess="sameDomain" allowfullscreen="false" type="application/x-shockwave-flash" pluginspage="http://www.macromedia.com/go/getflashplayer"></embed>
    </object>

    This object works in all browsers where it was tested, except IE8 (also works in earlier versions). I would like to know the reason why this is happening.

    Does anyone have any thoughts?

    Await feedback,

    Greetings.
    Wednesday, January 27, 2010 4:49 PM

All replies

  • Do you have URL to share for the page?
    Wednesday, January 27, 2010 6:56 PM
    Moderator
  • Do you have problem watching swf files on other web sites?
    You can also search "IE8 flash" in forums.adobe.com. There are many discussions about problem related to flash and IE8 over there.


    The following is signature, not part of post
    Please mark the post answered your question as the answer, and mark other helpful posts as helpful.
    Visual C++ MVP
    Wednesday, January 27, 2010 7:41 PM
  • Wednesday, January 27, 2010 11:04 PM
  • It works in my IE8.

    The following is signature, not part of post
    Please mark the post answered your question as the answer, and mark other helpful posts as helpful.
    Visual C++ MVP
    Wednesday, January 27, 2010 11:46 PM
  • What happens when it doesn't work?  Do you get an error?  What do you see?  What version of flash do you have installed?
    Thursday, January 28, 2010 5:27 PM
  • Simply nothing happened.

    I have installed the version 10 of Adobe Flash Player. This problem occurs not only on my computer or in my operating system or something else. This page has been tested on many machines from the Windows XP operating system until the Windows Server 2008 R2, with everything updated.

    The problem only occurs in version 8 of Internet Explorer. It has been tested in Mozilla Firefox, Google Chrome and in earlier versions of Internet Explorer and it works.

    I can not even realize what's wrong.
    Thursday, January 28, 2010 9:49 PM
  • Really work? You're the first person who tells me that ...

    Can you tell me which version of the Adobe Flash Player and the exact version you have installed IE8 and if you have any other plugin or update made that affected the display of the swf?

    By the way which the operating system you use?

    I'm desperate to solve this ...

    Thanks for your help
    Thursday, January 28, 2010 9:56 PM
  • Windows 7
    IE 8.0.7600.16385
    Adobe Flash 10,0,42,34 


    The following is signature, not part of post
    Please mark the post answered your question as the answer, and mark other helpful posts as helpful.
    Visual C++ MVP
    Friday, January 29, 2010 2:02 AM