none
Get rid of annoying pop-up message

    Question

  • I am trying to print barcodes from a web page using a Dymo label printer. When I try this on IE8, I get a yellow bar at the top of the page with the following message:

    This website wants to run the following add-on: 'Dymo Label Framework IE Plugin' from 'Sanford, L.P.'. If you trust the website and the add-on and want to allow it to run, click here ...

    Unfortunately, I cannot click here, as the whole page is overridden with another spurious error message:

    Unable to create DYMO.Label.Framework ActiveX object. Check that DYMO.Label.Framework is installed. Exception details:[object Error]

    I know this second error message is spurious as I have truied it in Firefox and it all works perfectly.

    When I click OK on this message, both message disappear, so I don't get a chance to ;click here'.

    I want to permanently override this message. Whatever I have to do on my own PC to achieve this, I will have to get the client to do on all their PC's.

    I tried adding AllowedDomains to the Registry:

    REGEDIT4

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Ext\Stats\{CLSID}\iexplore\AllowedDomains\89.234.13.90]
    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Ext\Stats\{CLSID}\iexplore\AllowedDomains\ciosltd.gotadsl.co.uk]

    That didn't work earlier.

    By some fluke, I have had this working, but it stopped again an hour os so later. This is too inconsistent. It needs to work 100% of the time.

    Tuesday, March 29, 2011 2:35 PM

Answers

  •  

    The security settings vary for different security zones in Internet Explorer. You can see all the zone under Tools > Internet Options > Security Tab.

     

    It seems you are changing the security settings for the Internet Zone. This is the zone in which most websites will open. This zone should usually be restricted. The reason why you are getting the warning of "fix these settings for me" is also explained to some extent here:

     

    http://windows.microsoft.com/en-GB/windows-vista/Security-and-privacy-features-in-Internet-Explorer-8#

     

    You should add the website to the Trusted Sites as follows and test to see if the website works fine:

     

    1. Go to Tools > Internet Options
    2. Click on Security tab , select Trusted Sites
    1. Click on the Sites button
    2. Type the URL of the website in the box shown, click Add
    1. Click Close, then OK

     

    If even after adding the site to the Trusted Sites zone you get the same issue, set the security settings shown below for the Trusted Sites zone and test:

     

    Download signed ActiveX controls - Enable

    Download unsigned ActiveX controls - Enable

    Initialize and script ActiveX controls not marked as safe - Enable

    Run ActiveX controls and plug-ins - Enable

    Tuesday, April 05, 2011 8:29 PM

All replies

  • More information on this problem:

    I have managed to get this working in a hit-and-miss fashion on IE8.

    First I went into Tools > Internet Options > Security > Custom Level

    Then I tick a load of boxes:

    Download signed ActiveX controls - Enable
    Download unsigned ActiveX controls - Enable
    Initialize and script ActiveX controls not marked as safe - enable

    Then, when I OK it, the Yellow Bar pops up telling me that the settings are unsafe, asking if I would like Windows to fix it for me. After clicking Yes, my application SOMETIMES works.

    Now that's a mystery.

    Obviously, this is not an acceptable work around, as I would have to get every single user to perform this fix on a regular basis.

     


    Wednesday, March 30, 2011 8:43 AM
  • Does anybody ever answer these?
    Thursday, March 31, 2011 11:34 AM
  •  

    The security settings vary for different security zones in Internet Explorer. You can see all the zone under Tools > Internet Options > Security Tab.

     

    It seems you are changing the security settings for the Internet Zone. This is the zone in which most websites will open. This zone should usually be restricted. The reason why you are getting the warning of "fix these settings for me" is also explained to some extent here:

     

    http://windows.microsoft.com/en-GB/windows-vista/Security-and-privacy-features-in-Internet-Explorer-8#

     

    You should add the website to the Trusted Sites as follows and test to see if the website works fine:

     

    1. Go to Tools > Internet Options
    2. Click on Security tab , select Trusted Sites
    1. Click on the Sites button
    2. Type the URL of the website in the box shown, click Add
    1. Click Close, then OK

     

    If even after adding the site to the Trusted Sites zone you get the same issue, set the security settings shown below for the Trusted Sites zone and test:

     

    Download signed ActiveX controls - Enable

    Download unsigned ActiveX controls - Enable

    Initialize and script ActiveX controls not marked as safe - Enable

    Run ActiveX controls and plug-ins - Enable

    Tuesday, April 05, 2011 8:29 PM