none
IE7: extremly slow and uses too much CPU

    Question

  • Hi there,

     

    The version of my IE is 7.0.5730.13. It's been so slow to almost dead recently. It also uses too much resources so my computer is almost dead too. For some links, the content just never showed up. Tried Firefox and it worked just fine.

     

    Seams that I am not alone. Check http://www.techsupportforum.com/microsoft-support/internet-explorer-forum/

     But didn't find the answer. Hope this is the right place to post this question.

     

    BTW, I checked the task manager and didn't find any spyware running.

     

    Thanks a lot!

     

    Helen

    Thursday, November 20, 2008 12:05 AM

All replies

  •  

    Go to Tools / Manage Addons....disable them one at a time...or all of them...see what happens.
    Thursday, November 20, 2008 12:41 AM
  • Tt's much faster after I disabled "Groove GFS Browser Helper", "Sun Java Console" and "Research". Hope other problems will go away too.

     

    Thanks a lot!

     

    Helen

    Thursday, November 20, 2008 5:12 PM
  • Hi there,

    The problems are not gone. I disabled all the add-ons on my laptop which runs Windows Vista home edition, but IE's still very slow and some links didn't show content for a long time without any error message (no problems using Firefox).

     

    Vista updated itself (twice?) recently(within about one month). I noticed that there's no these problems before the upgrades.

     

    Thank you very much for any input in advance.

     

    Helen

    Monday, November 24, 2008 6:27 PM