none
Internet Explorer 8 hyperlinks not working - using Group Policy

    Question

  • We just switched to Windows 7 on our network, after configuring the workstations and turning on our group policy - the hyperlinks will not work. If you click on a link nothing happens.  When we were running the same group policy on Windows XP the links worked.

    Any ideas??

    thanks

    gary

    Thursday, June 03, 2010 2:49 PM

All replies

  • Hi,

    Win7 ships with IE8.

    XP could have had IE6-8 installed before you did the switch over.

    IE8 requires a new set of adm files for GP management. Download IEAK 8 to ensure you are using the correct adm files.

    Assuming you are using the appropiate adm files it probably has nothing to do with GP, but rather what you are leaving out of GP.

    On a workstation, go Tools>Compatibility View Settings and check "Include updated website information from Microsoft" and (perhaps) check "Display intranet sites in Compatibility View".

    Then go to the Security tab and if the button "Reset all zones to default" is enabled then this will indicate that your GP security zone settings are incorrect.

    IE8 users template security zone settings that you deploy with GP.

    Hyperlinks may not work on web pages for a number of reasons.

    Compatibility View settings is one known reason... scripted links will not work if scripting is disabled.. which is a security zone setting (this is my bet).

    Since you have not provided a link to a site or an example of a hyperlink that is not working I am only guessing.

    It is also relavent if you have rolled out your Win7 as an upgrade or it is a new deployment of new machines from an OEM with Win7 pre-installed. An upgrade from XP/IE6 to Win7/IE8 requires care because of the different schema of the security zones.

    Regards.


    Rob^_^
    Friday, June 04, 2010 8:52 AM
  • Rob:
    Thank  you for the information, it turned out to be a Desktop Management software that we use that was changing the .dll's in the System32 folder.

    thank you again

    Tuesday, June 08, 2010 9:33 AM