none
How to launch IE10 in IE9 compatibility mode?

    Question

  • IE10 is incompatible with some of my working sites. While it works well in IE9 compatibility mode, but it is annoying to press F12 and select the IE9 mode every time. Is there any solution to let the IE10 always run in IE9 mode?


    • Edited by Norven Monday, October 22, 2012 11:13 AM
    Monday, October 22, 2012 11:12 AM

Answers

  • Hi,

    it looks like the Telerik RAD html editor control...

    You must be missing a document type declaration (dtd) on your master page... forcing IE10 to use IE10 Quirks mode.... which is an attempt to allow modern html features and tags to be usable in legacy web documents without a dtd (quirks)....

    add a valid document type declaration to your page hosting the editor control or to your asp.net master page....

    <!doctype html> is the dtd for html5 (latest/but unratified version of xhtml)

    if using asp.net in vs2010, update to sp1 and turn on error correction and intellisence.... download and install the Nuget utility... you will find downloads there to update your VS environment and intellisence to recognise the new html5 tags.

    or

    post the asp.net source (first few lines) to show us if my guess is correct and that you aren't using a valid dtd... forcing IE10 to use IE10 Quirks mode....

    If your company is using "Display intranet sites in compatibility view" (tools>Compatibility View Settings)... you need to add the x-ua IE=Edge meta to your page to over-ride the intranet compatibility view setting.


    Rob^_^


    • Edited by IECustomizerMVP Tuesday, October 23, 2012 8:22 AM
    • Marked as answer by Norven Wednesday, October 24, 2012 6:44 AM
    • Unmarked as answer by Norven Thursday, October 25, 2012 2:14 AM
    • Marked as answer by Norven Thursday, October 25, 2012 2:14 AM
    Tuesday, October 23, 2012 8:19 AM

All replies

  • Hi,

    see Defining document compatibility

    when asking a question in this forum it is helpful if you can provide a link to your website so that we can inspect and debug your web pages and view your servers response headers...

    document compatibility mode may also be triggered by certain markup in your pages (see Internet Options>Advanced tab>"automatically recover from rendering errors with conpatibility view")

    Regards.


    Rob^_^

    Monday, October 22, 2012 6:58 PM
  • I'm sorry for that, the website can be accessed from my workgroup only. It is a TFS(Team Foundation Server) 2010 site. Some elements do not work in IE10. Captured below:

    but they work fine in IE9 compatibility mode, F12-> IE9.

    I have no permissions to recode the snippet. So, is there any solution to let the IE10 always run in IE9 mode?

    PS: Unfortunately, my local OS is Server 2012. I have no choice but IE10.

    Tuesday, October 23, 2012 2:46 AM
  • Hi,

    it looks like the Telerik RAD html editor control...

    You must be missing a document type declaration (dtd) on your master page... forcing IE10 to use IE10 Quirks mode.... which is an attempt to allow modern html features and tags to be usable in legacy web documents without a dtd (quirks)....

    add a valid document type declaration to your page hosting the editor control or to your asp.net master page....

    <!doctype html> is the dtd for html5 (latest/but unratified version of xhtml)

    if using asp.net in vs2010, update to sp1 and turn on error correction and intellisence.... download and install the Nuget utility... you will find downloads there to update your VS environment and intellisence to recognise the new html5 tags.

    or

    post the asp.net source (first few lines) to show us if my guess is correct and that you aren't using a valid dtd... forcing IE10 to use IE10 Quirks mode....

    If your company is using "Display intranet sites in compatibility view" (tools>Compatibility View Settings)... you need to add the x-ua IE=Edge meta to your page to over-ride the intranet compatibility view setting.


    Rob^_^


    • Edited by IECustomizerMVP Tuesday, October 23, 2012 8:22 AM
    • Marked as answer by Norven Wednesday, October 24, 2012 6:44 AM
    • Unmarked as answer by Norven Thursday, October 25, 2012 2:14 AM
    • Marked as answer by Norven Thursday, October 25, 2012 2:14 AM
    Tuesday, October 23, 2012 8:19 AM
  • Thank you~~

    tools>Compatibility View Settings

    Wednesday, October 24, 2012 6:44 AM
  • Thank you~~

    tools>Compatibility View Settings

    Hi Vedbaek,

    I meet the same problem

    I press F12 and find Tools, but can't find "Compatibility View Settings".

    Do you have an idea?

    Thanks

    Joe

    Friday, October 26, 2012 8:37 AM
  • I press F12 and find Tools, but can't find "Compatibility View Settings".

    Press F12 again to close the Developer Tools window (or frame) and then (in IE) just press Alt-T,b,Enter.

     
    ---

    Friday, October 26, 2012 3:01 PM
  • I signed into TechNet just to say "thank you".

    Thank you.

    Friday, March 22, 2013 5:30 PM