none
IE7 and desktop icons

    Question

  • I just installed Internet Explorer 7 today, which I guess is a.k.a. Windows Live. All of my fancy customized shortcuts on the desktop disappeared and each got replaced by the same generic windows icon.

    Right-clicking & changing the icons in properties no longer works.

    Also, when I create an internet shortcut while browsing, that creates a shortcut with that same generic icon (not even an explorer logo).  

    Now my desktop is just one forest of identical icons.

    Anyone know how I can fix this? I've wasted all day without success.  

    Sunday, October 01, 2006 3:21 AM

Answers

  • Try changing your icon size.  It worked for me.  I wasn't getting any shortcut icons either.  What I noticed was under my husband and daughters profiles,  the shortcuts worked just fine.  They used standard sized icons.  I was using large icons.  When I changed the size, all my custom icons were restored. 

     

    Properties------>Appereance-------->Effects------->Make sure large icons is not checked 

    Sunday, October 22, 2006 4:37 AM
  • Found this on another site:

    "After you have chosen your personal icon, go to the General tab on the Properties dialog and check "read only", save your changes."

    Problem is, people have complained that it isn`t allowed. Solution: After your have changed the icon to your desired one, click apply but DO NOT try to apply the " read only" tab, and close out the window. Right click on it again, go to the General tab, and click on "read only". It`ll take now!

    Monday, October 23, 2006 1:17 PM

All replies

  • Hi,

    The favicon implementation has changed to be more effective in IE7. If you revisit the content the favicon should be replaced by the correcte one.

    Thanks
    -Dave

    Monday, October 02, 2006 7:01 PM
  • The issue is not the favicon. In my case it is for a shortcut to a webpage that has been placed on the desktop. I have several web based applications that I had created icons for. I work in a school district where that is how teachers differentiate between applications. When I try to change the icon, to the customized version,  by choosing right mouse button, properties, change icon, it will not change. It changes on the tab, but when I watch the shortcut on the desktop, it flashes like it is going to change, but ultimately does not...it just has the e with the piece of paper behind it, not the custom .ico image.

    Is this going to be fixed, or is it going to remain this way?

    Monday, October 02, 2006 11:07 PM
  • Does not work for IE7 RC1. Any other solutions?
    Tuesday, October 03, 2006 3:57 PM
  • JDECO   You are absolutely correct. This has nothing whatsoever to do with favicons. The situation you describe is

    exactly the same as what I experienced except that I did not even get the icon with the e and the paper behind it, I

    got a different generic kind of icon, the first one in that .dll where we are supposed to be able to obtain changes in

    icons. Anyway, I started getting messages when visiting common sites like my Bank and the University of Maryland,

    telling me that those sites don't exist, so I finally just uninstalled IE 7.0 and re-installed Netscape 8.1 which is not

    much better but functional.

    Wednesday, October 04, 2006 2:21 PM
  • Dave   Don't take this personally, but this kind of "canned" response, not even related to the question matter is what really irritates a lot of people about Microsoft.
    Wednesday, October 04, 2006 2:30 PM
  • SKA1  Rigth. Ultimate solution is of course uninstall, and I did.
    Wednesday, October 04, 2006 2:37 PM
  • The issue is not a "favicon," whatever that happens to be ... the problem is that when one install IE7 it hijacks all of the custom icons for URL/web sites that we changed in IE6.  IE7 simply changes all of the existing URL/web site icons for a generic icon for IE7.  Then, to add insult to injury, IE7 doesn't allow you to change the generic icons back to the custom icons.  The bottom line question is .. how do you get IE7 to change a web page/URL icon?????
    Monday, October 16, 2006 2:25 AM
  • CPIAD

    That is exactly the problem and question I am also experiencing...I finally uninstalled both IE7 and Netscape 8.1 (which is also behaving unsatisfactorily now that AOL owns it) and I just surrendered to the IE6 that came hard-wired in my PC. It seems the lesser of all evils to just learn to live with IE6's shortcomings; at least it does'nt make anything dissappear and it does not crash very often. It seems that IE6 cannot be removed from my computer, that is why I am calling it "hard-wired"...

    Monday, October 16, 2006 11:35 PM
  • Use view as "icons" as the initial view is set for thumbnails or tiles. This allow for changing of icons.
    Thursday, October 19, 2006 4:33 AM
  • Dave,

    I followed your favicon suggestion... revisiting the site does NOT restore the shortcut icon. Also, as others have pointed out, IE7 does not permit a shortcut icon to be changed. How can this be corrected?

     

    Jeff

     

    Thursday, October 19, 2006 2:54 PM
  • i have same problem...has been true since first beta of ie7...web page icons saved in file for web pages refuse to take the change and revert back to shell32.dll...tried tweakui, it changed one icon for one second and flipped back to shell32.dll...anyone with a coherent answer???
    Friday, October 20, 2006 4:08 PM
  • I have just installed ie7 today

    I like lots of things about it BUT

    I have the same problem; all my customised icons with which I am familiar have dissapeared and have been replaced by a system icon? ( not the ie 7 icon)

    They will not change when you try to do so with Properties tab.  It seems they cannot be changed at all.

    Amazing that Microsoft would claim to do so much work on user interface and then effectively destroy the customers own custom designed interface.  Is there something I'm missing here? I don't get it!

    I would like some urgent explanation / input here from Microsoft

    Friday, October 20, 2006 4:44 PM
  • I like the features I've seen, but the loss of the icon control is not something I can tolerate.

    I will commence the uninstall as soon as I send this.

    Friday, October 20, 2006 6:12 PM
  • Yes... I did the same. Fortunately, the uninstaller is thorough, so everything returned to normal as soon as IE7 was gone.

    Friday, October 20, 2006 7:24 PM
  • see my message in the thread...help???
    Friday, October 20, 2006 7:47 PM
  • I am growing a suspicion that all of us who are experiencing this "disappearing icon" problem after installing IE7 probably bought computers with IE6 hard-wired in the operating system, something I believe the Supreme Court ordered Microsoft to stop doing (but its too late for us who already bought such computers). I think IE7 does not install properly to our computers because IE6 is there and there is a conflict between the two versions of IE regarding shortcuts and icons as well as other things. I tried to uninstall IE6 so I could install IE7 on a clean slate but it is impossible to uninstall IE6, all I can do is remove the tick in the Add/Remove Windows Components, which makes IE6 dormant but does not uninstall it. The proof of that for me is that when I got mad enough to remove the malfunctioning IE7 from my computer, I did not have to re-install IE6, it was still there, lurking in the background. It would be nice if someone from Microsoft would give us some guidance on this...!
    Friday, October 20, 2006 10:39 PM
  • Sorry, but that is wrong. In Windows XP that control is under Folder Options and the default setting is icons, not thumbnails or tiles. Anyway, I tried changing to every kind of view there is from every accessible option in my operating system and it did not fix the problem. 

      

    Friday, October 20, 2006 10:49 PM
  • Try changing your icon size.  It worked for me.  I wasn't getting any shortcut icons either.  What I noticed was under my husband and daughters profiles,  the shortcuts worked just fine.  They used standard sized icons.  I was using large icons.  When I changed the size, all my custom icons were restored. 

     

    Properties------>Appereance-------->Effects------->Make sure large icons is not checked 

    Sunday, October 22, 2006 4:37 AM
  •  Fluster_Cluck_Chickie wrote:

    Try changing your icon size.  It worked for me.  I wasn't getting any shortcut icons either.  What I noticed was under my husband and daughters profiles,  the shortcuts worked just fine.  They used standard sized icons.  I was using large icons.  When I changed the size, all my custom icons were restored. 

     

    Properties------>Appereance-------->Effects------->Make sure large icons is not checked 

     

    Very strange...

    I'm getting just some system/generic icon (not the Internet Explorer page icon) when I do that for URL shortcuts. Then when I enable large icons I get the proper icons showing what they should be. Thing is.. I don't want large icons! :( Why would it be doing this? This issue should have been fixed before official release.

    Sunday, October 22, 2006 5:35 AM
  • Hello Scribework:

    Here is the way I found to solve the problem...mmmmm ..not sure solve is the best term here: go to Control Panel/Display/Appearance/Effect and un-click large icons if it's clicked. Alas, I thought I could work my way around by going to Appearance/Advanved and change the size of the icon from 32 to say 40 or 50. But doing this automatically re-activate the lare icon tick in Effect.  The only good news- so far - is that it doesnt affect the large icon option in Office programs.

    Sunday, October 22, 2006 12:50 PM
  •  

    Thanks Fluster......Luke........& Antares....

    We seem to be getting a little closer to the solution here.

    Yes, unticking "large Icons" in Properties / Appereance / Effects, Made most of my icons return to my original customized choices but they were very small for my screen.

    Good news is, I found that I can make them almost as large again by using: Properties / Appereance / Effects / Advanced, select Icon from the top most drop down menu and set the size to 47.

    selecting anything above 47 seems to invoke the original problem.

    As I said; this seems to return most of my custom icons.  The ones which do not revert to my original customized choices either revert to their default icon or IE7 icon,

    in any case they are all changeable again using the properties tab. But the problem I now find is that the first time I visit a site the desktop icon reverts to its default icon and loses my customizations once again!!!

    Of course all of this also makes all my icons lose their location on my desktop. I can relocate them but I have enough to be doing without all this extra work. this is still very unsatisfactory for me.

    Sunday, October 22, 2006 8:30 PM
  • Same exact problem.  Cannot change internet shortcut icons that are on my desktop.  When I change it through properties --> change icon... , it will change for a quick moment and then flash back to the default ie7 shortcut icon. It's also discussed in the Microsoft discussion groups... with no solution as of yet.  I hope they're looking into this because it is entirely unreasonable that our ability to make personalized shortcut icons is being taken away.
    Sunday, October 22, 2006 9:10 PM
  •  

    But are you using IE7 ? Adjusting the size of icons without IE7 installed may deal with a similar problem, but I'll bet you a dozen donuts it does not work for someone with IE7 installed...Personally, I uninstalled IE7 and my computer experience is stable again and I'm not going to reinstall IE7 to experiment...

    Sunday, October 22, 2006 10:37 PM
  • Jeffnpat

    Don't be too complacent about the thoroughness of the uninstaller...I uninstalled IE7 too but just yesterday noticed that the search engine from "Windows Live" that came with the installation of IE7 is still in my system and is the one that pops up now when I click search in my IE6...this does not seem to cause any problem, but I think adds to Microsoft software's notoriety for "never letting go"...

    Sunday, October 22, 2006 10:44 PM
  • Hi Gerry Kaye,

    Thanks for the comprehensive description of your experience, which makes it clear you are still dealing with IE7 and desktop icons, not just desktop icons in general like some other posts seem to... So, it sounds like fooling with the icon sizing fixes the dissappearing icon problem but creates other troubles...I'm still not going to re-install IE7 but it is encourageing to know that if/when they get it out of Beta stage, it may be worthwile trying again... Congratulations to the poster who first suggested it had to do with icon sizing, I owe you a box of donuts..!     

    Sunday, October 22, 2006 10:59 PM
  • Found this on another site:

    "After you have chosen your personal icon, go to the General tab on the Properties dialog and check "read only", save your changes."

    Problem is, people have complained that it isn`t allowed. Solution: After your have changed the icon to your desired one, click apply but DO NOT try to apply the " read only" tab, and close out the window. Right click on it again, go to the General tab, and click on "read only". It`ll take now!

    Monday, October 23, 2006 1:17 PM
  • Thanks xrilander,

    Clicking "read only" keeps my customized icons alive.

    I'm beginning to like ie7 again

    GerryKaye

    Monday, October 23, 2006 5:32 PM
  • Hello guys strugling with these @##$%^& icons in IE7. Want to report that I seem to have fixed the problem on my PC. (DELL XPS 600 with DELL OEM XP PRO with native SP2).

    As indicated in a previous post I suuceeded in getting the IE7 icons back by going to Display/Appearance/ Effect and un-tick the large icons option. Well, further trial and error showed that, once you have shrunk all your beautiful icons (and made a mess of your desktop) if you re activate large icons in Display/Apprearance/Effect while KEEPING IE7 open, you restore the large icons AND keep the IE7 icons. The nice suprise is that some of my favorite links icons changed as they were taken over by the corresponding web site favicon.

     

    Hope it helps.

    Tuesday, October 24, 2006 9:39 AM
  •  

    Hello guys struggling with these @##$%^& icons in IE7. Want to report that I seem to have fixed the problem on my PC. (DELL XPS 600 with DELL OEM XP PRO with native SP2).

    As indicated in a previous post I succeeded in getting the IE7 icons back by going to Display/Appearance/ Effect and un-tick the large icons option. Well, further trial and error showed that, once you have shrunk all your beautiful icons (and made a mess of your desktop) if you re activate large icons in Display/Apprearance/Effect while KEEPING IE7 open, you restore the large icons AND keep the IE7 icons. The nice suprise is that some of my favorite links icons changed as they were taken over by the corresponding web site favicon.

     

    Hope it helps.

    Oooops...guess I posted it twice..sorry

    Tuesday, October 24, 2006 9:49 AM
  • Thanks for your posts on this thread. 

    Yesterday I installed 7 and am now experiencing the same problem(s).  Seems my entire collection of personally selected icons are now auto displaced when logging onto a particular site.  They are either replaced by site icons or my icons are removed and replaced by the generic IE7 logo icon. 

    I, personally, liked the ability to identify MY favorite links with MY CHOICE of icons.  That choice has now been summarily removed by our friends in Redmond, WA. No explanation, no forwarning, just doin' what MS does when it CHOOSES to take control of your browser options and individual decisionmaking.  This is a big step backwards insofar as I'm concerned -- neither user friendly, nor allowing "friendly" customer interaction with their product line "improvements."  I haven't checked into Vista beta yet, but now wonder what it will have in store for us. 

    Tuesday, October 24, 2006 3:28 PM
  • scribework..... did you ever find anything more on the IE shortcuts or Favicons as they are called.  Most of the posts here are about desktop icons or custom folder things rather than the ICONS IE explorer uses in links toolbars etc or even shortcuts to programs which cannot be changed in most cases because it greyed out.

    MY desktop icons for programs and documents etc they are fine.... but it I drag a url link from IE7 it is just a generic rectangle and can not be changed no matter what you do about read only etc. I have seen.

    I mean its obviously machine specific because I have some computers in my office that work and some that dont so its some combination of programs or MS addons causing this.

    Bloody annoying is what it is.

    Could MS please respond to some of this..... I even called IE7 support and the guy was so green he did not know what a Favicon even was.  His fix roll back to IE6 till new release comes out and it would be fixed.... NOT!!!!

    Thursday, October 26, 2006 5:26 PM
  • You are wrong my friend, now whats going on with IE7 and Favicons... see my posts in this area please.
    Thursday, October 26, 2006 5:28 PM
  • Does anyone have an issue with the full live verion of IE 7 where the little icons on the tabs show just the generic no association icon display on any website you go to ?.. Ive sorted my favorites icons to display fine  by removing the assoc under file type and readding it , but the quicktab icons still show generic noassociation icons. ??

    I,m sure its an ie7 bug ?.. even going to www.msn.com show genric icon , even thou Microsoft.com/ie7screen shots show the flowers icons on the tabs..

    Any help greatly appricated

    Thursday, October 26, 2006 10:07 PM
  • Sorry folks I fixed it , my Large icons was grey / ticked under display properties - advanced setting like the previous posts in this blog .. I assumed it wasnt ticked ..

    Unticked it and my favicons ? / tab icons displayed fine ..

    Weird odd stupid Micysoft bug I reackon!

    Thursday, October 26, 2006 10:29 PM
  • Richard,

     

    A Favicon, to my knowledge, is what you create when you right click on an open web page and proceed to "Add to Favorites". It is a Favorites Icon, or Favicon. My problem with IE7 and my posting that started this thread was about icons created on the desktop when one right clicks on an open web page and selects "create shortcut." This then creates an icon on the desktop that is in fact a shortcut to return to that page. Nothing to do with favicons, which do not  appear on the desktop, they are stored somewhere else, and you retrieve them by clicking on Favorites at the top of your IE browser.

     

    I uninstalled my IE7 because of the desktop icon/shortcut problem as well as some other issues. Since then, several people have posted in this thread that they found the solution to the icon problem to be (if I understand them right) to go into Start/Control Panel/Display/Appearance then click on the Effects button and make sure that the little box in front of "use large icons" does not contain a tick mark or a shade color; it should be totally blank and you can make it that way by clicking on the box until it goes blank.  All of the aforementioned would be the procedure if you were working with IE6; I'm not sure if the procedure is still the same with IE7. I do not wish to re-install IE7 to find out.

     

    If you have some computers at your office that work fine with IE7 and some that don't, you could start by checking to see if that "use large icons" box is different in the computers that work fine vs the ones that are being problematic. The "use large icons" box affects the size of icons everywhere in your windows. IE7 is not only a web browser, it is an integrated application involving your windows setups as well as acting as a web browser and it could be that they put some default codes in IE7 that assume everyone's windows settings are at the default status, which of course "use large icons" is not, it is a customized status.   Let us know what happens; I'm curious to find out.

     

    Cheers,

     

    Scribework

    Friday, October 27, 2006 12:46 AM
  •  

    Quote: Nothing to do with favicons, which do not  appear on the desktop

    Clarification: a "favicon.ico" is a file from the linked website, it is not controlled by you, the user.

    IE 7 now uses "favicon.ico" as the desktop icon when you drag and drop a web address to your local PC.

    My testing on XP Home with IE 7 shows that I can change the icon ... however ... as soon as I use the icon to visit the web page again the "favicon.ico" will override my chosen icon.

    Please understand that most websites do not have a "favicon.ico" so the lack of icon is probably being interpreted by IE 7 as "use default".

    --Brad

    Sunday, October 29, 2006 10:54 PM
  •  LukeAP wrote:
     Fluster_Cluck_Chickie wrote:

    Try changing your icon size.  It worked for me.  I wasn't getting any shortcut icons either.  What I noticed was under my husband and daughters profiles,  the shortcuts worked just fine.  They used standard sized icons.  I was using large icons.  When I changed the size, all my custom icons were restored. 

     

    Properties------>Appereance-------->Effects------->Make sure large icons is not checked 

     

    Very strange...

    I'm getting just some system/generic icon (not the Internet Explorer page icon) when I do that for URL shortcuts. Then when I enable large icons I get the proper icons showing what they should be. Thing is.. I don't want large icons! :( Why would it be doing this? This issue should have been fixed before official release.



    In fact, it has nothing to do with IE7, I think. I also got this problem today but I have no IE7 at all! The problem for me is that all icons in my desktop change to same icon which is from a installed program. I tried changing several times but all kept same. I tried the method Fluster_Cluck_Chickie wrote and it works great. If you don't want large icon, just change it back to small icon, and the problem is fixed even you changed back.

    I think this is the problem for caching. I got this problem when I shutdown my computer inormally and when I restarted it, the icons show in correct mode and changed to same wrong icon immediately.

    Tuesday, October 31, 2006 1:32 AM
  • Somebody suggested clicking Properties > Appearance and unchecking LARGE icons to solve the problem.  They reported that they could now change their desktop icons.  However, when I do this, I have no Appearance tab at all.  Is there a solution?
    Saturday, November 04, 2006 3:29 PM
  • Sounds like you are selecting the wrong "properties" dialog. Right-click your desktop and select "properties" from the popup menu...
    Saturday, November 04, 2006 8:40 PM
  •  Brad Einarsen wrote:

    Quote: Nothing to do with favicons, which do not appear on the desktop

    Clarification: a "favicon.ico" is a file from the linked website, it is not controlled by you, the user.

    IE 7 now uses "favicon.ico" as the desktop icon when you drag and drop a web address to your local PC.

    My testing on XP Home with IE 7 shows that I can change the icon ... however ... as soon as I use the icon to visit the web page again the "favicon.ico" will override my chosen icon.

    Please understand that most websites do not have a "favicon.ico" so the lack of icon is probably being interpreted by IE 7 as "use default".

    --Brad



    H-m-m-m-m.  I think I understand what you're saying, Brad, but just for further clarification, we're not giving up control of our system or anything to a remote site when we link to it, are we?   Another point:  if most sites don't have a favicon, then of what use is this feature really?
    Sunday, November 05, 2006 2:43 AM
  •  Fluster_Cluck_Chickie wrote:

    Try changing your icon size.  It worked for me.  I wasn't getting any shortcut icons either.  What I noticed was under my husband and daughters profiles,  the shortcuts worked just fine.  They used standard sized icons.  I was using large icons.  When I changed the size, all my custom icons were restored. 

     

    Properties------>Appereance-------->Effects------->Make sure large icons is not checked 

    Monday, November 06, 2006 3:41 PM
  • Fluster_Cluck_Chickie's post worked for me...
    Monday, November 06, 2006 3:43 PM
  •  

     

    Fluster_Cluck_Chickie's post seems to work.

    Monday, November 06, 2006 3:48 PM
  • I had the same issue with the favicons on IE7:
    Some of the icons of the "Links"-Toolbar  in IE (what are nothing else as favorites) were displayed with a wrong symbol. I figured out that the error is dependend on the current logged in user (different display errors on different user profiles).

    Usually the erroneous icons showed the symbol of a later visited web site.

    My solution: I deleted the temporary internet files in the IE options, closed the browser and reopened it.
    After that all the icons of the toolbar where displayed with the correct symbol!

    The windows icon cache repair tricks didn't help on my computer (changing the display color depth or the icon size).

    I think that IE7 caches the favicons apart from the windows icon cache in the temporary internet files folder.
    Sometimes it mixes up the favicons of different web pages in that folder. So deleting the folder helps,..

    Thursday, November 09, 2006 2:50 PM
  • The New finished IE7......because of live feeds....when you visit a site that has a fabracon embeded.....it will change your PERSONALLY CHOSEN ICON..............you can change your icon back as much as you want..but it is useless for everytime you click on it to that web page the IE7 by default will change it to the webmasters choice....

    We people who like making personal icons or cartoon icons or any type icon..

     

    are very upset with Microsoft

    Icon usage is a personal choice......which IE7 the final version has taken away...............

    Live feeds are the cause........and there is nothing to stop it right now........Live feeds will drain your system and eventually slow you to a crawl or a crash.......and they stop your choice of icon choice that you desire.

    pa

     

    Saturday, November 18, 2006 3:49 PM
  • Why is it that we feel like Paul Revere on this issue? 

    Wait til users wake up to see all of their personally chosen icons replaced with "auto-icons" from whatever site they visit.  Personally, I liked having a Daffy Duck icon for Yahoo mail.    And now I have the big red Y for every single Yahoo website I visit from my favs. 

    So much for personal choice in Explorer 7 and no wonder that not a single MS tech or "manager" here on MSDN has had the guts to confront this issue with their opinion much less their rationale for changing this protocol.  ...silence is golden, eh?

    Anyone listening in @ 98055?

    Oh, oh, better be careful or they will remove the ability to make larger or colored fonts here on MSDN. 

    Monday, November 20, 2006 2:11 AM
  • Hello.

    Try my fix I posted here:

    http://forums.microsoft.com/MSDN/ShowPost.aspx?PostID=890597&SiteID=1

    It will repair your "generic icon" problem.

    Bye
     
    Markus
    Monday, November 20, 2006 11:39 AM
  • xrilander, you de man!!!

    I've been fighting a changing desktop icon problem ever since installing IE7. Your solution is simple and effective. Thanks a bunch.

    Jim O

    Thursday, November 23, 2006 1:19 AM
  • I was experiencing the same problems w/ ie7 and seemed to have solved them by right clicking on a shortcut and changing the attributes to "read only". This seems to have been a quick solution until microsoft fixes their bugs. P.S. you'll have to do this w/ all the shortcuts you wish to customize the icons on after you've changed them.
    Friday, November 24, 2006 4:20 AM
  • your fix/////////// PHOOEY///////

     

    You are not even understanding what we are all talking about............!

     

    We all use  icons.....you know cartoon caracters...or pictures....But IE7  displaces them when we visit a site....

    Changing size and ticking this and that DOES NOT WORK.........

     

    I like to click Mickey Mouse and it takes me to Googel,,,or Donald Duck goes to Hotmail...

     

    All my  Favorites have characters,,,,and all my desktop icons are those of my choice....

     

    I use IE7 and my bear ICON

    changes to NETSCAPE....i do not like Netscape...

    Nor your choosing my icons for me.....change the program in IE7......and do not tell me Microsoft cannot do it...PHOOEY!

     

    You at Microsoft simply need to change the gut internal program line that seeks default from the web site,,,,,,,,,,,,THAT SIMPLE!!!!

     

    SO GO DO IT..............PLEASE!!!!!!!

     

    Saturday, November 25, 2006 4:26 AM
  •  

    I recently updated a lab of 28 laptops all running windows xp pro. IE7 changed the custom URL icons on all the desktops but only 2/3 of them would pick up the provided icon once the web sites were revisited. Strangely enough if I right clicked on the desktop and changed the diplay mode to high color from true color the icons would change from the IE default white paper to the icon from the site. It still does not allow me to customize icons for websites that provide their own but at least it's better than nothing. My custom icons for websites that do NOT provide their own remain unchanged either way.

     

    Wednesday, November 29, 2006 4:52 PM
  • I have got the same problem. I have icons on my desktop that link to my favourite websites, for which the icons now default to IE icon, dispite trying to change the icon.

    I had problems with the IE7 beta so I uninstalled it. But on final release of IE7 I installed it - I really need it as I am a web designer and I'm learning WPF.

    The icon bug seemed to be resolved at first, but because I love using custom icons I like to turn on the "use large icons" effect. It was then that the icons default to IE again.  As said before this really decreases usability since there is no graphical differantiator.

    Has anybody had any success with third party tools like Microangelo?

    I hope Microsoft fix this bug. It won’t even use the default Firefox icon that the system is set to use.

    Wednesday, November 29, 2006 7:20 PM
  • Well I'm sure no  puter techie by any means -- I just use the  icon that the site gives me-- some times my ETrade icon is there and some times it's gone back to a generic icon. My Ad-Aware and Spybot icons seem to be holding up fine so far!!

    For U techies out there I did notice that when I upgraded to IE7 it put this note into "My pictures" folder >>

    [DeleteOnCopy]
    Owner=Ron
    Personalized=39
    PersonalizedName=My Pictures
    [.ShellClassInfo]
    InfoTip=@Shell32.dll,-12688
    IconFile=%SystemRoot%\system32\mydocs.dll
    IconIndex=-101

    Maybe some of U techies can figure out some icon fixes from this info!!!!!!!!!!

    Regards Ron

    Thursday, November 30, 2006 8:54 AM
  • I am also experiencing this issue with IE7, I have tried some of the fixes here, and have had some success.  Any internet shortcut placed on the desktop is fine now, but as soon as I drag that icon into a folder it defaults to the IE7 generic icon.  Being that I am in chage of a few labs at a college, I need to keep the internet shortcuts seperated via folders for different classes so the students can access them easily.  Is anyone else having this problem going from desktop to folder with the shortcuts?  It is probably some simple setting I am missing in Folder Options, but at the moment I am at a loss.  Any ideas?

    Friday, December 01, 2006 6:53 PM
  • There is a simple solution for all of these messy issues... let's wait for service pack 1.
    Friday, December 01, 2006 9:23 PM
  • Here's my 2cents worth on this issue (as a user).

    (1) In my environment (WXP Home), dragging the address link off the browser from a website that calls out its own custom icon to your desktop (ie, creating a shortcut), DOES pickup the custom favicon file and shows it on my desktop as anticipated. By experimentation with my own website code, It also appears that the favicon file can be favicon.ico or favicon.png.

    (2) IE7, version 7.0.5730.11  DOES NOT save or use favicon files *within the browser*. That is, it DOES NOT show the custom icon in the address bar nor in the favorites lists. No matter how many times you go back, no matter how many times you refresh, no matter NOTHING. It simply does not work, or as some have implied, perhaps the custom icon is intentionally overwritten by IE7 with the generic IE logo.

    It must be repeated: THIS IS UNACCEPTABLE behavior and *will* drive people back to Firefox if they are not otherwise constrained to stay within the Microsoft environment. I actually like the new IE7 and, aside from this one very very very unacceptable item, find it attractive enough to continue using it.

    But, surely, something as straightforward as this favicon, itself introduced by Microsoft with IE5 to the delight of the user world, can be "fixed" to work as anticipated by USERS? It seems odd to see that Firefox should now be setting the standard for this Microsoft innovation. 

    By the way, the favicon should not have to be something a user has to 'Tweak' or otherwise select as an option.

    edit: well, fooey...just installed IE7 w/sp2 and all the custom icons were overwritten with the "generic page" (ie, not even the IE icon). So, now my IE *totally* behaves with unexpected behavior.

    Friday, December 01, 2006 11:32 PM
  • @Pabear
    I guess I understand what you are talking about. But there are some posts here different to yours. And a solution to keep your favicon was given here!? Change the icon and "read-only". Only one more step you have to do.

    PS: "your fix///////////PHOOEY///////"
         Sorry, but I did it on my own. Compared two sytems and found out what changed...
     
    PPS: I also found the reg-key which "kills" your favicons, but each IE7-start renews that key. Changes will be reset... Only write-protection could help.
     
    Bye 
    Monday, December 04, 2006 1:29 PM
  • In response to my earlier post about the icons holding the custom icon on the desktop, but defaulting to the IE7 icon in the folder, the problem has been solved.  I am not sure why this was happening, I was logged in as the local Admin and could not get the icons to hold (these were internet shortcuts).  I tried some of the fixes posted on here, and it was not working.  I became frustrated and decided to leave the problem for now and reset the computer and logged in on the student side (power user rights).  Viola, all the icons held the custom icons and worked normally.  Perplexed by this, I logged out and logged back in as Admin and the icons were the default IE7 icons.  It works on the power user side, and not the admin side, what ever, it works for the students and that is what matters.  I do think Microsoft needs to look at this problem though.
    Thanks for the help guys.

    -cloud.
    Monday, December 04, 2006 7:29 PM
  •  

    December 9th reinstalled IE7

    Tried the "read Only" FIX....which worked for but a few.....and MANY WERE LOCKED BY IE7.....yet when tabbed to change icon then showed in the change box the cartoon icon of my choice..but would not apply..applied and then IE7  would control them back to IE 7's choice. Icon or favicon makes no difference...shortcut or lead makes no difference...ICON CONTROL IS OUT OF USERS CONTROL...and that alone is the ISSUE!

    By the way I shall spell PHOOEY as I desire...Go look it up!

     Too much confusion on this issue....Simply,

    Microsoft needs to change the IE7 internally....This should not be a HOME USER......Let me learn to bypass Microsoft deal on the simple choices of User Preference....

    DO NOT YET YOU SEE?   IE7 is making your choices for you without your opinion and rights....As you surf...It is deciding for you..Why do we have individual brains then? Or why should we choose say a Donald Duck cartoon icon to take us to our desired home page rather than NETSCAPE BLACK ICON.....or if you goto YAHOO you will soon have a computer full of RED Y'S....all the same....PHOOEY!

    HAVE TO DO........AND Microsoft appears not to really care at this point.

    Of Course....I had to

    Uninstall IE7 to enjoy

    my chosen icons for my shortcuts and favorites......

    IE7 is also so very slow

    for surfing...and that also is yet another issue...I like high speed surfing...PERIOD!

     

    And, the IE7 extra line added to APPLETS....why that is so foolish and causes USER to have to reform Game Applets to see the entire Game Applet..another question showing IE7 actually sucks to users that like Speed and Uniformity and Control of their own System.

     

    Pabear

    Sunday, December 10, 2006 9:57 AM
  • I'm an amateur web designer, and just created and added a favicon to my web site.  In learning about favicons, I learned that there are many different formats of favicons, and you can get an editor to great a "multi-format" favicon.  IE will ignore anything but a 16x16 pixel icon.  Other programs are looking for a 24x24, 32x32, 48x48 or even 64x64 pixel icons.  I found an icon creator program that allows me to bundle all the sizes into one 'favicon.ico' file.  Then depending on what is viewing/using the file, the appropriate icon will display.

    While IE likes 16x16 ONLY, if you create a desktop shortcut to the website, XP will pick one of the larger versions of the file - not sure which one but it's not the 16x16.  The way I know is because on the one multi-format favicon I created, the 16x16 is rude & crude, but there is lots more details on the larger versions of the favicon -- and the detailed version of my favicon is what is showing up on the desktop shortcut.

    So, my GUESS, is that XP is using the larger versions of the icons.  it probably uses the 24x24 when you are not showing large icons.  It probably uses the 32x32 or 48x48 version when you have "large icons" checked in your display options.

    So if the webpage creator did not create a "multisize" icon when they created their favicon, then you may/may not see what you want to see -- you'll get a default icon, probably.

    There is even a color dimension to this.  For a 16x16 icon, you can create a 16 color, 256 color OR 32 bit color icon.  Same with the 24x24 and 32x32.... icons.  So depending on how you have your monitor display set (numbers of colors) again you will probably see different icons. 

    This might explain why different users on the same computer see different results - are the color settings, display size, and icon size the same on all the users?

    So blame MS for allowing all the options, but it is probably the developers not creating a favicon with enough options for all the different MS programs to read! 

    Tuesday, December 12, 2006 10:11 PM
  • Why is so much of this thread devoted to "FavIcons"?!?! This is supposed to be about Desktop Icons, has nothing to do with the color depth or dimension of the icons, and little or nothing to do with shortcuts you drag onto your desktop.

     This problem - DESKTOP ICONS not displaying, etc. is serious.  The fixes provided in this thread may temporarily "fix" the icon display but there is, so far, no permanent fix.  Removing IE7 does NOT always fix this problem. TweakUI provides no fix and continually hangs when I try to "Repair Icons".

     I find it curious that the ShellIconCache file is missing from the WINDOWS folder, as are ALL references to ShellIconCache in the registry?!!!! I also find that Windows Explorer is now hanging on Shutdown/Reboot and must be manually terminated (or timed out). This tells me that IE7 has made significant changes to the way XP (and Explorer) handle icon caching. I suspect that ntdll and some other system files, including ntuser.dat have been modified and that the "uninstall" did not undo those changes.

     This system is less than a month old and has been CAREFULLY setup.  Everything worked well until IE7. Today and tonight are now set aside to do a complete system restore and re-load app's, drivers, etc. - except for IE7.

    Microsoft is surely aware of this problem and the typical lack of response is typically disheartening but expected. that's the Totally Bogus reality of most MSDN forums - there are precious few posts from Microsoft that contain anything of real value, such as a RESOLUTION to problems or even the acknowledgement that these problems exist.

    That and the fact that too many people find it easier to change the thread topic inthe middle of their posts rather than starting an appropriate thread  of their own. So clearly labeled threads like IE7 and desktop icons end up full of favicon and icon color depth and other potentially interesting but totally misplaced and irrelevant posts like "So blame MS for allowing all the options, but it is probably the developers not creating a favicon with enough options for all the different MS programs to read! " What drivel!

    Such is life.........

    Wednesday, December 13, 2006 10:10 PM
  • I have had the same VERY IRRITATING problem since installing IE7.

    Here's the issue -- unchangable IE7 desktop shortcut icons -- as I experience it on all eight PCs at home:

    1) The problem occurs only when the desktop icons are set to "Use large icons" in Display Properties > Appearance > Effects. It does not occur when standard small desktop icons are used.

    2) The problem occurs only with IE7 desktop shortcut icons, not with any other folders, file or app shortcuts (in other words, when you drag a URL from the browser to the desktop, thereby creating an IE7 shortcut icon on the desktop). Remember Point 1 above - the desktop must be set to "Use large icons"!

    3) This has absolutely nothing to do with favicon or "Read only" settings.

    4) This is a very irrrrrrrrrrrrrrrrrrrrrrrrrrrrrritating bug!  Please fix it, Microsoft. Soon. Don't alienate your best users.

    Thursday, December 14, 2006 9:07 AM
  • There are in fact (at least) TWO distinct IE7 desktop icon problems, though they might well be related:

     

    PROBLEM ONE - CANNOT CHANGE DEFAULT IE7 SHORTCUT ICON ON DESKTOP WHEN USING LARGE ICONS

    To replicate this problem:

    1. Set the desktop icons to Large by right-clicking the the desktop and then Properties > Appearance > Effects and ticking on the "Use large icons" box. Apply the setting by OK-ing out back to the desktop.

    2. Open IE7 and navigate to a website.

    3. In the IE7 address bar, click the icon immediately to the left of the URL and drag it to the desktop, thereby creating a dsktop shortcut for that particular web page. The shortcut icon created on the desktop will be the default IE7 icon.

    4. Now right-click the newly-created desktop shortcut icon, click Properties > Change Icon.... This opens the SHELL32.DLL default icon file.  Select a new icon for the shortcut (or your own custom icon using Browse...) and apply it by clicking OK and OK again.

    5. The desktop shortcut icon created in Step 3 above does not change to the newly-applied icon selected in Step 4 above -- it flashes briefly and reverts back to the default IE7 desktop shortcut icon.

    6. No amount of fiddling changes anything.

    7. Sigh.

     

    PROBLEM TWO - WHEN USING STANDARD ICONS, IE7 DESKTOP SHORTCUT ICON CHANGES TO THE WEBSITE'S FAVICON WHENEVER YOU VISIT THAT WEBSITE BY CLICKING THE SHORTCUT

    To replicate this problem:

    1. Make sure the desktop uses standard/default icon size by UNticking the "Use large icons" box in Display Properties > Appearance > Effects 

    2. Open IE7, navigate to a website that uses a favicon (eg cnn.com). Drag a website URL to the desktop to create a shortcut (as in Step 3 in Problem One description).

    3. Change the newly-created shortcut icon to another as in Step 4 above. Apply the new icon selection.

    4. The IE7 desktop shortcut icon changes to the newly-selected icon, and all seems fine.

    5. Close IE7.

    5. Now, click on the desktop shortcut icon you created in Steps 2 and 3 above - this will open the web page specified in the shortcut.

    6. Your newly-customised desktop shortcut icon spontaneously changes to the favicon, overriding your customised icon selection.

    7. Sigh.

     

    A few other funnies I discovered:

    a) When in Large Icons desktop mode, customising an IE& desktop shortcut does not change the icon (this is Problem One above).  Howeve, when you then change the desktop to standard icons, the newly-cusomised icon does indeed appear.

    b) If you have a Quick Launch toolbar with Large icons defined, changing the desktop to small icons also changes the Quick Launch icons to intermediate-sized icons (neither large nor small) - and your customised shortcut icon in the Quick Launch toolbar also changes to the correct icon.  Changing the desktop to Large icons changes the icon back to the default IE7 icon, ignoring your cutomised icon.

    Thursday, December 14, 2006 10:18 AM
  • Solution that worked for me and my husband's computers.  Right click on blank area on desktop, click on properties, click on appearance, click on effects, un-check use large icons.
    Sunday, December 17, 2006 12:11 AM
  • When IE7 was still in pre-release and Microsoft was asking for feedback, the issue of customized desktop icons reverting to generic icons was discussed in several posts.  Microsoft either couldn't fix, didn't want to take the time to fix, or didn't think it was important enough to fix.  The problem is more than an inconvenience for visually handicapped users.  Let's hope Microsoft puts this issue on their list of priority fixes for IE7.  I've opted to remain with IE6 when I need to use a Microsoft browser and use Firefox for everything else.

    Sare1

    Thursday, December 28, 2006 4:46 PM
  • Here is a workaround:

    Create a new desktop shortcut (not an IE shortcut) -- rt click on desktop, click New, click Shortcut

    For the target, enter "C:\Program Files\Internet Explorer\iexplore.exe" http://www.sitename.com

    Change the icon

     

    Friday, December 29, 2006 2:23 AM
  • Here is a workaround:

    Create a new desktop shortcut (not an IE shortcut) -- rt click on desktop, click New, click Shortcut

    For the target, enter "C:\Program Files\Internet Explorer\iexplore.exe" http://www.sitename.com

    Change the icon

    Friday, December 29, 2006 2:25 AM
  • Thank you for the response Howard39.  I'm not sure we're talking about the same issue.  In IE6, I could right click a desktop icon pointing to a particular website or folder.  If I selected <Properties>, I then had an option to change the desktop icon to any .ico file I wanted.  I used custom icons, downloaded icons, et. al. to represent visually what was at the website or in the folder.  When I installed IE7 (and apparently when others installed it), those custom icons became generic and simply won't display as the custom icons previously selected.  I can create a new desktop shortcut, but the icon displayed is a generic Windows icon.  I tried your workaround--didn't solve the problem.  I think Microsoft is going to have to help users  with this one by issuing a patch or update.

    Sare1

    Friday, December 29, 2006 3:29 PM
  • Thank you Sare1 and all others in the forum for all of your hard work in this matter.
    I agree with Sare1 wholeheartedly and profoundly that Microsoft really, REEEEAAALLY MUST, help us out with this problem. I'm one of those visually handicapped folks and the fact is that I'm legally blind so I must have the largest icons that I can get. These must be distinguishable also from each other and IE7 fust won't do this. All of my web page shortcut icons are as others in the forum have described and I'm so angry and disgusted with Microsoft over it that mere words fail to express it. How long will this arrogant disregard continue. Microsoft keeps telling all who will listen that they are very concerned with accessability for handicapped individuals but when it's time to actually make something to be so....
    How 'bout it Microsoft? Are you reading any of this thread?
    Be aware that you really are making a REAL LOT of folks like me REAL UPSET and I mean this in the stronges sense. I'm not kidding even a little bit!!!
    Thank you once again forum members. I'm glad that I was able to figure out how to participate in this. I used my 3rd party screen reader to good advantage in order to do so because the one built into Win XP is another piece of junky engineering from Microsoft.

    Saturday, December 30, 2006 5:47 PM
  • Dave,

    Actually, it appears to work intermittently for some strange reason. It's not clear to me whether some legacy problem can cause IE7 to be impaired on some systems, because the results we test here show the bookmark favicon operating very irratically.   On some systems we note the favicons just "come" and "go" in odd ways - one browse on, one browse off, one site adopted everywhere, on others, they don't display at all, on others they work fine with IE7.

    What seems to be missing is the "absolute" mode of updating the favicon image for a tab and the address bar.  By default, if otherwise unable to display the favicon, and there exists a favicon.ico 16x16 in the root, it should be displayed.  It also should be displayed promptly, the GET sequence appears to be backwards in IE7.

    It appears as if it is also sometimes dependent upon the server hosting the page, and on the condition of the TEMP INT folder, we see variance there, and sometimes it appears the mime type has to be corrected in the .html.

    Frankly, the rules were supposed to be to address ANY favicon.ico in the root of the site and keep addressing it unless and until over-ridden in the <head> or in a script by the writing of a different .ico in a page.

    We also note that we have simply been unable to verify whether you support the "animated" form of favicon. Does IE7?

    Please advise.

    Dr. Jack A. Shulman
    for: COMPAMERICA
    908-931-1200

    Sunday, December 31, 2006 6:54 AM
  • Restore your favourite icons, apply,save,click general,check read only. Problem solved.Worked for me in all cases.
    Friday, January 05, 2007 9:09 AM
  • You win the prize.........this works!!!!! with one exception, just change icon size either way and the icons come back then put it bakc to whatever is normal for you.
    Sunday, January 07, 2007 12:57 AM
  • lancelot88, can you explain in more detail?  The problem I'm having is that I can't restore a favorite icon for an Internet link.  I did try logging on with limited rights rather than as administrator.  I was able to change the icons, but since I'm the only user of this computer, it seems bizarre to have to 'recreate' myself with limited rights.  It's clearly a change from IE6.  I imagine it has to do with the increased security IE7 is supposed to provide, bit I'm not willing to sacrifice the functionality of customized icons.

    Sare1 

    Sunday, January 07, 2007 10:43 PM
  •  Dave Massy wrote:

    Hi,

    The favicon implementation has changed to be more effective in IE7. If you revisit the content the favicon should be replaced by the correcte one.

    Thanks
    -Dave

    Why, then, do I have icons from several sites, such as Google and others, in my favorites but mine doesn't show up? It shows up in FireFox and Netscape. Could it be the file extension does not match the file type? I saved the file as favicon.ico with an icon creation tool by importing a .bmp at 16 x 16 px. Any chance the icon tool only changed the extension text and not converted the file to .ico?

    Word has it that FF and NS can both use .bmp for the icon.

    The tool was Icon Edit Pro v 7.14

    Thanks

    Monday, January 08, 2007 8:44 PM
  •  Dave Massy wrote:

    Hi,

    The favicon implementation has changed to be more effective in IE7. If you revisit the content the favicon should be replaced by the correcte one.

    Thanks
    -Dave

    Why, then, do I have icons from several sites, such as Google and others, in my favorites but mine doesn't show up? It shows up in FireFox and Netscape. Could it be the file extension does not match the file type? I saved the file as favicon.ico with an icon creation tool by importing a .bmp at 16 x 16 px. Any chance the icon tool only changed the extension text and not converted the file to .ico?

    Word has it that FF and NS can both use .bmp for the icon.

    The tool was Icon Edit Pro v 7.14

    Thanks

    Monday, January 08, 2007 8:44 PM
  • Unchecking large icons does work to allow personalized desktop icons.
    Friday, January 19, 2007 4:00 PM
  • I've been able to develop a workaround, similiar to some of the previous posts but with more specific information.  If you select <Display> from the the Control Panel menu, then select <Appearance> and <Effects>, you should uncheck the 'Use large icons' box.  Your customized IE shortcut icons will reappear, but much smaller (size is 32).  Select the<Advanced> button in the Appearance dialog box, then select <Icon> in the Item dropdown menu.  You can increase the size of the icon up to 47.  If you try to go larger, the software  apparently assumes you want to use large icons and rechecks the 'Use large icons' box in <Effects>.  I don't know if this is a universal workaround, but it has solved the problem of generic icons for IE7 shortcuts on the Desktop for me.  FYI, I saw lots of postings about Favicons for this thread.  That really is a different topic and should be a separate thread.

    Sare1

     

    Friday, January 19, 2007 5:23 PM
  • Thank you Sare1. It works.
    As I said in a previous message, I'm legally blind and so the smaller icons are a bit small for me to deal with but at least they don't look so stupid anymore and I can recognize them again.
    Now... if anyone can figure out how to get the same results using the "Large Icons" setting we'll have something that will help better still for folks whose eyesight is even worse than my own.
    The MS software engineers that created this bug in the first place are clearly still the villians here and it OUGHT TO BE FIXED BY MICROSOFT.
    They make such a BIG noise about how they're sooooo interested in making thier products accessable for folks with handicaps but I keep wondering when they're actually going to put thier money where thier mouth is.
    Once again, thank you very much Sare1. This is the only thing that has helped me at all.

    Friday, January 26, 2007 5:30 PM
  • Changing the size....unchecking large....DOES NOT CORRECT THE PROBLEM.....

    The problem is in IE7 itself....Only Microsoft can repair what it has done...Probably will not because certain web sites pay MIcrosoft per unit shortcut to theirs instead of users choice of ICON.  So do not expect Microsoft to repair what they are making money on.

    Cute icons are fun and over the years many of us use them and even create our own...Some handicapped users use them as easy identifiers to their sites they like to use....IE7 will not allow this!

    We write here..but, Microsoft apparently does not read here...Have sent inquieries directly to Microsoft....Useless it appears!

    I will never install or use IE7 as long as I can use something else....Have tried it over and over with always the same end results.....The end!

    pabear

    Monday, January 29, 2007 3:45 PM
  • Pabear, don't despair.  There is for sure a problem when a desirable capability from prior versions has been dropped.  As several contributors to this forum have said, this isn't trivial for people with visual impairments or poor eyesight.

    Re unchecking the 'use large icons' box in the <Effects> dialog box in the <Appearance> tab of <Display Properties>, that will shrink the icons from 48 to 32, but custom IE shortcut icons on the desktop will display properly, though small.  Then if you go to <Advanced> under the <Appearance> tab and select <Icon> from the items dropdown menu, you can enlarge the icons up to 47 and they will display correctly.  I'd like to make them bigger, but that won't happen until Microrsoft addresses the problem.  But in the meantime, you can have decent-sized icons and no tears.

    Sare1

    Monday, January 29, 2007 4:30 PM
  • Sare1, your sneaky workaround does work. Thanks.  But it doesn't solve the favicon replacement problem.

    But think you missed what Howard39 was offering.  It is a legitimate workaround.  He is talking about just right-clicking on the blank desktop, and choosing to make a new shortcut.  This brings up the shortcut creation wizard, and then you just follow what he said to do, again:

    For the target, enter "C:\Program Files\Internet Explorer\iexplore.exe" http://www.sitename.com

    Then click Next, give a name to the new shortcut, click ok to leave the wizard, then go into the properties of the new shortcut and change the icon.

    I like this workaround, because it solves Problem 1 and Problem 2.  It lets me have my full-sized icons, PLUS it keeps IE7 from reverting my icons back to the favicon.

    It basically just takes IE7's grubby hands away from these shortcuts, because they are no longer internet shortcuts, but just desktop shortcuts with internet links.

    I just created new shortcuts this way for about 10 internet shortcuts I keep on my desktop, and it just took a few minutes.  With cut and pasting of the url info from your existing shortcuts properties box, you can create each new one in less than a minute, without hand-typing anything.  In fact, someone could make a teeny little app to convert desktop internet shortcuts to generic shortcuts, and have it come up on the drop-down menu whenever you right-click on an internet shortcut.

    Thanks Howard39, I'm enjoying my large icons and IE7 now.  I am going to migrate to Vista in a month or two whenever 3rd party vendors catch up with all the driver support and such that are still lacking, and maybe this workaround will still work for me there.

    Personally I don't even care if Microsoft fixes this now.

    Peace,

    Danube

    Monday, February 12, 2007 5:43 PM
  • Thank you, Danube.  I like your solution (actually Howard39's) and didn't understand at first what he was suggesting.  Since I have about 10 IE shortcuts, it's been easier for me to just resize using the advanced button in <Appearance> and adjusting the icon size (after I unchecked <use large icons> in the <Effects> menu).  The workaround applies to all my icons at once.

    This forum is great--better than an IT department of twenty!  Thanks Howard 39 and Danube.
    Sare1
    Wednesday, February 14, 2007 7:16 PM
  • Hi, thank you !  I actually followed your instructions but had to check the large icons box.   All my shortcuts reappeared large.  I then just un-checked the large and they all returned to normal size.   Problem solved, thank you, thank you, thank you
    Saturday, April 21, 2007 7:57 AM
  • One unsatisfactory solution is to use small icons.

     

    Right Click on desktop, then choose properties-appearance-effects - then unckeck the "use large icons" option.  This will now allow you to change icons, although the Icons are hopelessly small.

     

    If I find another solution, i will let you know

    Sunday, April 22, 2007 7:57 PM
  • Further to my recent reply re "change icon" in IE7, this is the full solution

     

    First, on desktop, right click, choose properties .... appearance ---- effects, and unckeck the "use large icons"

     

    Next, change icon to one you want.

     

    Now to make the icons bigger again, go to desktop, and right click,....properties, appearance, advanced. Underneeath item, select icon from the frop down list, and I have been able to inrease the size to 46 without the icon chnaginf back - any higher and we are back to square one.

     

    Hope this helps

     

    daveandhannah, UK

    Sunday, April 22, 2007 8:11 PM
  •  

    Microsoft posted a fix for this problem that does not always work. Type the given link in your browser if it is not highlighted, and it leads to a blog that gives the link to Microsoft's fix plus step-by-step instructions how to fix the problem if the fix by MS does not work.

     

    http://bextruthfinder.blogs.com/mental_equilibrium/2007/05/yes_virginia_yo_l.html

     

     

     

     

    Wednesday, May 02, 2007 1:22 PM
  •  daveandhannah wrote:

    One unsatisfactory solution is to use small icons.

     

    Right Click on desktop, then choose properties-appearance-effects - then unckeck the "use large icons" option.  This will now allow you to change icons, although the Icons are hopelessly small.

     

    If I find another solution, i will let you know

     

     Thank You SWEETIE, you clued me into what was wrong with my desktop urls !!!!!

    Now goto Properties-Appearance-Advance-Choose Icon from drop down list and change 32 to 46.

    You will have large icons again!

     

    MomDawg57

    Wednesday, May 09, 2007 2:00 PM
  •  This should solve your problem:

    a. Right click the Desktop

    b. Choose 'Properties" from the menu.

    c. Click the 'Appearance' tab.

    d. Click the 'Advance'button.

    e. Click the 'Item' drop-down menu on the window that appears.

    f. Select 'Icon'.

    g. Change the size down to 47 or lower.

    h. Click 'OK' twice.

    Wednesday, May 23, 2007 12:19 AM
  • Thanks, xrilander.  You solved my icon problem!

     

    Thursday, December 27, 2007 1:23 AM
  • Wow, after phrasing the question a thousand ways, and searching a thousand pages, finally a super simple (duh)
    answer to a most simple question.  Thanks.  Guess I should have noticed the problem began when my eyes
    decided to go larger.  I'll put on my glasses and go smaller again, since I love to play with my icons, and get a
    kick outta the grandkids checking them out. Not to mention, not using IE for much. I must say, the grandkids are
    starting to get better on the web stuff than me, but I'll still kick their rears on business apps, and actually using the "computer" not the web. 
    HEAVY SIGH
    Tuesday, March 11, 2008 3:18 AM
  •  

    I was so excited I had to register just to post.  Though it was not exactly the same problem I had it fixed something that had been driving me nuts. My IE icons would not work after repairing windows xp from the disc and then IE7 and resetting all my preferences etc. They showed as "unassociated files"

    No matter what I tried would not work. They worked on other user accounts so I assumed it was something I transferred to my new account on the new windows. I also tried switching registry icon stuff and the icon target but it wouldnt work.

     

      Anyway after all that trouble and nothing worked I took a suggestion from one of the repliers. Yes I do like using "large icons" and that is one of my settings. The "fade affect" I never touch, I dont think. Still, unchecking "fade affect" made the icons back to normal. I realized also another mystery that having "large icons" is why custom icons from a website disappear but that I dont care about. 

    Monday, March 31, 2008 2:37 PM
  • The uninformed and unenlightened masses thank you for your simple fix.  I know you posted it almost a year and a half ago - some of us are slow.  Works good.  Way to go, Mary!

    Saturday, April 26, 2008 8:19 AM
  • I have found this works:

    Right click where you want the web shortcut.
    Go to new, select shortcut
    Navigate to the web browser of your choice.  Firefox users may have seen that this "IE bug" also prevents firefox shortcuts from changing icons.
    After choosing the web browser, add a single space after the closing ", then copy(or type) the web page address you want the browser to open when it is launched.
    Finish creating the shortcut, then right-click on it, and change the icon as you normally would.
    This works when you check off the "use large icons" box, or increase your icon size above 46 in the advanced settings.

    Sunday, April 27, 2008 7:42 PM
  •  Fluster_Cluck_Chickie wrote:

    Try changing your icon size.  It worked for me.  I wasn't getting any shortcut icons either.  What I noticed was under my husband and daughters profiles,  the shortcuts worked just fine.  They used standard sized icons.  I was using large icons.  When I changed the size, all my custom icons were restored. 

     

    Properties------>Appereance-------->Effects------->Make sure large icons is not checked 

    Sunday, May 04, 2008 7:29 AM
  • I was having the same problem as everybody else, and I did this adjustment described and it works fine.

    Thanks a lot,

    Regal

    Sunday, May 04, 2008 7:00 PM
  •  Howard39 wrote:

    Here is a workaround:

    Create a new desktop shortcut (not an IE shortcut) -- rt click on desktop, click New, click Shortcut

    For the target, enter "C:\Program Files\Internet Explorer\iexplore.exe" http://www.sitename.com

    Change the icon

    I've scoured the internet for a workaround that will allow the use of large custom icons and I've finally found my holy grail! For those of you who use firefox 99% of the time and just keep IE7 installed for occasional use, this workaround functions equally well as "C:\Program Files\Mozilla Firefox\firefox.exe" http://www.sitename.com

    Great one, Howard!
    Sunday, June 29, 2008 4:47 PM
  • I had this problem over & over.  Fluster is right.  I changed my icon size to 45 and everything came back.  Go to desktop properties, appearance, advanced, and choose icon in the drop down options.  I found that 45 always works for my web icons.  Can't believe this was so simple.

    Thursday, July 10, 2008 1:47 PM
  •  

    I found that choosing "Use Large Icons" in the Effects page of the Display Properties does make all icons default to that awesomely bland IE7 icon BUT.........if you right click the desktop, choose Properties which opens the Display Properties, click Appearance then click Advanced, open the ITEM menu, scroll down to Icon and change the SIZE you can have whatever size icons you want and you will have the customized icons, not the generic.  I had to figure this out after coming home from an afternoon away and my computer had taken it upon itself to make a number of changes it refused to reverse for me. I keep saying I'm going to try Linex but I'm hopelessly addicted to Microsoft's bells and whistles.

     

    I've instructed in detail because there are lot's of green computer users that don't easily know their way around their computers and detailed instructions save them a lot of frustration trying to find what WE WHO KNOW are talking about. LOL

     

    There is almost always some deeply buried, waiting to be discovered way to get around the frustrating and pointless restraints that Microsoft builds into all their "new and improved" features.

    Sunday, August 17, 2008 6:51 PM
  • I found that choosing "Use Large Icons" in the Effects page of the Display Properties does make all icons default to that awesomely bland IE7 icon BUT.........if you right click the desktop, choose Properties which opens the Display Properties, click Appearance then click Advanced, open the ITEM menu, scroll down to Icon and change the SIZE you can have whatever size icons you want and you will have the customized icons, not the generic.  I had to figure this out after coming home from an afternoon away and my computer had taken it upon itself to make a number of changes it refused to reverse for me. I keep saying I'm going to try Linex but I'm hopelessly addicted to Microsoft's bells and whistles.

     

    I've instructed in detail because there are lot's of green computer users that don't easily know their way around their computers and detailed instructions save them a lot of frustration trying to find what WE WHO KNOW are talking about. LOL

     

    There is almost always some deeply buried, waiting to be discovered way to get around the frustrating and pointless restraints that Microsoft builds into all their "new and improved" features.

    Sunday, August 17, 2008 7:02 PM
  • Hi, I experienced the same problem. However, I could change the Icon back to my desired one, which seemed not be possible according to the things which were mentioned later on. However, just go to properties and set the link to Read-only. It works so far fine with my IE7.
    Thursday, August 21, 2008 1:12 AM
  • What I think you're asking about are customized desktop icons for URLs.  These are not favicons, which are the small icons that appear in the browser address bar before http://.  Yes, something got changed between IE6 and IE7.  Try this to fix:


    Step 1:
          Click on the "Start" tab then go to Control Panel. On the upper left side, click on "Switch To Classic View
        
          Step 2:
          Go to "Display" and the Display Properties box will open. Select the "Appearance" tab, then the "Effects" button amd uncheck  the first box that reads, "Use Large Icons."

          Step 3:
          Click the "Advanced" button and choose "Icons" from the "Items" dropdown menu'

          Step 4:
          Set the size to a number less than 48 but larger than 32.  If you select 48 or larger, the effects setting will default to "use large icons".  

          I don't know why it works this way and given up trying to figure it out.

    Sare1
    Thursday, August 21, 2008 3:16 AM
  •  

    Great tips!Helped me a lot!Thanks for sharing!


    Make Money With Free Blog

    Saturday, August 23, 2008 9:50 AM
  •  

    I have found the answer to the everchanging internet shorcuts with the default icon on it, it occured to me that the issue was in security and so I added URL of the desktop internet shorcut to my " trusted sites" in the IE control panel, and whalla all is back to normal.

     

    Enjoy

     

    CBR

    Saturday, September 27, 2008 11:17 PM