none
IE8 is not deleting history

    Question

  • I found this a few weeks after installing IE8 Beta 2. When I choose "Delete history" it deletes it only from history window, but when I start typing URL in adress bar, it shows me viewed web-sites. It means, that IE is not deleting history. Only hides it from history window. It's a bug (I hope) or a "feauture"?

    Wednesday, November 12, 2008 6:03 PM

All replies

  • Well... No messages((( And I still can't delete history from address bar(((

     

    Tuesday, November 18, 2008 4:06 PM
  • I have run into the same issue and so far not been able to find a solution.  I will keep trying and let you know if I come across a fix. 

    Tuesday, December 02, 2008 7:37 AM
  • Try

     

    Tools

    Internet Options

    Content

    AutoComplete

    Settings

     

    Uncheck 'Forms'

     

    Tell me how you get on?

     

    • Proposed as answer by Tenorsax69er Saturday, July 25, 2009 6:58 PM
    Wednesday, December 03, 2008 10:00 PM
  • It's already uncheked. Even third-party utilities can't delete history from adress bar.

    Thursday, December 04, 2008 1:27 PM
  • uncheck: gone
    re check: come back again

    i m using XP version and i found that win 7 ver is ok
    Wednesday, April 01, 2009 7:49 AM
  • I just installed the final release version of Internet Explorer 8 through the Windows Update and the problem you specified months ago with the beta version still persists now even with the final version.  There doesn't seem to be a way of deleting search history in the upper-right search bar, other than to individually delete them with the "X" mark appearing beside each search term.  The problem is, I don't want to have to keep doing this every time for every search item.  I just don't want it to save the history, period.  The Autocomplete settings do delete the history on the main url address bar but it doesn't seem to have any effect on the search bar to the right of it.   I've tried everything.  This is most likely a bug but I'm surprised they haven't done anything about it since months ago with the beta release...

    Friday, May 01, 2009 9:47 PM
  • Try

     

    Tools

    Internet Options

    Content

    AutoComplete

    Settings

     

    Uncheck 'Forms'

     

    Tell me how you get on?

     

    This was close but not quite right. Instead of Forms, I checked/unchecked the "Browsing History" in the sub-menu for the "Address Bar" box and it cleared it all up.
    • Proposed as answer by midgetmac Tuesday, January 03, 2012 1:55 AM
    Saturday, June 06, 2009 7:26 PM
  • This worked for me. Cleared up any old URL addresses. Thanks. Microsoft should really look into this issue.
    Saturday, July 25, 2009 6:59 PM
  • have same problem and yes above does hide them but out of curiousity i switched autocomplete back on ticked the boxes and all the adresses came back so is not a complete fix
    john
    Wednesday, August 05, 2009 11:28 PM
  • There is a box "use windows search for better results" above the forms box you mentioned. I think this is something to do with it but I am lost cos tho it can be made to not display them but if someone just rechecked the boxes it comes back.
    It seems to be just some adreses cos deleting thro internet options deletes the most recent ones but some just stay behind. could it be someting to do with windows keeping them somehow?
    john
    Wednesday, August 05, 2009 11:40 PM
  • just use firfox way better save you fixing all these problems lost my whole sunday doing it.
    Sunday, August 09, 2009 2:59 PM
  • If you are still reading to find the solution it seems all common ways to delete history didn't worked for you as it didn't for my history.
    So:
    1)GO TO Control Panel\System and Maintenance
    2)OPEN Modify Index Locations
    3)SELECT Internet Explorer History
    4)CLICK Advanced button
    5)CLICK Restore To Default
    6)RESTART your computer.

    TA TA:):)

    Wednesday, November 11, 2009 3:04 AM
  • go to tools>internet options>Content>AutoComplete>Settings>uncheck Browsing History and/or AutoComplete...This will disable the history bar altogether. Pretty sure this is a ie8 Glitch. When you re-check the browsing history box back certain sites will stay in the history drop down...Usually the sites you want no one to see too....Hahaha...maybe it comes from those sites???
    Wednesday, November 11, 2009 8:29 AM
  • wizzzkiddd got it, go to tools>internet options>Content>AutoComplete>Settings>uncheck Browsing History and/or AutoComplete...
    it worked, although they're probably not really gone you can at least not see them with browsing history unchecked.
    Sunday, December 06, 2009 3:03 PM
  • or we could all just stop watching ____ until the problem gets fix! =D
    Saturday, December 12, 2009 8:04 PM
  • To delete browser history in IE8 click the Adjust Toolbar options <wrench icon> clear the box next to "Store search history on my computer" then click "Save". 

    To clear history, but continue to save history just go back to the Adjust Toolbar options <wrench icon>, put a check back into the box next to "Store search history on my computer", then click "Save". 

    Tuesday, December 15, 2009 7:12 PM
  • Go to www.filehippo and download a app called CClearner (it is free) and run it and your history will be gone!  You can pick from a menu what you want to delete.  You will be ask to analyze first.   Hope this helps...i worked for me when nothing else would. 
    Friday, January 15, 2010 12:40 AM
  • This worked for me... and I went back after and put it back on and then when I wrote something in the search and then shut off my browser and turned it back on my Clear History link was back in the search bar at the bottom so I can delete history again...

    Thanks this worked perfect.... everything mentioned above your post did not work but doing what you said worked big time...

    So to add just a bit to what you have above.....

    THIS WORKS:

    To delete browser history in IE8 click the Adjust Toolbar options <wrench icon> clear the box next to "Store search history on my computer" then click "Save". 

    To clear history, but continue to save history just go back to the Adjust Toolbar options <wrench icon>, put a check back into the box next to "Store search history on my computer", then click "Save".  After you do this when you search something and turn your browser off and then go back ... what you searched will be there but this time there will be a Clear History Link :)

    Saturday, January 16, 2010 1:11 AM
  • I think there is confusion about which search bar this thread was originally talking about.  If you have IE8 installed, there is a Google search bar (or it can be another search engine that you can configure) that appears on the top-right corner (beside the url address bar).  This is the search that is causing all the controversy and still no fix as far as I know (except manually deleting each search term by pressing the 'X' that appears next to each).  This is no wrench icon associated with this search.

    The search that people seem to be confusing this with is the Google search located on the Google Tool bar (if you've installed it).  I never installed this Google Tool bar until recently.  So now that I have installed it, I can see what people are talking about and the wrench icon that people have been talking about that I had never seen before.  So for me, I now have 2 Google search bars, one at the top-right that comes with IE8 and the other that comes with Google Tool Bar.  The search bar located on the Google Tool bar is NOT the same as the one on the top-right.   The one on the top-right is the one remembering every search term and is associated with IE8.  The search on the Google Tool bar looks relatively easy to configure and does not even show my history of searched terms.  So these are 2 different search boxes and you should explain which one you're talking about when you're posting...
    Sunday, January 17, 2010 11:24 PM
  • How I cleared the history in google search box:

    LOGGED IN to GOOGLE (gmail address)

    click MY ACCOUNT

    click WEB HISTORY

    click REMOVE ITEMS

    Then there was an option to clear all web history
    It turned off the "service" that collects web history (I was amazed at what I found and how far back it dated)
    Now the search box functions as it used to... it shows history but also has the CLEAR HISTORY link.

    Friday, January 22, 2010 1:03 PM
  • tnks... it's working :)
    Friday, April 02, 2010 6:13 AM
  • OK GUYS I NO THE PROBLEMS SORRY FOR CAPS

     

    THE PROBLEM IS YOUR ANTI VIRUS WHEN YOU RUN SCANS IT SHOULD SAY CLEAR HISTORY INTERNET TEMPORY CLEANUP NETWORK ADRESS AND ECT..

     

    DO THAT YOU DONT NEED TO DO VIRUS CHECK YOU CAN CHOOSE I GOT NORTAN ANTI 360 SO YEA

    • Proposed as answer by conairrr Sunday, April 11, 2010 10:41 PM
    Monday, April 05, 2010 7:42 AM
  • Hello everyone:

    After a long battle with Windows Internet Explorer 8, I figured out the way to Delete the history completely. You do not need to restart your computer in SafeMode or anyother software. All you have to do is,

    1        Close all the windows and open only one Internet Explorer window and click on tools and go in options, or you can to go Start Menu and click Control Panel and access Internet Options. Whatever makes you happy!

          Tools > Internet Options

    2        Locate the Browsing History and click on Browsing History Settings. Temporary Internet Files and History Settings window will appear, and in the “Click for newer versions of stored pages” option select Never.

     “Browsing History” Setting> Temporary Internet Files> Never

    3        Click on View files, which will take you to all the files. Select all the files by using Ctrl + A, and delete all of them at once by using Shift + Del. And after that Press OK and exit from the Internet Options.

    View files> Select all files and delete them> OK

                Steps below are very important.

    4        To go Tools again and click on Internet Options.

     Tools> Internet Options

    5        In the Internet Options tab, you will see different options, starting with General, Security, Privacy, Content, etc. Click on Content and go to the AutoComplete column, and click on Settings. In the AutoComplete Settings Uncheck everything, and make sure nothing is left with a check mark and then click on Delete AutoComplete history…, and Delete Browsing History window will pop-up. Make sure that all options are checked here, which are Preserve Favorite Website Date, Temporary Internet Files, Cookies, History, Form Date, Passwords and InPrivate Filtering Data.

    Internet Options> Content> AutoComplete> Settings> Uncheck all> Delete AutoComplete history…> Check all boxes> Delete> OK.

     

    6        Delete all and Press OK to exit. Restart your Internet Explorer and you will see that this will take care of all the History issues that most people are having with Internet Explorer 8. Please, let me know if this helps.

    Thank you.

    Syed

    • Proposed as answer by Syeali2 Wednesday, August 25, 2010 7:47 AM
    Wednesday, August 25, 2010 7:46 AM
  • Wow, Syed, thank you so much.  I've been trying for weeks to fix this problem.  I tried everything else on this page (except for mhardworking's suggestion) but after following your instructions word for word, my IE 8 browser history is finally totally cleared.  After I did everything you stated, I closed and restarted my IE 8 browser a couple of times and even after I put all my settings back to how they were before I carried your instructions out, my internet explorer history and autocomplete history were still cleared, exactly how I wanted it.  Thanks again!!!!!!
    Sunday, September 05, 2010 5:15 AM
  • omg this is so weird.  Yesterday, I thought this problem was solved.  All the history was gone.  There was nothing left.  Even after restoring the settings to what they were before following Syed's instructions.  Then today I clear my history again just to make sure one more time that it is clear.  And when I do that the pages that I have been trying to delete for weeks, pages that I have not even visited for weeks including yesterday and today, reappear in the address bar.  I have no idea why this webpages show up with autocomplete when yesterday they did not and I have not even visited them for weeks.  I guess I'll try mhardworking's suggestion. 
    Monday, September 06, 2010 12:17 AM
  • If you are still reading to find the solution it seems all common ways to delete history didn't worked for you as it didn't for my history.
    So:
    1)GO TO Control Panel\System and Maintenance
    2)OPEN Modify Index Locations
    3)SELECT Internet Explorer History
    4)CLICK Advanced button
    5)CLICK Restore To Default
    6)RESTART your computer.

    TA TA:):)


    Worked for me - Thanks :)
    Wednesday, December 22, 2010 9:40 AM
  • This problem (IE8 not deleting history) seems to happen when IE8 history is included in Windows search index. To fix this:

    (1) Change IE8 setting to disable the AutoComplete feature:
    Internet Options > Content > AutoComplete > Settings > Use AuoComplete for > (uncheck all) > OK > OK

    (2) Delete all browsing history:
    Internet Options > Content > AutoComplete > Settings > Delete AutoComplete history... > (check all, except "Preserve Favorites website data") > Delete > OK > OK

    (3) Exit Internet Explorer 8

    (4) Remove Internet Explorer history from Windows Indexing service:
    Control Panel > Indexing Options > Modify > Change selected locations > (uncheck "Internet Explorer History") > OK

    (5) Rebuild the search index (otherwise the old index will continue to show the previously indexed AutoComplete information):
    Control Panel > Indexing Options > Advanced > Troubleshooting > Rebuild (this will take a long time to complete)

    After the index is rebuilt, the problem should go away (worked for my IE8 on Windows 7).

    NOTE: Do not re-enable the IE8 AutoComplete and Browser history features, otherwise the problem is likely to return (the indexing service will start including history / AutoComplete data again while automatically updating the index).

    • Proposed as answer by Ha Ch Tuesday, January 18, 2011 6:59 AM
    Sunday, December 26, 2010 11:06 PM
  • 'Forms' was automatically unchecked when I did this but I found that the solution worked when I followed the same steps but unchecked 'Browsing History' as well.

    Tuesday, January 03, 2012 1:56 AM