none
Object window.opener.location.href is malfunctioning in IE8

    Question

  • "Error: 'window.opener.location' is null or not an object" is what I get when I try to do the following javascript:

      var UrlAddonString =  "&JobExtensionSubmissionFlag=1&StringModsToPlacementRecord=An effective date of " + document.getElementById("CommissionEFDate").value + " has been added to the placement record.|";
      
      window.opener.location.href = window.opener.location.href + UrlAddonString;

    This worked perfectly fine in IE7, why does it not work in 8? 

    Wednesday, May 06, 2009 10:20 PM

Answers

  • The Answer:

    Under the Security Tab in your internet options, click on the Trusted Websites Icon.  Now check the checkbox marked "Enable Protected Mode" and restart internet explorer.

    (in this example please keep in mind that the website in question was a Trusted Website)

    EVERYTHING WILL MAGICALLY WORK!!! 

    WOOT WOOT WOOT.

    • Marked as answer by NighterSmiter Friday, May 29, 2009 10:18 PM
    Friday, May 29, 2009 10:18 PM

All replies

  • there is one person in my office that has IE8 on his machine and he does not have this problem...  This is VERY frustrating....  All windows updates have been downloaded and installed.  Java is fully updated.  I have tried viewing the page in compatability mode but still no dice.  I tried resetting all of the internet explorer settings as well...  Any professional advice at this point would be greatly appreciated!  I cannot imagine that Javascript objects would suddenly stop working with an update like this, I am thinking this issue must be a security setting of some kind.  ANYWAY, PLEASE HELP!!!!!
    Thursday, May 07, 2009 4:41 PM
  • The Answer:

    Under the Security Tab in your internet options, click on the Trusted Websites Icon.  Now check the checkbox marked "Enable Protected Mode" and restart internet explorer.

    (in this example please keep in mind that the website in question was a Trusted Website)

    EVERYTHING WILL MAGICALLY WORK!!! 

    WOOT WOOT WOOT.

    • Marked as answer by NighterSmiter Friday, May 29, 2009 10:18 PM
    Friday, May 29, 2009 10:18 PM
  • check the checkbox marked "Enable Protected Mode"  ..i cant find that option..pls help..thank
    Thursday, August 06, 2009 4:57 AM
  • Did you ever get this resolved?

    Monday, June 14, 2010 3:13 PM
  • yes, this issue is resolved.  Note that the Checkbox labeled "Enable Protected Mode" is in Tools>Internet Options>Security Tab

    and you need to have clicked on "Trusted Sites" and then check the checkbox at the bottom of the interface for "Enable Protected Mode"

    This checkbox is on the Security Tab toward the bottom and is easy to find.

    Thanks guys, I have a knack for solving my own problems - but when I do I will still post my findings here in case someone decides that they might be useful.

    Monday, June 14, 2010 4:31 PM
  • yes, this issue is resolved.  Note that the Checkbox labeled "Enable Protected Mode" is in Tools>Internet Options>Security Tab

    and you need to have clicked on "Trusted Sites" and then check the checkbox at the bottom of the interface for "Enable Protected Mode"

    This checkbox is on the Security Tab toward the bottom and is easy to find.

    Thanks guys, I have a knack for solving my own problems - but when I do I will still post my findings here in case someone decides that they might be useful.


    Can you please post the solution to this problem. I am facing the same issue and still not resolved.
    Wednesday, June 23, 2010 12:55 PM
  • Protected mode is only available on Vista or above. Unfortunatley, I too am having this error - on an XP IE8 machine.

    http://msdn.microsoft.com/en-us/library/bb250462(VS.85).aspx

    Tuesday, July 13, 2010 11:53 PM
  • In IE8 on Windows XP,

    Internet Options --> Security tab --> Custom level --> Enable Navigate windows and frames across different domains

    • Proposed as answer by Carlsl Wednesday, February 22, 2012 2:48 PM
    Wednesday, February 22, 2012 2:48 PM
  • Hi,

    I am facing the same issue. and the proposed solution i.e to enable protected mode works. But I cant ask users to change the security settings everytime they access my application. Is there any way i can programmatically  solve this issue or is there a work around for window.opener null issue?

    Thanks,

    Remya


    Friday, July 20, 2012 10:09 AM
  • Can this issue be resolved pragmatically? Can i handle this by providing any alternate for window.opener?

    Friday, July 20, 2012 10:11 AM
  • Hi,

    without a link to your website or a publicly accessible mashup that shows the issue we cannot help you.

    see http://blogs.msdn.com/b/ieinternals/archive/2012/04/03/explaining-same-origin-policy-part-2-limited-write.aspx


    Rob^_^

    Friday, July 20, 2012 8:35 PM