none
iexplorer old versions. why?

    Diskusi Umum

  • Hi all.

    Talking about browser compatibility, you never hear about Chrome 7,8,9; Firefox 7,8,9; Opera 7,8,9; etc.

    Why IExplorer has to be always a 'pain in the butt'?

    I think is a must to have an Auto-silent-update functionality on IE so everybody around the world would use always the last IE version, like other major browser do.

    That would save lots of headaches to all web developers around. Don't you think?

    Sounds absurd that I must modify all my code because IE 8 doesn't accept for example:

    span:last-of-type{}

    Regards.


    30 Mei 2013 16:37

Semua Balasan

  • Hola Iván.

    En primer lugar, discrepo contigo en cuanto a las versiones porque sí que he oído hablar siempre de versiones con Firefox y con Opera. Chrome sí que se salta un poco esta incidencia, pero Firefox no se auto-actualizaba de la versión 3 a la 3.5 ni a la 4 ni a la 5...

    En segundo lugar, hay una gran diferencia entre IE y el resto de navegadores. En sus inicios, IE venía integrado con el sistema y en la actualidad seguramente sigue usando funciones del sistema. Esto hace que no sea del todo posible actualizarlo sin haber actualizado antes el sistema y, para eso está Windows Update, esa gran herramienta que todo el mundo desactiva o a la que no le hace caso.

    Por lo tanto, ¿el IE se actualiza silenciosamente? Pues sí, si tienes activado Windows Update de forma silenciosa.

    En tercer lugar, esto que estás intentando usar es parte de CSS3 con lo que, sin hacer nada no te va a funcionar. Pruébalo con versiones anteriores de Chrome, Firefox, Opera, Safari, Konqueror,... a ver si funciona... Porque hay gente que desactiva las actualizaciones de sus navegadores ¿Soluciones para que funcione tu página en navegadores antiguos (pero no tanto)?

      • No usar CSS3 (Impensable hoy en día)
      • Aconsejar y casi obligar a los usuarios a que actualicen sus navegadores y sistemas operativos (puedes con unos pocos pero no con todos)
      • Usar Modernizr u otros sistemas similares. Con sólo agregar la referencia a Modernizr (tiene CDN) los usuarios con navegadores antiguos disfrutarán de una experiencia similar a la de los usuarios con navegadores actuales.

    "En los momentos de crisis, sólo la imaginación es más importante que el conocimiento"
    MCTS | SharePoint 2010, Application Development
    MCTS | SharePoint 2010, Configuring
    MS | Programming in HTML5 with JavaScript and CSS3 (MS), Developing ASP.NET MVC 4 Web Applications
    Twitter | @saintwukong

    30 Mei 2013 20:57
  • Hola Santiago.

    Supongo que lo que marca la diferencia es que quien usa Firefox , Chrome, etc. suele "preocuparse más" por su navegador que quien navega con IE porque viene de serie en Windows, por eso los primeros están siempre actualizados.

    Pero es que me parece ridículo tener que desarrollar pensando en IE8 y no en Chrome 5!

    Parte de lo que no entiendo de IE es que esté, como dices, tan vinculado al sistema. ¿Por qué tiene que ser así? ¿No pueden hacer un navegador independiente y punto? Además, resulta que el amado XP no es compatible con IE de 9 en adelante.

    Con esto, no basta con animar al usuario a actualizar su navegador, sino el Sistema Operativo entero! (como bien dices también)

    Claro, hay que vender.

    Por lo demás, le echaré un vistazo a Modernizr. Gracias.

    Un saludo.


    07 Juni 2013 9:41
  • Buenas de nuevo Iván.

    Cierto es que IE6 no cumplía los estándares y también es cierto que IE10 es el que más los cumple. IE8 es el que marca el cambio a las nuevas tecnologías en uso. Como ya te comenté, no tiene sentido que tengas instalado IE8 a no ser que tengas Windows XP pero... ¿tiene sentido tener Windows XP? Yo creo que no, de hecho, cuando he visto algún Windows XP en algún ordenador, le he dado un toque de atención al usuario porque no puede pretender acceder a las nuevas aplicaciones y nuevos contenidos en internet usando un sistema operativo al que ya no se le da soporte.

    Que los usuarios que usan chrome o firefox están más preocupados por su navegador es totalmente erróneo. Los usuarios de forma general no se preocupan por sus navegadores, de hecho, ni sabrán qué versión tienen.

    La vinculación con el sistema no tiene por qué significar que IE no sea un navegador independiente. De hecho, la versión europea de Windows se distribuye de tal forma que te permita seleccionar el navegador que desees durante la instalación del sistema operativo. La vinculación reside en que históricamente se usaban elementos del propio sistema operativo para mejorar el rendimiento, acoplarlo más, que fuera más ligero,... Hoy en día ya no está nada clara esta vinculación, pero aún así, la actualización de IE puede pasar por Windows Update porque mejorar el sistema es mejorar la experiencia de IE y porque es una aplicación de Microsoft. ¿Por qué tener 20 servicios de actualización de software cuando lo puedes pasar todo por el mismo? ¿Por qué tengo que tener adobe updater, google updater,... quitándome recursos del sistema que necesito para trabajar?


    "En los momentos de crisis, sólo la imaginación es más importante que el conocimiento"
    MCTS | SharePoint 2010, Application Development
    MCTS | SharePoint 2010, Configuring
    MS | Programming in HTML5 with JavaScript and CSS3 (MS), Developing ASP.NET MVC 4 Web Applications
    Twitter | @saintwukong

    07 Juni 2013 10:07
  • Hola Santiago.

    Reconozco que quizá sí que empieza a ser un poco exagerado remontarse a IE8. No será sólo mi web la que verán mal esos usuarios, por lo tanto más les vale actualizarse. Y más viendo el precio "ridículo"que cuestan hoy día los equipos.

    Con lo de los usuarios de otros navegadores me refiero a que si los instalan es porque buscan alternativas al IE de serie, y por eso mismo les gustará estar a la última. Por otro lado, conozco gente que aún no entiende lo que es un navegador, y piensan que internet es Google, o que para ir a una página hay que pasar siempre por Google (sí, yo también me reí, jeje).

    Mi crítica a IE viene también por los comentarios (a veces de guasa y a veces rabiosos) que veo por los foros refiriéndose a su falta de compatibilidad. Pero sí, cierto es que pueden ser comentarios antiguos, pues como bien dices, actualmente se respeta el estandar.

    En fín , que si por un lado IE cumple el estándar y por otro se permite elegir navegador al instalar el SO, me tengo que callar. Y eso sí, añadir un gran <h1> en mis webs que invite a ¡actualizarse! en caso de usar IE8-.

    Un saludo, ha sido un constructivo placer.

    07 Juni 2013 11:40
  • Iguelmente Iván.

    Ha sido todo un placer tener este minidebate constructivo :o)


    "En los momentos de crisis, sólo la imaginación es más importante que el conocimiento"
    MCTS | SharePoint 2010, Application Development
    MCTS | SharePoint 2010, Configuring
    MS | Programming in HTML5 with JavaScript and CSS3 (MS), Developing ASP.NET MVC 4 Web Applications
    Twitter | @saintwukong

    07 Juni 2013 12:01