none
Echec de l'opération Invoke "CreateUser". Le serveur distant a retourné une erreur : NotFound

    Discussion générale

  • Bonjour,

    J'ai créé un projet "Business Application" sans y toucher une seule ligne, sauf bien sûr le ficher web.config.

      <connectionStrings>	
    	<remove name="ApplicationServices" />  
    	<add name="ApplicationServices" connectionString="data source=SRV-SQL002\SQLMUTU;Integrated Security=False;Persist Security Info=True;User ID=********; Password=********;User Instance=False" providerName="System.Data.SqlClient" /> 
      </connectionStrings>

    Ensuite j'ai importé ma base de données dans "sql server management studio" pour pouvoir l'exporter au format .bak (backup) car c'est le seul moyen qu'on me donne chez OVH pour importer une base de données existante.

    Aucun problème a ce niveau là, car j'arrive très bien a m'identifier avec le compte que j'ai précédemment créé en local.

    Néanmoins, il met impossible de créer un nouveau compte sur le serveur (OVH).

    Il me retourne cette erreur : échec de l'opération Invoke "CreateUser". Le serveur distant a retourné une erreur : NotFound

    Est-ce mon fichier web.config qui ne convient pas ?

    Ou est-ce mon fournisseur qui a oublié de paramétrer quelque chose, car ce n'est pas la première fois ?

    Pourriez-vous m'aider ?

    D'avance merci.


    jeudi 26 avril 2012 19:31

Toutes les réponses

  • Bonjour,

    Cette erreur peut provenir de différentes raisons :

    - Problème de communication entre votre serveur et votre application Silverlight.
    - Une erreur côté serveur dans le serveur CreateUser().

    Pour trouver d'où vient l'erreur, essayer de loguer les traces WCF : http://msdn.microsoft.com/en-us/library/ms733025.aspx.

    Ainsi, vous verez l'exception qui est déclenché côté Silverlight.

    Cordialement


    Gilles TOURREAU - MVP C#
    Architecte logiciel/Consultant/Formateur Freelance
    Blog : http://gilles.tourreau.fr
    - MCPD : Enterprise Developper / Windows Developper 3.5 / ASP .NET 3.5/4.0
    - MCITP : SQL Server 2008 Developper
    - MCTS : ADO .NET 3.5 / SQL Server 2008 Developper / Windows Forms 3.5 / ASP .NET 3.5/4.0

    vendredi 27 avril 2012 09:49
    Modérateur
  • Je n'y comprends plus rien !!!

    Encore merci pour ton aide.

    J'ai fait ce que tu m'as demandé de faire.

    Pas d'erreur, juste des warning concernant :

        <modules runAllManagedModulesForAllRequests="true">
          <add name="DomainServiceModule" preCondition="managedHandler"
              type="System.ServiceModel.DomainServices.Hosting.DomainServiceHttpModule, System.ServiceModel.DomainServices.Hosting, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
        </modules>

    De plus je n'arrive pas à récupérer le fichier Traces.svclog depuis mon server OVH !

    J'ai pu le faire une fois, après impossible.

    Sinon, j'ai pu insérer dans ma base de données un champ via un script aspx !

    Que dois je faire si c'est une erreur côté serveur dans le serveur CreateUser() ?

    D'avance merci


    vendredi 27 avril 2012 15:47
  • Bonjour,

    De plus je n'arrive pas à récupérer le fichier Traces.svclog depuis mon server OVH !
    Vous n'avez pas accès au votre trace via un accès FTP ? Si vous n'avez pas accès à ce fichier, vous ne pourrez pas logguer votre application et vous serez complètement aveugle...

    Cordialement


    Gilles TOURREAU - MVP C#
    Architecte logiciel/Consultant/Formateur Freelance
    Blog : http://gilles.tourreau.fr
    - MCPD : Enterprise Developper / Windows Developper 3.5 / ASP .NET 3.5/4.0
    - MCITP : SQL Server 2008 Developper
    - MCTS : ADO .NET 3.5 / SQL Server 2008 Developper / Windows Forms 3.5 / ASP .NET 3.5/4.0

    lundi 30 avril 2012 06:47
    Modérateur
  • Salut,

    As-tu réussi à trouver d'où venait le problème?

    Je suis aussi chez OVH et j'ai le même message d'erreur...

    Eric

    vendredi 19 juillet 2013 08:20